IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Debian Discussion :

modification paramètres wifi et redémarrage service


Sujet :

Debian

  1. #1
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    février 2008
    Messages
    6 944
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 6 944
    Points : 17 906
    Points
    17 906
    Par défaut modification paramètres wifi et redémarrage service
    Bonjour,

    j'ai une machine sous Buster, et
    quand j'entre cette commande
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    vim /etc/network/interfaces && systemctl restart networking ; ip address show dev wlp7s0
    l'interface wifi est "déconfigurée", et DOWN, mais ne prend jamais les nouveaux paramètres; pour l'instant je dois redémarrer la machine (ce n'est pas propre).

    qu'est-ce que je ne fais pas correctement ? qu'est-ce que j'oublie ?
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  2. #2
    Expert éminent sénior Avatar de disedorgue
    Homme Profil pro
    Ingénieur intégration
    Inscrit en
    décembre 2012
    Messages
    3 990
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur intégration
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : décembre 2012
    Messages : 3 990
    Points : 11 764
    Points
    11 764
    Par défaut
    Hello,

    Faut peut-être que tu recharges ton driver wifi ...

    (https://debian-facile.org/viewtopic.php?id=26501)
    Cordialement.

  3. #3
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    février 2008
    Messages
    6 944
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 6 944
    Points : 17 906
    Points
    17 906
    Par défaut
    a priori, non :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    07:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
            Subsystem: Foxconn International, Inc. AR9285 Wireless Network Adapter (PCI-Express)
            Flags: bus master, fast devsel, latency 0, IRQ 16
            Memory at d5200000 (64-bit, non-prefetchable) [size=64K]
            Capabilities: <access denied>
            Kernel driver in use: ath9k
            Kernel modules: ath9k
    si ça peut aider...
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  4. #4
    Expert éminent sénior Avatar de disedorgue
    Homme Profil pro
    Ingénieur intégration
    Inscrit en
    décembre 2012
    Messages
    3 990
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur intégration
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : décembre 2012
    Messages : 3 990
    Points : 11 764
    Points
    11 764
    Par défaut
    Juste comme ça, as-tu essayer un passage en mode avion puis retrait de celui-ci ?

    Car chez moi, lorsque je sors du mode veille, dés fois je dois faire ça pour que celui-ci refonctionne...
    Cordialement.

  5. #5
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    février 2008
    Messages
    6 944
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 6 944
    Points : 17 906
    Points
    17 906
    Par défaut
    comment on gère le mode avion en ligne de commande ?
    et pourquoi penses-tu que ça peut être lié à un souci de sortie de veille ?

    c'est vrai que je n'ai pas détaillé la situation.

    mon ordi portable est allumé, et connecté à un modem 4G (prêté par SFR pour compenser une défaillance de connexion de la fibre )
    la connexion a été rétablie, et je voudrais me reconnecter à la box.
    pour faire ça, j'édite /etc/network/interfaces, et je redémarre le service networking. Ça me paraît suffisant, mais ça ne l'est pas.

    en prévoyance d'un éventuel nouveau problème, je voudrais basculer d'un modem à un autre sans avoir à redémarrer.

    EDIT: en passant par ifdown/ifup, j'arrive à reconfigurer l'interface, mais pas par systemctl.
    c'est bizarre, non ?
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  6. #6
    Responsable Systèmes


    Homme Profil pro
    Gestion de parcs informatique
    Inscrit en
    août 2011
    Messages
    15 554
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Gestion de parcs informatique
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 15 554
    Points : 37 527
    Points
    37 527
    Par défaut
    comment on gère le mode avion en ligne de commande ?
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    nmcli radio wifi on/off
    je suppose que ça doit pouvoir se faire aussi avec iwconfig

    la connexion a été rétablie, et je voudrais me reconnecter à la box.
    Il te faut donc changer de wifi, tu as bien lancé la commande iwcondfig ?

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    iwconfig  wlp7s0 SSID key s:ta_passphrase
    Si clé héxadécimale, retirer s:
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  7. #7
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    février 2008
    Messages
    6 944
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 6 944
    Points : 17 906
    Points
    17 906
    Par défaut
    bien sûr, il y a des contournements.
    je peux aussi passer par /etc/network/interfaces, puisque ça configure correctement l'interface au démarrage, mais pourquoi la modification n'est-elle pas prise en compte sans redémarrer ?
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  8. #8
    Expert éminent sénior Avatar de Flodelarab
    Homme Profil pro
    Inscrit en
    septembre 2005
    Messages
    4 873
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Charente (Poitou Charente)

    Informations forums :
    Inscription : septembre 2005
    Messages : 4 873
    Points : 12 312
    Points
    12 312
    Par défaut
    Bonjour

    Citation Envoyé par N_BaH Voir le message
    comment on gère le mode avion en ligne de commande ?
    Citation Envoyé par Internet
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    org.gnome.settings-daemon.plugins.rfkill active false
    Mais moi, si j'ai bien vu apparaître le mode avion avec les dernières mises à jour, ce schéma n'existe pourtant pas dans ma configuration de simple utilisateur non-root. Et la commande ne fonctionne pas chez moi.

    Une autre page d'info intéressante.
    Le problème est le même. Si root ne pointe pas son nez, est-on bloqué ?

    L'enquête continue.
    Cette réponse vous apporte quelque chose ? Cliquez sur en bas à droite du message.

  9. #9
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    février 2008
    Messages
    6 944
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 6 944
    Points : 17 906
    Points
    17 906
    Par défaut
    je n'utilise pas gnome, mais xfce4.
    et rfkill ne montre aucun blocage.
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

  10. #10
    Expert éminent sénior Avatar de disedorgue
    Homme Profil pro
    Ingénieur intégration
    Inscrit en
    décembre 2012
    Messages
    3 990
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur intégration
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : décembre 2012
    Messages : 3 990
    Points : 11 764
    Points
    11 764
    Par défaut
    Citation Envoyé par N_BaH Voir le message
    comment on gère le mode avion en ligne de commande ?
    et pourquoi penses-tu que ça peut être lié à un souci de sortie de veille ?

    c'est vrai que je n'ai pas détaillé la situation.

    mon ordi portable est allumé, et connecté à un modem 4G (prêté par SFR pour compenser une défaillance de connexion de la fibre )
    la connexion a été rétablie, et je voudrais me reconnecter à la box.
    pour faire ça, j'édite /etc/network/interfaces, et je redémarre le service networking. Ça me paraît suffisant, mais ça ne l'est pas.

    en prévoyance d'un éventuel nouveau problème, je voudrais basculer d'un modem à un autre sans avoir à redémarrer.

    EDIT: en passant par ifdown/ifup, j'arrive à reconfigurer l'interface, mais pas par systemctl.
    c'est bizarre, non ?
    Difficile à dire, networking appelle, entre autre, ifup -a qui ici, le -a n'est pas pour all mais pour les interfaces déclarées en auto. Donc je dirais que cela dépend de si tu as déclaré ton interface en auto ou pas.
    Cordialement.

  11. #11
    Modérateur
    Avatar de N_BaH
    Profil pro
    Inscrit en
    février 2008
    Messages
    6 944
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 6 944
    Points : 17 906
    Points
    17 906
    Par défaut
    mais bien sûr, auto !

    merci.
    .
    N'oubliez pas de consulter les cours shell, la FAQ, et les pages man.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [RedHat]Service docker ne prend pas en compte la modification du ulimit au redémarrage
    Par pierreJacquot dans le forum RedHat / CentOS / Fedora
    Réponses: 0
    Dernier message: 11/01/2016, 10h36
  2. Problème redémarrage service
    Par jagboys dans le forum MFC
    Réponses: 10
    Dernier message: 16/12/2008, 17h21
  3. Paramètres wifi non sauvegardé
    Par julien.63 dans le forum Ubuntu
    Réponses: 5
    Dernier message: 09/01/2008, 20h31
  4. paramètres out dans les services web
    Par adaneels dans le forum Delphi .NET
    Réponses: 1
    Dernier message: 11/04/2007, 10h14
  5. [XP Pro] Script modification paramètres réseau
    Par lidouka dans le forum Administration
    Réponses: 4
    Dernier message: 10/03/2007, 22h03

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo