IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Applications et environnements graphiques Discussion :

ImportError: /lib64/libSDL2-2.0.so.0: version ’V_2.0.22’ not found


Sujet :

Applications et environnements graphiques

  1. #1
    Membre à l'essai
    Homme Profil pro
    Sans emploi
    Inscrit en
    avril 2004
    Messages
    29
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 49
    Localisation : France, Vendée (Pays de la Loire)

    Informations professionnelles :
    Activité : Sans emploi

    Informations forums :
    Inscription : avril 2004
    Messages : 29
    Points : 22
    Points
    22
    Par défaut ImportError: /lib64/libSDL2-2.0.so.0: version ’V_2.0.22’ not found
    Bonjour à tous et à toutes.
    Pour aider une personne du forum francophone de darktable, je pose son problème ici.
    Il a l'erreur suivante :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    ImportError: /lib64/libSDL2-2.0.so.0: version ’V_2.0.22’ not found (required by /usr/local/lib64/python3.8/site-packages/libwx_gtk3u_core-3.1.so.5)
    Le fichier /lib64/libSDL2-2.0.so.0 est pourtant présent sur le système. Ils est sur GNU/Linux OpenSuse Tumbleweed.

    J'ai moi-même le même logiciel d'installé sur mon système (GNU/Linux Manjaro) et il fonctionne très bien. J'ai utilisé la même méthode d'installation du logiciel.

    J'ai posé la question sur le forum Python et on m'a dit que c'était un problème Linux.

    Y a-t-il quelqu'un qui peut aider pour résoudre ce problème ?
    Merci.
    Ignace.
    Mon site internet : La vue d' Ignace https://ignace72.eu

  2. #2
    Responsable Systèmes


    Homme Profil pro
    Gestion de parcs informatique
    Inscrit en
    août 2011
    Messages
    15 546
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Gestion de parcs informatique
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 15 546
    Points : 37 503
    Points
    37 503
    Par défaut
    Essayes de lancer :
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  3. #3
    Membre émérite Avatar de papajoker
    Homme Profil pro
    Développeur Web
    Inscrit en
    septembre 2013
    Messages
    1 382
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nièvre (Bourgogne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : septembre 2013
    Messages : 1 382
    Points : 2 924
    Points
    2 924
    Par défaut
    Je lui ai répondu, mais dans le premier sujet (pas vu celui-ci)
    $moi= ( !== ) ? : ;

  4. #4
    Membre à l'essai
    Homme Profil pro
    Sans emploi
    Inscrit en
    avril 2004
    Messages
    29
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 49
    Localisation : France, Vendée (Pays de la Loire)

    Informations professionnelles :
    Activité : Sans emploi

    Informations forums :
    Inscription : avril 2004
    Messages : 29
    Points : 22
    Points
    22
    Par défaut
    Bonjour.
    Il a fait un :
    Et cela n'a rien changé.

    papajoker, si tu regardes la capture d'écran suivante fourni par la personne, libSDL2-2.0.so.0 pointe bien vers libSDL2-2.0.so.0.22.0.

    Note : j'ai fait un machine virtuelle Virtualbox avec dessus OpenSuse Tumbleweed et je n'ai pas ce problème.
    Ignace.
    Mon site internet : La vue d' Ignace https://ignace72.eu

  5. #5
    Membre émérite Avatar de papajoker
    Homme Profil pro
    Développeur Web
    Inscrit en
    septembre 2013
    Messages
    1 382
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nièvre (Bourgogne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : septembre 2013
    Messages : 1 382
    Points : 2 924
    Points
    2 924
    Par défaut
    Citation Envoyé par ignace72 Voir le message
    Note : j'ai fait un machine virtuelle Virtualbox avec dessus OpenSuse Tumbleweed et je n'ai pas ce problème.
    Si pas de problème pour toi, cette personne est bien à jour ? Tumbleweed c'est du rolling et voir un message d'erreur avec python 3.8 ... on est à des années du rolling (ou il a plusieurs python sur sa machine et utilise le mauvais)
    $moi= ( !== ) ? : ;

  6. #6
    Membre à l'essai
    Homme Profil pro
    Sans emploi
    Inscrit en
    avril 2004
    Messages
    29
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 49
    Localisation : France, Vendée (Pays de la Loire)

    Informations professionnelles :
    Activité : Sans emploi

    Informations forums :
    Inscription : avril 2004
    Messages : 29
    Points : 22
    Points
    22
    Par défaut
    Ben oui, il est bien à jour, c'est une des premières choses qu'on lui a demandées.
    J'ai regardé sur ma machine virtuelle, quand je regarde le « À propos », il est indiqué aussi Python 3.8. Je ne sais pas comment ils conçoivent les versions continues chez Suse, mais c'est bizarre.
    Mais il y a une chose à savoir, c'est qu'avec OpenSuse, on peut avoir plusieurs versions de Python installé sur la même machine.
    Ignace.
    Mon site internet : La vue d' Ignace https://ignace72.eu

  7. #7
    Membre émérite Avatar de papajoker
    Homme Profil pro
    Développeur Web
    Inscrit en
    septembre 2013
    Messages
    1 382
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nièvre (Bourgogne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : septembre 2013
    Messages : 1 382
    Points : 2 924
    Points
    2 924
    Par défaut
    Citation Envoyé par ignace72 Voir le message
    Je ne sais pas comment ils conçoivent les versions continues chez Suse, mais c'est bizarre.
    la lib en erreur c'est un module python lié à wxgtk3 3.1 ? ici et avec arch nous avons encore la version 3.0.5 (de 2020) pour wxgtk3 donc chaque rolling fait ces choix plus ou moins conservateurs.
    peut-être une incompatibilité de version entre le module python "wxpython?" et wxgtk3 ?

    Étrange (pour moi) que chez toi, le soft fonctionne avec la même distribution.
    Note: Oui, avoir plusieurs python n'est pas rare.
    $moi= ( !== ) ? : ;

  8. #8
    Membre à l'essai
    Homme Profil pro
    Sans emploi
    Inscrit en
    avril 2004
    Messages
    29
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 49
    Localisation : France, Vendée (Pays de la Loire)

    Informations professionnelles :
    Activité : Sans emploi

    Informations forums :
    Inscription : avril 2004
    Messages : 29
    Points : 22
    Points
    22
    Par défaut
    Est-ce à cause du fait que chez moi, je suis en machine virtuelle ?
    Je n'ai pas eu de retour de quelqu'un qui aurait testé ma procédure sur un PC avec OpenSuse Tumbleweed, c'est vrai que c'est tout neuf.
    Pour info ma procédure est ici : https://ignace72.eu/displaycal-en-py...r-une-opensuse
    Ignace.
    Mon site internet : La vue d' Ignace https://ignace72.eu

  9. #9
    Responsable Systèmes


    Homme Profil pro
    Gestion de parcs informatique
    Inscrit en
    août 2011
    Messages
    15 546
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Gestion de parcs informatique
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 15 546
    Points : 37 503
    Points
    37 503
    Par défaut
    Le fait que tu sois en VM n'a rien à voir, tu n'est pas sur exactement la même conf.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  10. #10
    Membre à l'essai
    Homme Profil pro
    Sans emploi
    Inscrit en
    avril 2004
    Messages
    29
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 49
    Localisation : France, Vendée (Pays de la Loire)

    Informations professionnelles :
    Activité : Sans emploi

    Informations forums :
    Inscription : avril 2004
    Messages : 29
    Points : 22
    Points
    22
    Par défaut
    Bonjour, chrtophe.
    D'accord, merci.
    Ignace.
    Mon site internet : La vue d' Ignace https://ignace72.eu

  11. #11
    Candidat au Club
    Homme Profil pro
    Retraité
    Inscrit en
    mai 2022
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 71
    Localisation : France, Meurthe et Moselle (Lorraine)

    Informations professionnelles :
    Activité : Retraité
    Secteur : Santé

    Informations forums :
    Inscription : mai 2022
    Messages : 1
    Points : 4
    Points
    4
    Par défaut
    Bonjour, ignace72 a créé ces posts pour moi. On a discuté du problème que j'ai sur le forum darktable français. Je viens de faire une mise à jour de Tumbleweed hier.
    Voilà les différentes versions qui sont installées :
    Nom : Screenshot_20220516_101220.png
Affichages : 43
Taille : 313,6 Ko
    et aussi pour libSDL2-2.0 :
    Nom : Screenshot_20220516_102005.png
Affichages : 48
Taille : 325,3 Ko
    Merci pour l'aide.

  12. #12
    Expert éminent sénior Avatar de disedorgue
    Homme Profil pro
    Ingénieur intégration
    Inscrit en
    décembre 2012
    Messages
    3 989
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur intégration
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : décembre 2012
    Messages : 3 989
    Points : 11 761
    Points
    11 761
    Par défaut
    déjà, que donne la commande:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    ldd /usr/local/lib64/python3.8/site-packages/libwx_gtk3u_core-3.1.so.5
    PS: au lieu de faire des copie d'écran, utilisez la balise code (le bouton [#])
    Cordialement.

  13. #13
    Expert éminent
    Avatar de Escapetiger
    Homme Profil pro
    Administrateur système Unix - Linux
    Inscrit en
    juillet 2012
    Messages
    1 264
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 59
    Localisation : France, Hauts de Seine (Île de France)

    Informations professionnelles :
    Activité : Administrateur système Unix - Linux

    Informations forums :
    Inscription : juillet 2012
    Messages : 1 264
    Points : 9 478
    Points
    9 478
    Par défaut
    En pleine réflexion sur le fond de ce sujet également, un rajout amical sur la forme :
    Citation Envoyé par disedorgue Voir le message
    PS: au lieu de faire des copie d'écran, utilisez la balise code (le bouton [#])
    Le bouton [#] : Démonstration de l’utilisation des balises code (animation .gif)

    Aide sur l'utilisation des boutons [Infos]


    [Edit]
    darktable, pour nos chères lectrices et lecteurs (et moi-même) selon Wikipedia :

    Darktable
    darktable est un logiciel libre de traitement d'image non-destructif et sans perte, principalement axé sur le traitement de photographies numériques brutes de capteur (raw), mais il supporte aussi les fichiers HDR (OpenEXR) et rasterisés (TIFF, JPEG, JPEG 2000, PNG, WebP, PPM, AVIF, HEIF/HEIC), en entrée comme en sortie. Il permet de cataloguer ses photographies et d'appliquer des corrections et effets divers à ces images, et autorise également le contrôle en temps réel d'appareils photographiques numériques connectés par un câble à un ordinateur (tethering). Il est disponible gratuitement pour la plupart des distributions Linux, Mac OS X, Windows 7, 8 et 10, et Solaris sous licence GNU General Public version 3 ou ultérieure. C'est l'un des principaux logiciels libres de dématriçage, avec RawTherapee, Photivo et Rawstudio,
    (.../...)
    « Developpez.com est un groupe international de bénévoles dont la motivation est l'entraide au sens large » (incl. forums developpez.net)
    Club des professionnels en informatique

Discussions similaires

  1. ImportError: /lib64/libSDL2-2.0.so.0: version ’V_2.0.22’ not found
    Par ignace72 dans le forum Déploiement/Installation
    Réponses: 6
    Dernier message: 14/05/2022, 14h10
  2. libstdc++.so.6: version `GLIBCXX_3.4.9' not found
    Par infcem dans le forum RedHat / CentOS / Fedora
    Réponses: 1
    Dernier message: 07/01/2011, 11h35
  3. Erreur version `GLIBCXX_3.4.9' not found
    Par Mistervanhalen dans le forum Linux
    Réponses: 2
    Dernier message: 27/11/2009, 13h45
  4. php --version command not found
    Par princesse95 dans le forum Administration système
    Réponses: 1
    Dernier message: 19/10/2009, 14h52
  5. version `GLIBC_2.3.2' not found
    Par jobim08 dans le forum Administration système
    Réponses: 5
    Dernier message: 06/01/2009, 11h08

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo