IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Sybase Discussion :

Impossible d'ouvrir une transaction dans une procédure stockée


Sujet :

Sybase

  1. #1
    Membre expérimenté
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    avril 2003
    Messages
    1 300
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Seine Saint Denis (Île de France)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : Service public

    Informations forums :
    Inscription : avril 2003
    Messages : 1 300
    Points : 1 379
    Points
    1 379
    Par défaut Impossible d'ouvrir une transaction dans une procédure stockée
    Bonjour,

    J'ai une procédure stockée Sybase qui en appelle d'autres. Elle est appelée par un programme Java via Jdbc. La semaine dernière j'arrivais a faire une insertion mais la procédure renvoyait une erreur "JZ0P1: Type de résultat inattendu."
    Vendredi il y a probablement eu des modifications côté Sybase car la même procédure renvoie toujours la même erreur mais dès la tentative d'ouverture de la transaction. Plusieurs personnes utilisent cette BDD et les DBA y font fréquemment des modifs (les bases sont instables). Et pour l'instant, personne ne s'est d'où vient le problème.
    J'ai modifié la procédure pour ouvrir la transaction dès le début (après les déclaration de variables) et il y a l'erreur JZ0P1 sur le code d'ouverture de la transaction. Je vois bien le log "Ouverture transaction" mais pas "Création des tables tempos".
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
      SELECT @mytran = 1
      SELECT @infomsg = 'Ouverture transaction'
      EXEC sp_batchlog @thisprocid, @infomsg, 0, @outputmode
      BEGIN TRAN
      SELECT @infomsg = 'Création des tables tempos'
      EXEC sp_batchlog @thisprocid, @infomsg, 0, @outputmode
    Une idée d'où ça peut provenir ?
    Christophe

    Pensez à mettre quand c'est le cas.

  2. #2
    Membre expérimenté
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    avril 2003
    Messages
    1 300
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Seine Saint Denis (Île de France)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : Service public

    Informations forums :
    Inscription : avril 2003
    Messages : 1 300
    Points : 1 379
    Points
    1 379
    Par défaut
    La solution de mon pb se trouve ici : https://stackoverflow.com/questions/...ed-result-type
    Christophe

    Pensez à mettre quand c'est le cas.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [WebFlow] Impossible d'ouvrir une vue dans une popup
    Par Marcolinho dans le forum Spring Web
    Réponses: 2
    Dernier message: 31/05/2011, 16h57
  2. Réponses: 0
    Dernier message: 07/04/2010, 16h39
  3. Les transactions dans les procédures stockées
    Par CharleLéo dans le forum Connexion aux bases de données
    Réponses: 2
    Dernier message: 04/12/2009, 16h04
  4. Impossible de créer une procédure stockée sur MySQL: 5.0.38
    Par donbrico dans le forum SQL Procédural
    Réponses: 5
    Dernier message: 19/11/2008, 18h30
  5. Impossible de creer une Procédure Stockée
    Par freud dans le forum MS SQL Server
    Réponses: 4
    Dernier message: 15/07/2007, 19h48

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo