IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Lazarus Pascal Discussion :

[2.2.0] Installer Dwarf 3 ou Dwarf 2 [Lazarus]


Sujet :

Lazarus Pascal

  1. #1
    Membre actif
    Homme Profil pro
    Retraité
    Inscrit en
    Juillet 2008
    Messages
    385
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Seine Maritime (Haute Normandie)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : Juillet 2008
    Messages : 385
    Points : 223
    Points
    223
    Par défaut [2.2.0] Installer Dwarf 3 ou Dwarf 2
    Bonjour,
    Je suis un petit développeur sous Linux avec Lazarus. Je viens d'installer la dernière version disponible la 2.2.0.
    Pour l'installation pas de problème, comme d'habitude je dois installer les paquets que j'utilise sqlite3, lazreport et dbexport. Mais j'ai un petit problème lors du lancement de la compilation d'une application via la touche F9 : j'ai une fenêtre d'information dont je ne connais pas la signification et naturellement pas la réponse à choisir.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Activer DwarF 3 (-gw3)  ou Dwarf 2 (-gw) activer Dwarf 2 avec les ensembles
    .
    Qui est ce Dwarf ? Pourquoi ce message que je n'avais pas avec la version précédente de Lazarus et son FPC associé et je dois choisir quelle réponse ?
    Merci d'avance
    A+

  2. #2
    Modérateur
    Avatar de tourlourou
    Homme Profil pro
    Biologiste ; Progr(amateur)
    Inscrit en
    Mars 2005
    Messages
    3 854
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 61
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : Biologiste ; Progr(amateur)

    Informations forums :
    Inscription : Mars 2005
    Messages : 3 854
    Points : 11 287
    Points
    11 287
    Billets dans le blog
    6
    Par défaut
    Bonjour,
    Je pense que c'est lié au débogueur et au niveau souhaité d'informations.

    Effectivement : https://wiki.lazarus.freepascal.org/DWARF

    Mais je ne sais pas pourquoi il te le demande... Ça doit se régler dans les Options du Projet : pê ne sont-elles pas complètes, ou incohérentes ?
    Delphi 5 Pro - Delphi 11.3 Alexandria Community Edition - CodeTyphon 6.90 sous Windows 10 ; CT 6.40 sous Ubuntu 18.04 (VM)
    . Ignorer la FAQ Delphi et les Cours et Tutoriels Delphi nuit gravement à notre code !

  3. #3
    Membre éprouvé
    Homme Profil pro
    Chef de projets retraité
    Inscrit en
    Juillet 2011
    Messages
    419
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Cher (Centre)

    Informations professionnelles :
    Activité : Chef de projets retraité
    Secteur : Transports

    Informations forums :
    Inscription : Juillet 2011
    Messages : 419
    Points : 1 096
    Points
    1 096
    Par défaut
    Bonjour,

    Citation Envoyé par tourlourou Voir le message
    Je pense que c'est lié au débogueur et au niveau souhaité d'informations.
    En fait, c'est lié au nouveau débogueur installé avec LAZARUS 2.2 qui demande obligatoirement du DWARF. Pour éviter ce message, il faut revenir au GDB dans les options du compilateur (Outils/Options de l'EDI/ Backend du débogueur)
    Si on reste sur FPDebug Internal Dwarf deboger il faut passer les options de débogage de chaque projet à DWARf (il y a trois options mais celle qui est recommandé est DWARF avec ensembles en attendant mieux (DWARF2 ou DWARF3 pas encore totalement au point)
    Si on veut rester sur les options anciennes du projet alors il faut utiliser les backend de type GDB.

    Cordialement

  4. #4
    Membre actif
    Homme Profil pro
    Retraité
    Inscrit en
    Juillet 2008
    Messages
    385
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Seine Maritime (Haute Normandie)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : Juillet 2008
    Messages : 385
    Points : 223
    Points
    223
    Par défaut
    Merci pour vos explications. Dommage que l'on propose une système pas encore au point.
    A+

  5. #5
    Expert confirmé

    Inscrit en
    Août 2006
    Messages
    3 942
    Détails du profil
    Informations forums :
    Inscription : Août 2006
    Messages : 3 942
    Points : 5 654
    Points
    5 654
    Par défaut
    Bonjour,
    Citation Envoyé par ovni76 Voir le message
    Merci pour vos explications. Dommage que l'on propose une systrème pas encore au point.
    A+
    Il ne pourra jamais l'être !

    L'évolution des projets fait que ce qui est nécessaire aujourd'hui ne le sera peut-être plus demain, et pourrait l'être à nouveau plus tard.
    Si les cons volaient, il ferait nuit à midi.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. dwarf fortress, vous connaissez?
    Par r0d dans le forum PC
    Réponses: 15
    Dernier message: 12/03/2013, 09h15
  2. [mpp.dwarf] Pwet a tous les Sapiens
    Par mpp.dwarf dans le forum Présentations
    Réponses: 0
    Dernier message: 08/12/2011, 21h35
  3. Réponses: 0
    Dernier message: 16/05/2008, 11h07
  4. Problème d'installation oracle 8.1.7 sous NT
    Par Anonymous dans le forum Installation
    Réponses: 7
    Dernier message: 02/08/2002, 14h18
  5. Réponses: 7
    Dernier message: 01/05/2002, 20h23

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo