IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Réseaux Discussion :

Proxmox, VLAN et sous réseau


Sujet :

Réseaux

  1. #1
    Membre à l'essai
    Profil pro
    Inscrit en
    octobre 2009
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2009
    Messages : 12
    Points : 10
    Points
    10
    Par défaut Proxmox, VLAN et sous réseau
    Bonjour à tous,

    Je viens demander de l'aide sur du paramétrage réseau.

    Le contexte : j'ai un hyperviseur proxmox qui héberge des conteneurs et des VM en prod pour me fournir différents services (NAS, mediacenter, cloud, VPN, DNS local, site web en dev...) ainsi que des CT et des VM pour du test. Ce proxmox est derrière un routeur qui lui-même est derrière une box. Aujourd'hui toutes les VMs et tous les conteneurs ont une adresse IP fournie par le DHCP du routeur (IP du type 10.0.0.x/24)

    L'objectif : créer un sous-réseau pour y mettre VM et conteneurs de tests. L'idée est que ces derniers aient accès à internet mais soient isolés du reste.

    Ce que j'ai essayé : dans proxmox j'ai créé un bridge avec une adresse 10.0.1.x/24, un conteneur sous debian avec deux interfaces réseaux (une dans le réseau 10.0.0.x et une dans 10.0.1.x). Dans ce conteneur j'ai paramétré un DHCP qui fournit les adresses 10.0.1.x ainsi que le routage des paquets et le NAT qui vont bien.

    Le résultat : mes VM reliés au routeur via l'interface en 10.0.1.x ont bien accès à internet mais ont aussi accès au reste du réseau (les machines en 10.0.0.x).

    Du coup, je ne sais pas si le problème vient de proxmox ou de la debian qui fait office de routeur. Je penche pour la debian mais je ne m'y connais pas assez en paramétrage réseau (NAT, pare-feu ?).

    Merci de votre aide

    Rémi

  2. #2
    Expert confirmé
    Avatar de becket
    Profil pro
    Informaticien multitâches
    Inscrit en
    février 2005
    Messages
    2 516
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations professionnelles :
    Activité : Informaticien multitâches
    Secteur : Service public

    Informations forums :
    Inscription : février 2005
    Messages : 2 516
    Points : 5 106
    Points
    5 106
    Par défaut
    Salut,

    Pour la faire courte, le comportement que tu décris est parfaitement normal étant donné que tu mets en route un routeur entre tes VM de TEST et ton réseau de production et que tu y configure un NAT pour que ton réseau de test puisse atteindre INTERNET. Du point de vue de la box / de ton réseau de prod, tout se passe comme si l'origine du trafic émanait de l'ip de ta VM DEBIAN/Routeur/GW. Celle ci ayant forcément une patte dans ton réseau de prod ... 1 + 1


    Si tu veux interdire ce comportement, tu dois rajouter des règles dans le firewall de debian.

  3. #3
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 995
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 995
    Points : 34 818
    Points
    34 818
    Par défaut
    Depuis l'hôte du proxmox, tu peux créer des VLAN logiciels. Je ne me rappelle plus si on peut créer directement des VLAN depuis Proxmox ou non.

    Si ton routeur le permet, tu peux aussi le faire depuis celui-ci, sous réserve d'avoir deux cartes réseau dans l'hôte.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

Discussions similaires

  1. [Linux][VLAN] Sous réseau saturé - manque d'IP
    Par djibril dans le forum Réseaux
    Réponses: 12
    Dernier message: 25/11/2016, 14h41
  2. Mise en place réseau avec VLAN et sous-réseau
    Par Invité dans le forum Architecture
    Réponses: 2
    Dernier message: 08/10/2015, 22h57
  3. Mise en place d'un sous-réseau dédié sur Proxmox
    Par kalyparker dans le forum Réseau
    Réponses: 0
    Dernier message: 11/11/2013, 15h58
  4. [ADRESSAGE][DEBUTANT]Accés à une machine dans un sous-réseau
    Par Milark dans le forum Développement
    Réponses: 4
    Dernier message: 26/03/2004, 10h45
  5. [MFC] Récupération du masque de sous-réseau
    Par ChrSan dans le forum MFC
    Réponses: 2
    Dernier message: 02/02/2004, 17h31

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo