IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Debian Discussion :

mysql-utilities pour debian 10


Sujet :

Debian

  1. #1
    Membre régulier
    Homme Profil pro
    Etudiant du Genie Logiciel
    Inscrit en
    juillet 2011
    Messages
    392
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Etudiant du Genie Logiciel
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2011
    Messages : 392
    Points : 73
    Points
    73
    Par défaut mysql-utilities pour debian 10
    salut,

    je voudrais installer mysql-utilities sur debian 10 afin de pouvoir restaurer ma base de données mais j'ai le message suivant

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
     
    Sélection du paquet mysql-utilities précédemment désélectionné.
    (Lecture de la base de données... 42516 fichiers et répertoires déjà installés.)
    Préparation du dépaquetage de mysql-utilities_1.6.4-1debian8_all.deb ...
    Dépaquetage de mysql-utilities (1.6.4-1debian8) ...
    dpkg: des problèmes de dépendances empêchent la configuration de mysql-utilities :
     mysql-utilities dépend de mysql-connector-python (>= 2.0.0) | mysql-connector-python-commercial (>= 2.0.0) ; cependant :
      Le paquet mysql-connector-python n'est pas installé.
      Le paquet mysql-connector-python-commercial n'est pas installé.
     
    dpkg: erreur de traitement du paquet mysql-utilities (--install) :
     problèmes de dépendances - laissé non configuré
    Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
    Des erreurs ont été rencontrées pendant l'exécution :
     mysql-utilities
    malgré le fait que j'ai installé mysql-connector-python, rien ne va !!!. j'ai toujours le même message qui revient.

    que faire ? comment proceder ?

    j'ai déjà fouillé partout sur le net.

    merci.

  2. #2
    Membre éprouvé Avatar de gabriel21
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    315
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : février 2007
    Messages : 315
    Points : 1 101
    Points
    1 101
    Par défaut
    peux tu me donner ce que retourne la commande suivante :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    apt show mysql-connector-python
    "Les cons, ça ose tout. C'est même à ça qu'on les reconnaît." Michel Audiard - Les tontons flingueurs

  3. #3
    Membre régulier
    Homme Profil pro
    Etudiant du Genie Logiciel
    Inscrit en
    juillet 2011
    Messages
    392
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Etudiant du Genie Logiciel
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2011
    Messages : 392
    Points : 73
    Points
    73
    Par défaut MySQL Utilities
    Citation Envoyé par gabriel21 Voir le message
    peux tu me donner ce que retourne la commande suivante :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    apt show mysql-connector-python
    voici ce que me retourne cette commande :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    Package: mysql-connector-python
    State: pas un véritable*paquet (virtuel)
    N: Impossible de choisir une version candidate du paquet «*mysql-connector-python*» qui n'en n'a pas
    N: Impossible de choisir les versions du paquet «*mysql-connector-python*» qui n'est qu'un paquet virtuel
    N: Aucun paquet n'a été trouvé
    merci

  4. #4
    Membre régulier
    Homme Profil pro
    Etudiant du Genie Logiciel
    Inscrit en
    juillet 2011
    Messages
    392
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Etudiant du Genie Logiciel
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2011
    Messages : 392
    Points : 73
    Points
    73
    Par défaut
    salut,
    j'ai installé MySQL Utilities a partir d'ici : https://downloads.mysql.com/archives/utilities/
    merci

  5. #5
    Membre éprouvé Avatar de gabriel21
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    315
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : février 2007
    Messages : 315
    Points : 1 101
    Points
    1 101
    Par défaut
    Il faut que tu installes le paquet directement en le téléchargeant à partir du site https://downloads.mysql.com/archives/c-python/
    L'installation doit être faite avant mysql-utilities.
    Si tu as le même type d'erreur, il faut que tu trouves le paquet manquant. Soit via apt, s'il est disponible sur les dépôts soit par téléchargement.
    "Les cons, ça ose tout. C'est même à ça qu'on les reconnaît." Michel Audiard - Les tontons flingueurs

  6. #6
    Membre régulier
    Homme Profil pro
    Etudiant du Genie Logiciel
    Inscrit en
    juillet 2011
    Messages
    392
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Etudiant du Genie Logiciel
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2011
    Messages : 392
    Points : 73
    Points
    73
    Par défaut
    salut.comment résoudre ceci :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
     
    dpkg: avertissement: dégradation («*downgrade*») de mysql-connector-python-py3-dbgsym depuis 8.0.27-1debian10 vers 8.0.26-1debian10
    (Lecture de la base de données... 43419 fichiers et répertoires déjà installés.)
    Préparation du dépaquetage de mysql-connector-python-py3-dbgsym_8.0.26-1debian10_amd64.deb ...
    Dépaquetage de mysql-connector-python-py3-dbgsym (8.0.26-1debian10) sur (8.0.27-1debian10) ...
    dpkg: des problèmes de dépendances empêchent la configuration de mysql-connector-python-py3-dbgsym*:
     mysql-connector-python-py3-dbgsym dépend de mysql-connector-python-py3 (= 8.0.26-1debian10)*; cependant*:
      La version de mysql-connector-python-py3 sur le système est 8.0.27-1debian10.
     
    dpkg: erreur de traitement du paquet mysql-connector-python-py3-dbgsym (--install)*:
     problèmes de dépendances - laissé non configuré
    Des erreurs ont été rencontrées pendant l'exécution*:
     mysql-connector-python-py3-dbgsym
    merci

  7. #7
    Membre éprouvé Avatar de gabriel21
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    315
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : février 2007
    Messages : 315
    Points : 1 101
    Points
    1 101
    Par défaut
    Tu cherches a installer une version qui semble être trop ancienne pour ton système.
    As tu une bonne raison pour le faire?
    Si non, prends la dernière version du logiciel.
    Si oui, tu n'auras pas beaucoup d'alternative à compiler toi même le logiciel à partir des sources ou bien à installer une version compatible via pip et les environnement virtuel de python, mais là je ne te serais d'aucune aide. Je sais juste que cela existe.
    "Les cons, ça ose tout. C'est même à ça qu'on les reconnaît." Michel Audiard - Les tontons flingueurs

  8. #8
    Membre régulier
    Homme Profil pro
    Etudiant du Genie Logiciel
    Inscrit en
    juillet 2011
    Messages
    392
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Etudiant du Genie Logiciel
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2011
    Messages : 392
    Points : 73
    Points
    73
    Par défaut
    salut,
    merci pour !!!
    j'ai finalement géré le problème. j'ai installe mysql utilities.

Discussions similaires

  1. Script sauvegarde mysql pour DEBIAN
    Par Tofdu31 dans le forum Shell et commandes GNU
    Réponses: 4
    Dernier message: 27/07/2017, 16h37
  2. [MySQL] conseils pour gérer des images avec mysql
    Par briiice dans le forum Administration
    Réponses: 9
    Dernier message: 04/01/2006, 10h52
  3. [Info][Utile]Liens & Smiles Utiles Pour le Forum
    Par Swoög dans le forum Mode d'emploi & aide aux nouveaux
    Réponses: 12
    Dernier message: 28/08/2004, 03h52

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo