IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

OpenOffice & LibreOffice Discussion :

fonction si multiple


Sujet :

OpenOffice & LibreOffice

  1. #1
    Futur Membre du Club
    Profil pro
    Inscrit en
    mai 2004
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2004
    Messages : 11
    Points : 9
    Points
    9
    Par défaut fonction si multiple
    Bonjour à tous
    j'ai un petit souci avec la fonction: si.
    je dois tester le résultat d'une cellule, si le résultat est :
    -4 => afficher : Très forte
    -6 => afficher : Forte
    -8 => afficher : Moyenne
    -10=> afficher : Faible
    -12=> afficher : Très faible
    d'avance merci pour votre aide

  2. #2
    Membre régulier
    Homme Profil pro
    Maitre d'Oeuvre
    Inscrit en
    juin 2016
    Messages
    66
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 61
    Localisation : France, Loiret (Centre)

    Informations professionnelles :
    Activité : Maitre d'Oeuvre
    Secteur : Bâtiment Travaux Publics

    Informations forums :
    Inscription : juin 2016
    Messages : 66
    Points : 106
    Points
    106
    Par défaut
    Bjour,

    Voici deux solutions à froid, mais je suis sûr qu'il en existe d'autres.

    1/ la fonction Si imbriquée

    2/ la fonction RechercheV
    Cette seconde solution est plus facile à maintenir et éventuellement à compléter ou à modifier
    Fichiers attachés Fichiers attachés

  3. #3
    Membre éprouvé
    Homme Profil pro
    utilisateur
    Inscrit en
    janvier 2017
    Messages
    571
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 60
    Localisation : France

    Informations professionnelles :
    Activité : utilisateur
    Secteur : Service public

    Informations forums :
    Inscription : janvier 2017
    Messages : 571
    Points : 932
    Points
    932
    Par défaut
    Bonjour samkad, TpF45,

    en admettant que la cellule à analyser soit A1 :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SI(ET(EST.PAIR(A1);A1>3;A1<13);CHOISIR(A1/2;"";"Très forte";"Forte";"Moyenne";"Faible";"Très faible");"")


    Nom : samkad.png
Affichages : 27
Taille : 5,4 Ko
    LibreOffice 7.1.5.2/ (x64) FR-YT 15/08/21
    OS : Windows 10.0

  4. #4
    Futur Membre du Club
    Profil pro
    Inscrit en
    mai 2004
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2004
    Messages : 11
    Points : 9
    Points
    9
    Par défaut Fonction SI
    Bonjour
    je n'ai pas obtenu le résultat recherché, mais certainement que je me suis mal exprimé!
    Test effectué sur résultat dans la cellule : C11
    -4 : Très forte
    -6 : Forte
    -8 : Moyenne
    -10 : Faible
    -12 : Très faible
    il s'agit ici de la cotation de l'indice d'endurance formule de Peronnet.
    d'avance merci pour votre aide.
    Salutations

  5. #5
    Membre éprouvé
    Homme Profil pro
    utilisateur
    Inscrit en
    janvier 2017
    Messages
    571
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 60
    Localisation : France

    Informations professionnelles :
    Activité : utilisateur
    Secteur : Service public

    Informations forums :
    Inscription : janvier 2017
    Messages : 571
    Points : 932
    Points
    932
    Par défaut
    Essayez avec : si C11 est négatif

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SI(ET(EST.PAIR(C11);C11<-3;C11>-13);CHOISIR(ABS(C11)/2;"";"Très forte";"Forte";"Moyenne";"Faible";"Très faible");"")
    LibreOffice 7.1.5.2/ (x64) FR-YT 15/08/21
    OS : Windows 10.0

  6. #6
    Futur Membre du Club
    Profil pro
    Inscrit en
    mai 2004
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2004
    Messages : 11
    Points : 9
    Points
    9
    Par défaut si Multiple
    Bonjour
    j'ai fais le test , mais ce n'est pas bon !
    Peut être parce que l'on obtient des résultats intermédiaires entre les valeurs de chaque plage
    Merci quand même
    salutations

  7. #7
    Futur Membre du Club
    Profil pro
    Inscrit en
    mai 2004
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2004
    Messages : 11
    Points : 9
    Points
    9
    Par défaut Fonction si Résolu
    Bonjour
    j'ai enfin trouvé !
    Code formule : Sélectionner tout - Visualiser dans une fenêtre à part
    =SI.CONDITIONS(C11>=-4;"Très Forte";C11>=-6;"Forte";C11>=-8;"Moyenne";C11>=-10;"Faible";C11>=-12;"Très faible")
    Merci à vous tous pour l'aide apportée.
    Salutations

Discussions similaires

  1. [MooTools] Fonction sur multiples id
    Par patou247 dans le forum Bibliothèques & Frameworks
    Réponses: 5
    Dernier message: 16/03/2009, 07h36
  2. Fonction Split multiple
    Par bebest93 dans le forum Général JavaScript
    Réponses: 2
    Dernier message: 26/08/2008, 18h03
  3. Fonction de multiplication de polynôme
    Par Maxence45 dans le forum Scheme
    Réponses: 2
    Dernier message: 05/12/2007, 06h12
  4. Fonctions à variables multiples
    Par L. Sierra dans le forum C
    Réponses: 1
    Dernier message: 15/03/2007, 21h34
  5. fonction clic multiple ne marche pas !
    Par decksroy dans le forum Général JavaScript
    Réponses: 10
    Dernier message: 06/10/2006, 10h55

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo