IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Arduino Discussion :

Problème recharge batterie lipo avec cellule solaire


Sujet :

Arduino

  1. #1
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    septembre 2021
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 21
    Localisation : France, Indre (Centre)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2021
    Messages : 2
    Points : 2
    Points
    2
    Par défaut Problème recharge batterie lipo avec cellule solaire
    Bonjour,

    Je suis en train de travailler sur un prototype de système d'ouverture et de fermeture pour poulailler. Je dois programmer une porte de type guillotine, qui s'ouvre et qui se ferme selon le sens de rotation du moteur piloté par des relais, en mode automatique. qui fonctionne à l'énergie solaire.

    Mon maître de stage m'avait envoyé du matériel spécialisé, comprenant:
    -une porte prototype
    -des cartes Arduino UNO
    -un afficheur LCD
    -2 capteurs fin de course
    -un module relais à double canaux
    -une cellule solaire
    -4 batteries lipo (dont 2 qui sont maintenant usés)
    -plusieurs composants électroniques (résistances, polarisateurs, etc...)
    -des câbles pour les connecter

    Voici les photos du montage en question:

    https://aws1.discourse-cdn.com/ardui...2_666x500.jpeg

    https://aws1.discourse-cdn.com/ardui...2_375x500.jpeg

    https://aws1.discourse-cdn.com/ardui...2_666x500.jpeg

    https://aws1.discourse-cdn.com/ardui...2_375x500.jpeg

    https://aws1.discourse-cdn.com/ardui...2_375x500.jpeg

    Et voici un schéma représentant le montage. A noter qu'il ne faut pas prendre en compte la partie "Module GSM" qui n'est pas présente sur le montage:

    https://aws1.discourse-cdn.com/ardui...9356723f69.png

    Pour alimenter le montage, j'utilise une Batterie LIPO de 3.7V 1200 mAh que je branche à cet emplacement:

    https://aws1.discourse-cdn.com/ardui...b29ab182c.jpeg

    La porte fonctionne sans problème même si je dois encore y travailler là-dessus. Cependant, mon maître de stage m'a conseillé que les batteries lipo devrait âtre au moins chargée avec une tension minimale de 3.6V pour mieux fonctionner.

    En théorie, la cellule solaire qui doit détecter la luminosité extérieure pour contrôler la porte peut être alimentée par le soleil afin de recharger la batterie en 30 minutes. Pour être franc, je n'ai pas encore testé la recharge solaire de la batterie avec le matériel entier étant donné que je travaille sur un prototype.

    Alors, j'ai décide de réaliser un montage type comprenant des résistances, une diode de redressement (pour éviter que la batterie se décharge), la cellule solaire et la batterie lipo en question.

    https://aws1.discourse-cdn.com/ardui...1956a8a87.jpeg

    J'ai laissé ce montage illuminé par le soleil pendant 2 h alors qu'initialement, la batterie avait une tension de 3.56V. Mais 2 h après, en mesurant la tension, la cellule ne s'est pas chargée du tout !

    J'ai décide de faire autrement et de recharger la batterie lipo avec cette fois un générateur 5 V, un régulateur de tension (fournie par mon maître de stage) et un bloc secteur pour alimenter le générateur:

    https://aws1.discourse-cdn.com/ardui...197619179.jpeg

    J'ai alors rechargé la batterie à plusieurs reprises pendant plusieurs heures (voire toute la nuit), mais la batterie est soit rechargée très lentement, soit pas du tout.

    Pensez-vous que je dois m'y prendre autrement pour recharger ma batterie ?

    Répondez-moi vite SVP. Je crains que mes 2 batteries restantes pourront être grillées un jour.

    Merci d'avance.

  2. #2
    Membre expérimenté

    Homme Profil pro
    Directeur de projet
    Inscrit en
    mai 2013
    Messages
    503
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : Directeur de projet
    Secteur : Service public

    Informations forums :
    Inscription : mai 2013
    Messages : 503
    Points : 1 556
    Points
    1 556
    Par défaut Le montage fait de la résistance
    Bonjour,

    Je ne vois pas sur le schémas comment le capteur solaire pourrait servir à quoi que ce soit au travers d'une résistance de 330k. Par ailleurs la diode est un gâchis pour un montage fixe (se protéger des erreurs de branchement d'éléments que l'on change pourraient se comprendre). Pour vérifier que le panneau solaire fonctionne il suffit de placer un multimètre juste à la sortie du module (pas derrière résistances et diode).

    Qu'est-ce qui dit que le panneau fournit juste ce qu'il faut en tension ? En général on place un ou plusieurs modules qui vont contrôler la charge de la batterie, limiter sa décharge et fournir la tension de service.

    Salutations
    Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better. (Samuel Beckett)

  3. #3
    Membre expert

    Homme Profil pro
    mad scientist :)
    Inscrit en
    septembre 2019
    Messages
    1 695
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : mad scientist :)

    Informations forums :
    Inscription : septembre 2019
    Messages : 1 695
    Points : 3 299
    Points
    3 299
    Par défaut
    Mesure de sécurité : :Ne jamais laisser une batterie en charge sans surveillance et pour les batteries LiPo, utiliser un Sac LiPo ignifugé devrait être la règle,,,

    Une batterie lipo se charge en 3 phases, un preconditionnelent, Puis en courant constant (généralement à 1C (une fois sa capacité)) puis une fois qu’elle a atteint les 4.2V on passe en tension constante pour remplir les 20-30% d’énergie restante.

    Vous n’avez pas un chargeur adapté dans votre kit? on trouve aussi des chargeurs faits pour le solaire par exemple

    https://www.adafruit.com/product/390

Discussions similaires

  1. Problème VBA copier/coller avec cellule Fusionnée.
    Par amaury57280 dans le forum Macros et VBA Excel
    Réponses: 24
    Dernier message: 01/04/2016, 16h56
  2. Réponses: 6
    Dernier message: 21/10/2007, 17h27
  3. Problème de batterie avec mon PC portable
    Par winda dans le forum Ordinateurs
    Réponses: 1
    Dernier message: 06/08/2007, 10h50
  4. Problème de fonction avec cellule vide
    Par Samjeux dans le forum Excel
    Réponses: 4
    Dernier message: 14/06/2007, 08h45
  5. [HTML] [CSS ?] Tableau : problème avec cellules
    Par Epistoliere dans le forum Mise en page CSS
    Réponses: 8
    Dernier message: 07/08/2006, 17h04

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo