IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Excel Discussion :

TCD - Problème sur format du filtre


Sujet :

Excel

  1. #1
    Nouveau membre du Club
    Homme Profil pro
    Développeur .NET
    Inscrit en
    décembre 2011
    Messages
    31
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur .NET
    Secteur : Bâtiment

    Informations forums :
    Inscription : décembre 2011
    Messages : 31
    Points : 27
    Points
    27
    Par défaut TCD - Problème sur format du filtre
    Bonjour à toutes et tous,
    J'ai un problème de format de filtrage sur un tableau croisé dynamique. Sur certaines colonnes qui sont au format standard, le filtre sur la colonne affiche des valeurs filtrables au format monétaire (en €).
    Nom : image1.png
Affichages : 60
Taille : 3,7 Ko
    La liste est ainsi


    Nom : image2.png
Affichages : 57
Taille : 22,1 Ko
    Et le filtre affiche ceci !


    J'ai bien essayé sur l'onglet d'où viennent les données de m'assurer que tout était au format texte, puis fait un CTRL-ALT-F5 pour raffraÎchir le TCD, rien ne change.

    Je n'arrive pas à résoudre ce problème. Quelqu'un a-t-il une idée ?

  2. #2
    Expert confirmé
    Homme Profil pro
    Responsable des études
    Inscrit en
    juillet 2014
    Messages
    2 477
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Aude (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Responsable des études
    Secteur : Santé

    Informations forums :
    Inscription : juillet 2014
    Messages : 2 477
    Points : 5 361
    Points
    5 361
    Par défaut
    Bonjour,
    Citation Envoyé par jmatys Voir le message
    J'ai un problème de format de filtrage sur un tableau croisé dynamique. Sur certaines colonnes qui sont au format standard, le filtre sur la colonne affiche des valeurs filtrables au format monétaire (en €).
    Dans la liste des champs de ton TCD tu clic sur son ton champ en question puis paramètre de champ -> format de nombre (en bas a gauche) et tu changes le format.
    J'aimerais bien aller vivre en Théorie, car en Théorie tout se passe bien.

  3. #3
    Nouveau membre du Club
    Homme Profil pro
    Développeur .NET
    Inscrit en
    décembre 2011
    Messages
    31
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur .NET
    Secteur : Bâtiment

    Informations forums :
    Inscription : décembre 2011
    Messages : 31
    Points : 27
    Points
    27
    Par défaut
    Citation Envoyé par halaster08 Voir le message
    Bonjour,


    Dans la liste des champs de ton TCD tu clic sur son ton champ en question puis paramètre de champ -> format de nombre (en bas a gauche) et tu changes le format.

    Bonjour et merci pour la réponse,
    Je n'ai pas cette option possible. Y a-t-il un paramètre pour le faire apparaitre ?
    Nom : image3.png
Affichages : 41
Taille : 33,1 Ko

  4. #4
    Expert confirmé
    Homme Profil pro
    Responsable des études
    Inscrit en
    juillet 2014
    Messages
    2 477
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Aude (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Responsable des études
    Secteur : Santé

    Informations forums :
    Inscription : juillet 2014
    Messages : 2 477
    Points : 5 361
    Points
    5 361
    Par défaut
    Citation Envoyé par jmatys Voir le message
    Bonjour et merci pour la réponse,
    Je n'ai pas cette option possible. Y a-t-il un paramètre pour le faire apparaitre ?
    Je n'ai pas la même version d'Excel que toi ce qui explique peut être la différence mais ça m'étonne quand même
    Chez moi ce bouton est là de base et je ne connais pas de moyen de le faire disparaître

    Si tu essaye sur un autre champs tu as le bouton ?
    Si tu recrée un nouveau TCD sur un nouveau classeur avec une bdd bidon, tu vois le bouton ?
    Ton classeur / ta feuille est protégée ?

    edit: je viens de me rendre compte que si le champs n'est pas numérique, le bouton "format de nombre" n'apparait pas (ce qui est logique), quel est le format du champ dans ta base ?
    J'aimerais bien aller vivre en Théorie, car en Théorie tout se passe bien.

  5. #5
    Membre régulier
    Homme Profil pro
    Formateur en informatique
    Inscrit en
    janvier 2021
    Messages
    64
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Formateur en informatique
    Secteur : Enseignement

    Informations forums :
    Inscription : janvier 2021
    Messages : 64
    Points : 104
    Points
    104
    Par défaut
    Bonjour
    c'est en faisant clic droit sur un élément placé en zone valeur qu'on fait apparaitre le bon menu
    mais j'ai l'impression que Jmatys n'a pas mis les n° dans la zone valeur mais dans la zone de ligne non ?

  6. #6
    Nouveau membre du Club
    Homme Profil pro
    Développeur .NET
    Inscrit en
    décembre 2011
    Messages
    31
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur .NET
    Secteur : Bâtiment

    Informations forums :
    Inscription : décembre 2011
    Messages : 31
    Points : 27
    Points
    27
    Par défaut
    Citation Envoyé par Fab_de_chez_PERFORM Voir le message
    mais j'ai l'impression que Jmatys n'a pas mis les n° dans la zone valeur mais dans la zone de ligne non ?
    Oui, Fab_de_chez_PERFORM, c'est exactement cela. n° est dans la zone ligne. Je ne vois pas pourquoi le filtre de ces zones lignes apparaissent en monétaire et qu'on ne peut pas spécifier le format du filtre.
    J'ai d'autre données qui sont dans la zone ligne, qui sont des dates mais le filtre affiche aussi les valeurs de filtrage en euros.

    Connais-tu une astuce pour spécifier le format quand c'est dans une zone de ligne ?

    J'ai mis n° en zone valeur et j'ai bien la personnalisation du format, mais si je remets ensuite en zone ligne, le problème reste identique.

  7. #7
    Membre régulier
    Homme Profil pro
    Formateur en informatique
    Inscrit en
    janvier 2021
    Messages
    64
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Formateur en informatique
    Secteur : Enseignement

    Informations forums :
    Inscription : janvier 2021
    Messages : 64
    Points : 104
    Points
    104
    Par défaut
    Non désolé
    j'ai regardé ce matin déjà mais franchement je ne vois pas
    j'ai essayé de reproduire "l'erreur" mais en vain

  8. #8
    Expert confirmé
    Homme Profil pro
    Responsable des études
    Inscrit en
    juillet 2014
    Messages
    2 477
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Aude (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Responsable des études
    Secteur : Santé

    Informations forums :
    Inscription : juillet 2014
    Messages : 2 477
    Points : 5 361
    Points
    5 361
    Par défaut
    Citation Envoyé par Fab_de_chez_PERFORM Voir le message
    mais j'ai l'impression que Jmatys n'a pas mis les n° dans la zone valeur mais dans la zone de ligne non ?
    Ca ne change rien le menu est le même peut importe où le champs est situé
    Pour moi la seule raison pour que le bouton ne soit pas visible c'est que le champs n'est pas reconnu comme numérique
    J'aimerais bien aller vivre en Théorie, car en Théorie tout se passe bien.

  9. #9
    Nouveau membre du Club
    Homme Profil pro
    Développeur .NET
    Inscrit en
    décembre 2011
    Messages
    31
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur .NET
    Secteur : Bâtiment

    Informations forums :
    Inscription : décembre 2011
    Messages : 31
    Points : 27
    Points
    27
    Par défaut
    Citation Envoyé par halaster08 Voir le message
    Ca ne change rien le menu est le même peut importe où le champs est situé
    Pour moi la seule raison pour que le bouton ne soit pas visible c'est que le champs n'est pas reconnu comme numérique
    Ce ne sont pas des formats numériques, mais des textes ou des dates. Mais je ne vois pas pourquoi ça pose problème que ce soit du texte ou de la date. Quelqu'un peut-il me dire ?
    Halaster08, arrives-tu à reproduire le problème par hasard ?

  10. #10
    Membre expérimenté
    Homme Profil pro
    Formateur et développeur bureautique
    Inscrit en
    mars 2007
    Messages
    704
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Formateur et développeur bureautique
    Secteur : Conseil

    Informations forums :
    Inscription : mars 2007
    Messages : 704
    Points : 1 482
    Points
    1 482
    Par défaut
    Bonsoir

    Avec mon expérience, le bouton n'apparait que s'il s'agit d'un champ numérique. Pas sur un champ texte.

    Ceci étant, je n'ai jamais rencontré ce souci.

    Si c'est possible de mettre en pièce jointe une petite partie de fichier anonymisé afin que l'on puisse regarder ce qu'il en est, ce serait plus pratique me semble-t'il.

    Bonne fin de journée

    Pierre Dumas
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  11. #11
    Nouveau membre du Club
    Homme Profil pro
    Développeur .NET
    Inscrit en
    décembre 2011
    Messages
    31
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur .NET
    Secteur : Bâtiment

    Informations forums :
    Inscription : décembre 2011
    Messages : 31
    Points : 27
    Points
    27
    Par défaut
    Bonsoir,
    Merci pour ce retour aussi.
    Les données étant confidentielles et il y a pas mal de formules dans différents onglets, il est compliqué d'anonymiser ces données et je ne peux donc pas envoyer le fichier comme ça. Je vais me renseigner si je peux transmettre une partie.

    Merci de votre aide et peut-être à la semaine prochaine.

  12. #12
    Expert confirmé
    Homme Profil pro
    Responsable des études
    Inscrit en
    juillet 2014
    Messages
    2 477
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Aude (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Responsable des études
    Secteur : Santé

    Informations forums :
    Inscription : juillet 2014
    Messages : 2 477
    Points : 5 361
    Points
    5 361
    Par défaut
    Citation Envoyé par jmatys Voir le message
    Halaster08, arrives-tu à reproduire le problème par hasard ?
    Oui, si le champ n'est pas numérique le bouton n'apparait pas
    J'aimerais bien aller vivre en Théorie, car en Théorie tout se passe bien.

  13. #13
    Membre confirmé
    Homme Profil pro
    ingénieur
    Inscrit en
    mars 2015
    Messages
    155
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : ingénieur

    Informations forums :
    Inscription : mars 2015
    Messages : 155
    Points : 454
    Points
    454
    Par défaut
    Bonjour
    Avec Excel 365 je reproduis le visuel de votre filtre (avec les €) mais j'ai bien le bouton "Format" tant que je n'ai pas une donnée dans ma colonne qui n'est pas un nombre.
    C'est à dire que si vous avez mis un format € dans le TCD lorsque vous n'aviez que des nombres, puis qu'une donnée "Texte" est ajoutée dans la source, le bouton format disparaît et vous ne pouvez plus rien modifier

    Je pense donc qu'il faut essayer de convertir votre champ N° de la source en texte (via donnée/convertir/texte) puis de nouveau en nombre

    Sinon dupliquez les N° dans un nouveau champ par formule =[@N°]*1 pour nombre ou =[@N°]&"" pour texte

    Stéphane

Discussions similaires

  1. [BO XI R2] Problème de format de date sur invite
    Par jpcreux dans le forum Webi
    Réponses: 18
    Dernier message: 23/03/2018, 15h42
  2. Problème sur Format Conditionnel
    Par babybell dans le forum Macros et VBA Excel
    Réponses: 0
    Dernier message: 22/08/2011, 18h22
  3. Problème sur Format Conditionnel
    Par babybell dans le forum Excel
    Réponses: 0
    Dernier message: 22/08/2011, 18h22
  4. Encore un problème sur le format d'une date!
    Par bygui dans le forum Langage
    Réponses: 1
    Dernier message: 26/06/2006, 08h41
  5. Problème sur format
    Par G.D.O dans le forum ASP
    Réponses: 1
    Dernier message: 02/12/2005, 14h49

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo