IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Serveurs (Apache, IIS,...) Discussion :

[Nginx] localhost erreur de configuration


Sujet :

Serveurs (Apache, IIS,...)

  1. #1
    Membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    octobre 2018
    Messages
    63
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Loire (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : octobre 2018
    Messages : 63
    Points : 60
    Points
    60
    Par défaut [Nginx] localhost erreur de configuration
    Bonjour a tous,

    J'ai un petit soucis de configuration avec mon serveur Nginx sur mac. J'ai installé via HomeBrew.
    Petite precision, les dossiers sites-available et sites-enabled m'étaient pas present quand j'ai installé, alors je les ai créé manuellement.
    Et j'ai bien lié le site depuis sites-available vers sites-enabled avec la commande suivante : (ln -s /usr/local/etc/nginx/sites-available/exemple.local /usr/local/etc/nginx/sites-enabled/)

    Je pensais que c'était une question d'autorisation, mais en regardant j'ai bien tous les droits :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    drwxr-xr-x  2 alexis  admin    64 Sep  9 14:33 conf.d
    -rw-r--r--  1 alexis  admin  1077 Sep  9 11:08 fastcgi.conf
    -rw-r--r--  1 alexis  admin  1077 Sep  9 11:08 fastcgi.conf.default
    -rw-r--r--  1 alexis  admin  1007 Sep  9 11:08 fastcgi_params
    -rw-r--r--  1 alexis  admin  1007 Sep  9 11:08 fastcgi_params.default
    -rw-r--r--  1 alexis  admin  2837 Sep  9 11:08 koi-utf
    -rw-r--r--  1 alexis  admin  2223 Sep  9 11:08 koi-win
    drwxr-xr-x  4 alexis  admin   128 Sep  9 15:03 logs
    -rw-r--r--  1 alexis  admin  5290 Sep  9 11:08 mime.types
    -rw-r--r--  1 alexis  admin  5290 Sep  9 11:08 mime.types.default
    -rw-r--r--  1 alexis  admin  1559 Sep  9 16:12 nginx.conf
    -rw-r--r--  1 alexis  admin  2680 Sep  9 12:45 nginx.conf.default
    -rw-r--r--  1 alexis  admin   636 Sep  9 11:08 scgi_params
    -rw-r--r--  1 alexis  admin   636 Sep  9 11:08 scgi_params.default
    drwxr-xr-x  2 alexis  admin    64 Sep  9 11:08 servers
    drwxr-xr-x  3 alexis  admin    96 Sep  9 16:00 sites-available
    drwxr-xr-x  3 alexis  admin    96 Sep  9 16:17 sites-enabled
    -rw-r--r--  1 alexis  admin   664 Sep  9 11:08 uwsgi_params
    -rw-r--r--  1 alexis  admin   664 Sep  9 11:08 uwsgi_params.default
    -rw-r--r--  1 alexis  admin  3610 Sep  9 11:08 win-utf

    Voici a quoi ressemble mon fichier "/usr/local/etc/nginx/nginx.conf" :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    #user  nobody;
    worker_processes  1;
    
    #error_log  logs/error.log;
    #error_log  logs/error.log  notice;
    #error_log  logs/error.log  info;
    
    #pid        logs/nginx.pid;
    
    
    events {
        worker_connections  1024;
    }
    
    
    http {
        include       mime.types;
        default_type  application/octet-stream;
    
        #log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
        #                  '$status $body_bytes_sent "$http_referer" '
        #                  '"$http_user_agent" "$http_x_forwarded_for"';
    
        #access_log  logs/access.log  main;
    
        sendfile        on;
        #tcp_nopush     on;
    
        #keepalive_timeout  0;
        keepalive_timeout  65;
    
        #gzip  on;
    
        
    
    
        # another virtual host using mix of IP-, name-, and port-based configuration
        #
        #server {
        #    listen       8000;
        #    listen       somename:8080;
        #    server_name  somename  alias  another.alias;
    
        #    location / {
        #        root   html;
        #        index  index.html index.htm;
        #    }
        #}
    
    
        # HTTPS server
        #
        #server {
        #    listen       443 ssl;
        #    server_name  localhost;
    
        #    ssl_certificate      cert.pem;
        #    ssl_certificate_key  cert.key;
    
        #    ssl_session_cache    shared:SSL:1m;
        #    ssl_session_timeout  5m;
    
        #    ssl_ciphers  HIGH:!aNULL:!MD5;
        #    ssl_prefer_server_ciphers  on;
    
        #    location / {
        #        root   html;
        #        index  index.html index.htm;
        #    }
        #}
        include servers/*;
        include /etc/nginx/conf.d/*;
        include /etc/nginx/sites-enabled/*;
    }
    Et voici a quoi ressemble mon site test dans "/usr/local/etc/nginx/sites-available" : ( le fichier dans sites-available s'appel "exemple.local" )

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    server {
            listen       8080;
            server_name  exemple.local;
    
            #charset koi8-r;
    
            #access_log  logs/host.access.log  main;
    
            location / {
                root   html/exemple.local;
                index  index.html index.htm;
            }
    
            #error_page  404              /404.html;
    
            # redirect server error pages to the static page /50x.html
            #
            error_page   500 502 503 504  /50x.html;
            location = /50x.html {
                root   html;
            }
    
            # proxy the PHP scripts to Apache listening on 127.0.0.1:80
            #
            #location ~ \.php$ {
            #    proxy_pass   http://127.0.0.1;
            #}
    
            # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
            #
            #location ~ \.php$ {
            #    root           html;
            #    fastcgi_pass   127.0.0.1:9000;
            #    fastcgi_index  index.php;
            #    fastcgi_param  SCRIPT_FILENAME  /scripts$fastcgi_script_name;
            #    include        fastcgi_params;
            #}
    
            # deny access to .htaccess files, if Apache's document root
            # concurs with nginx's one
            #
            #location ~ /\.ht {
            #    deny  all;
            #}
        }
    Et apres tout ca, j'ai relance mon serveur avec la commande "sudo brew services restart nginx"

    Merci d'avance pour votre aide. J'ai essaye je ne sais combien de fois mais en vain.

  2. #2
    Membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    octobre 2018
    Messages
    63
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Loire (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : octobre 2018
    Messages : 63
    Points : 60
    Points
    60
    Par défaut
    Wooowww, j'ai trouvé mon erreur, bizarre d'ailleurs.
    Je poste pour les gens qui un jour auraient le même problème.

    Dans mon fichier nginx.conf, j'ai modifié les dernières lignes en ajoutant les chemins absolus et voila.
    Donc pour moi c'était :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    include /usr/local/etc/nginx/conf.d/*;
    include /usr/local/etc/nginx/sites-enabled/*;
    include servers/*;
    Si quelqu'un sait pourquoi il fallait mettre les absolus plutôt que les relatifs je suis preneur. ( en sachant que j'ai pas trop trop d'experience avec les serveurs en general )
    Bon code à tous !!

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [Mail] mail() localhost erreur
    Par keub51 dans le forum Langage
    Réponses: 4
    Dernier message: 18/04/2007, 17h03
  2. [log4j][debutant] erreur de configuration
    Par hugo123 dans le forum Logging
    Réponses: 2
    Dernier message: 01/12/2006, 14h50
  3. erreur de configuration
    Par tonton12 dans le forum WebDev
    Réponses: 1
    Dernier message: 29/08/2006, 21h24
  4. [Continuum] Bug ou erreur de configuration ?
    Par elitost dans le forum Intégration Continue
    Réponses: 2
    Dernier message: 15/08/2006, 23h11
  5. [VB.NET] Erreur de configuration
    Par toniolol dans le forum ASP.NET
    Réponses: 2
    Dernier message: 04/12/2005, 11h35

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo