IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre du Club
    Profil pro
    Étudiant
    Inscrit en
    juin 2010
    Messages
    97
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : juin 2010
    Messages : 97
    Points : 53
    Points
    53
    Par défaut Comptabiliser nombre cellules contenant un caractère spécifique suivant une colonne renvoyée par une cellule
    Bonjour,

    Je m'explique sur l'intitulé du post qui peut être complexe :

    Je ne souhaite pas être sur VBA.

    J'ai une cellule qui indique la date actuelle (fonction AUJOURDHUI()). A partir de cela, je souhaite que EXCEL recherche la colonne correspondante sur un tableau.

    En fait le tableau se compose de 365 colonnes (une colonne par jour) (pour les vannes sur les années bissextiles, passez le chemin ) et de x lignes (je peux en mettre 2 ou 30 lignes) dont une ligne présente la présence d'une personne en fonction du jour.

    Par exemple pour une personne (Aurélie) il y a des cases qui contiennent "P" (pour signifier Présent), d'autres cases qui contiennent "A" (pour absent) et les dernières qui contiennent "I" (indisponibles). Même chose pour Bastien, Charlie, Delphine etc...

    L'idée est que EXCEL me retourne sur trois cases le nombre de personnes présentes (donc le caractère P), absents ("A") et indisponibles ("I") pour aujourd'hui.

    J'ai essayé avec EQUIV et INDEX mais je n'arrive pas à boucler avec le fait que ça se porte sur une colonne et non sur une cellule.

    Je vous remercie d'avance pour vos aides !

    Bonne journée !

  2. #2
    Rédacteur
    Avatar de Philippe Tulliez
    Homme Profil pro
    Formateur, développeur et consultant Excel, Access, Word et VBA
    Inscrit en
    janvier 2010
    Messages
    10 898
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations professionnelles :
    Activité : Formateur, développeur et consultant Excel, Access, Word et VBA

    Informations forums :
    Inscription : janvier 2010
    Messages : 10 898
    Points : 26 087
    Points
    26 087
    Billets dans le blog
    34
    Par défaut
    Bonjour,
    J'aurais organisé mes données autrement et utilisé les tableaux croisé dynamiques mais bon voici une solution avec SOMMEPROD

    La formule en cellule C2
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMMEPROD( ($B$4:$V$4=$B2) * ($B$5:$V$10=C1) )
    Illustration de l'organisation des données (les présences et absences de B5 à V10

    Nom : 210903 - dvp Présences_Absences.png
Affichages : 27
Taille : 16,4 Ko
    Philippe Tulliez
    Ce que l'on conçoit bien s'énonce clairement, et les mots pour le dire arrivent aisément. (Nicolas Boileau)
    Lorsque vous avez la réponse à votre question, n'oubliez pas de cliquer sur et si celle-ci est pertinente pensez à voter
    Mes tutoriels : Utilisation de l'assistant « Insertion de fonction », Les filtres avancés ou élaborés dans Excel
    Ma dernière contribution : VBA - Les macros complémentaires

  3. #3
    Expert confirmé
    Homme Profil pro
    Responsable des études
    Inscrit en
    juillet 2014
    Messages
    2 477
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Aude (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Responsable des études
    Secteur : Santé

    Informations forums :
    Inscription : juillet 2014
    Messages : 2 477
    Points : 5 353
    Points
    5 353
    Par défaut
    Bonjour,

    Une proposition avec une formule nb.si qui se décale suivant suivant la date:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =NB.SI(DECALER($B:$B;0;EQUIV(J$1;$C$1:$H$1));$I2)
    Nom : 2021_09_03_11_48_06_Microsoft_Excel_Classeur2.jpg
Affichages : 25
Taille : 51,8 Ko
    J'aimerais bien aller vivre en Théorie, car en Théorie tout se passe bien.

  4. #4
    Membre confirmé
    Homme Profil pro
    ingénieur
    Inscrit en
    mars 2015
    Messages
    157
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : ingénieur

    Informations forums :
    Inscription : mars 2015
    Messages : 157
    Points : 456
    Points
    456
    Par défaut
    Bonjour

    Citation Envoyé par ThonySp Voir le message

    J'ai essayé avec EQUIV et INDEX mais je n'arrive pas à boucler avec le fait que ça se porte sur une colonne et non sur une cellule.
    Pour qu'un INDEX renvoie une colonne il ne faut rien mettre dans l'argument "ligne" : INDEX(Plage;;3) renverra toute la 3eme colonne de "Plage"

    Donc pour vous NB.SI(INDEX(VosDonnées;;EQUIV(AUJOURDHUI();VotreLignedeDates;0));"P") renverra le nombre de présents aujourd'hui.

    Stéphane

  5. #5
    Membre du Club
    Profil pro
    Étudiant
    Inscrit en
    juin 2010
    Messages
    97
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : juin 2010
    Messages : 97
    Points : 53
    Points
    53
    Par défaut
    Bonjour à vous 3,

    Je vous remercie pour vos contributions ! J'ai essayé celui proposé par Philippe Thulliez qui fonctionne bien et correspond bien à mon besoin.

    Merci encore et bonne journée !

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 6
    Dernier message: 02/09/2016, 23h59
  2. Réponses: 4
    Dernier message: 14/04/2016, 14h08
  3. Réponses: 2
    Dernier message: 06/11/2013, 12h03
  4. Réponses: 1
    Dernier message: 22/10/2013, 22h57
  5. compter un caractère spécifique dans une colonne
    Par m93.fred dans le forum Langage SQL
    Réponses: 1
    Dernier message: 22/01/2008, 15h01

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo