IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Arduino Discussion :

Pas de compilation avec un ESP 32


Sujet :

Arduino

  1. #1
    Membre habitué
    Homme Profil pro
    Webmaster
    Inscrit en
    mai 2011
    Messages
    241
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 59
    Localisation : France

    Informations professionnelles :
    Activité : Webmaster
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : mai 2011
    Messages : 241
    Points : 145
    Points
    145
    Par défaut Pas de compilation avec un ESP 32
    Voilà,

    Sur un portable Apple, j'ai installé Arduino IDE avec le site arduino.cc,
    puis j'ai ensuite rajouté le lien qui ajoute d'autres cartes dans Préférences ( vers l'ESP 32).

    Mais, maintenant, j'ai systématiquement une erreur de compilation quelque soit le code d'exemple que je lance.

    Je précise que la carte est reconnue, mais il doit manquer quelque chose !

    Un problème de librairie sans doute, mais comment rectifier ?

  2. #2
    Responsable Arduino et Systèmes Embarqués

    Avatar de f-leb
    Homme Profil pro
    Enseignant
    Inscrit en
    janvier 2009
    Messages
    11 643
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 50
    Localisation : France, Sarthe (Pays de la Loire)

    Informations professionnelles :
    Activité : Enseignant

    Informations forums :
    Inscription : janvier 2009
    Messages : 11 643
    Points : 51 314
    Points
    51 314
    Billets dans le blog
    19
    Par défaut
    Bonsoir,

    Citation Envoyé par frederic13870 Voir le message
    Sur un portable Apple, j'ai installé Arduino IDE avec le site arduino.cc,
    puis j'ai ensuite rajouté le lien qui ajoute d'autres cartes dans Préférences ( vers l'ESP 32).
    Il y a d'autres étapes, dans l'EDI :
    - Outils / type de carte / Gestionnaire de carte, puis rechercher et installer le gestionnaire "esp32" d'Espressif
    - Outils / type de carte, puis sélectionner le kit esp32

  3. #3
    Membre habitué
    Homme Profil pro
    Webmaster
    Inscrit en
    mai 2011
    Messages
    241
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 59
    Localisation : France

    Informations professionnelles :
    Activité : Webmaster
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : mai 2011
    Messages : 241
    Points : 145
    Points
    145
    Par défaut Merci, mais
    J'avais franchi ces étapes.
    En plus, sur un Mac, il faut télécharger un driver qui permet de piloter l'UART de la puce, ce que je n'avais pas fait.
    Je n'avais donc pas accès au bon port de sortie.
    Cependant, mon Mac est trop vieux pour installer celui-ci.
    J'ai donc choisis de programmer via un raspberry pi qui lui, ne nécessite seulement d'installer la carte.
    Mais, merci pour l'aide.

  4. #4
    Membre expert

    Homme Profil pro
    mad scientist :)
    Inscrit en
    septembre 2019
    Messages
    1 695
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : mad scientist :)

    Informations forums :
    Inscription : septembre 2019
    Messages : 1 695
    Points : 3 299
    Points
    3 299
    Par défaut
    Citation Envoyé par frederic13870 Voir le message
    J'avais franchi ces étapes.
    En plus, sur un Mac, il faut télécharger un driver qui permet de piloter l'UART de la puce, ce que je n'avais pas fait.
    Je n'avais donc pas accès au bon port de sortie.
    Cependant, mon Mac est trop vieux pour installer celui-ci.
    Sur mes anciens mac j'ai généralement trouvé le driver qui allait bien sur https://mac-usb-serial.com
    (c'est payant mais de qualité)

  5. #5
    Membre expert

    Homme Profil pro
    mad scientist :)
    Inscrit en
    septembre 2019
    Messages
    1 695
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : mad scientist :)

    Informations forums :
    Inscription : septembre 2019
    Messages : 1 695
    Points : 3 299
    Points
    3 299
    Par défaut
    Alors vous vous en êtes sorti?

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. compiler avec Qt == ne trouve pas Phonon
    Par phast dans le forum Qt
    Réponses: 2
    Dernier message: 02/12/2008, 17h07
  2. Problème de compilation avec gfortran et pas ifort
    Par Ladgalen dans le forum Fortran
    Réponses: 2
    Dernier message: 22/02/2008, 11h38
  3. Pas de compilation avec Dev cpp
    Par koKoTis dans le forum Dev-C++
    Réponses: 2
    Dernier message: 27/12/2006, 14h30
  4. Compile avec VC8, mais pas MinGW GCC 3.4.5
    Par Aszarsha dans le forum Visual C++
    Réponses: 3
    Dernier message: 01/09/2006, 13h26
  5. Réponses: 27
    Dernier message: 23/03/2006, 07h33

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo