IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Plateformes réactives et architectures modulaires Java Discussion :

Feature camel-hbase dans mon container karaf


Sujet :

Plateformes réactives et architectures modulaires Java

  1. #1
    Membre éprouvé
    Homme Profil pro
    Architecte Décisionnel
    Inscrit en
    février 2008
    Messages
    864
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Architecte Décisionnel

    Informations forums :
    Inscription : février 2008
    Messages : 864
    Points : 1 258
    Points
    1 258
    Par défaut Feature camel-hbase dans mon container karaf
    Bonjour,

    J'utilise l'outil Talend Open Studio ESB comme outil de développement pour créer une route camel que je tente de déployer ensuite dans un container karaf.
    La route que je crée utilise la feature camel-hbase, ça fonctionne bien lorsque je la test dans le studio de développement Talend. Mais lorsque je tente de la déployer dans le runtime karaf (fourni par Talend), j'ai cette erreur :
    org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=Test_HBase_com_body-feature; type=karaf.feature; version="[0.1.0,0.1.0]"; filter:="(&(osgi.identity=Test_HBase_com_body-feature)(type=karaf.feature)(version>=0.1.0)(version<=0.1.0))" [caused by: Unable to resolve Test_HBase_com_body-feature/0.1.0: missing requirement [Test_HBase_com_body-feature/0.1.0] osgi.identity; osgi.identity=camel-hbase; type=karaf.feature]
    Je comprends qu'il manque la librairie camel-hbase dans karaf, pourtant j'ai bien d'autres fonctionnalités camel :
    Nom : renditionDownload.png
Affichages : 106
Taille : 10,5 Ko

    Je ne suis pas développeur java à la base, du coup je ne maîtrise pas le fonctionnement des configurations des dépendances avec les pom.xls et les paramétrages maven...
    Si quelqu'un pouvait m'orienter sur ce que je dois faire pour installer cette feature camel-hbase dans karaf, ce serait super.

    Pour info, j'ai mis un message sur les forums Talend à ce sujet, sans succès pour l'instant : https://community.talend.com/s/quest...e-not-in-karaf

    Par avance merci !
    Nicolas

  2. #2
    Membre éprouvé
    Homme Profil pro
    Architecte Décisionnel
    Inscrit en
    février 2008
    Messages
    864
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Architecte Décisionnel

    Informations forums :
    Inscription : février 2008
    Messages : 864
    Points : 1 258
    Points
    1 258
    Par défaut
    Pour ceux que ça intéresse, je me suis rendu compte que la feature camel-hbase n'était plus dans les repo camel dans les versions 2.24 ou 3.2.0 par exemple.
    Du coup il faut que je trouve comment je suis sensé gérer ça au niveau karaf, vu que ça fonctionne dans mon studio talend...

    Nicolas

  3. #3
    Membre éprouvé
    Homme Profil pro
    Architecte Décisionnel
    Inscrit en
    février 2008
    Messages
    864
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Architecte Décisionnel

    Informations forums :
    Inscription : février 2008
    Messages : 864
    Points : 1 258
    Points
    1 258
    Par défaut
    Hello,

    Je me permets de renouveler mon appel à l'aide : Est-ce que quelqu'un aurait une idée de comment je peux envisager de récupérer ma feature camel-hbase au niveau de mon karaf ?

    Merci,
    Nicolas

Discussions similaires

  1. Feature camel-hbase dans mon container karaf
    Par DevNico dans le forum Services Web
    Réponses: 0
    Dernier message: 19/03/2021, 10h17
  2. [Lien]erreur dans mon programme python
    Par durnambule dans le forum Général Python
    Réponses: 11
    Dernier message: 29/01/2004, 15h59
  3. [langage] algo de bissection dans mon code
    Par killy dans le forum Langage
    Réponses: 5
    Dernier message: 19/01/2004, 19h35
  4. Réponses: 7
    Dernier message: 26/06/2003, 10h11
  5. [] Utiliser AVI d'une DLL dans mon programme
    Par seb.49 dans le forum VB 6 et antérieur
    Réponses: 5
    Dernier message: 02/05/2003, 15h52

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo