IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Futur Membre du Club
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    septembre 2015
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : septembre 2015
    Messages : 6
    Points : 5
    Points
    5
    Par défaut move_uploaded_file() : failed to open stream: Permission denied in
    Bonjour,

    J'ai transféré un site web en local sur mon nouveau Mac et j'ai un problème d'upload de fichier dans ma base de données (j'utilise XAMPP + phpMyAdmin).

    Quand j'ouvre mon site tout va bien : toutes les données de ma base de données sont bien lues. Je peux même les supprimer et les modifier via un formulaire html. Les changements sont bien répercutés sur ma db.
    Mais le problème se passe lorsque je veux uploader des nouvelles données. Impossible.
    Pourtant, sur mon ancien ordi (un windows pour le coup), tout marche nickel. Je n'ai rien changé au code. Juste fait copier-coller.

    J'ai l'erreur suivante :

    Warning: move_uploaded_file(../images/films/123 soleil_320x182.png): failed to open stream: Permission denied in /Applications/XAMPP/xamppfiles/htdocs/Lesquatreastrophes_site/admin/videos_add.php on line 61

    Warning: move_uploaded_file(): Unable to move '/Applications/XAMPP/xamppfiles/temp/php16EUeL' to '../images/films/123 soleil_320x182.png' in /Applications/XAMPP/xamppfiles/htdocs/Lesquatreastrophes_site/admin/videos_add.php on line 61



    En regardant sur internet, j'ai vu des solutions qui parlaient de chmod 777 ou d'user apache mais ça dépasse largement mes compétences...

    J'ai du mal à saisir pourquoi il ya des problèmes de droits pour l'upload mais pas pour le delete...

    J'imagine que c'est un pb un peu basique lors de changements de serveurs mais si qqn pouvait éclairer ma (faible) lanterne...

    Merci par avance

  2. #2
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 243
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 243
    Points : 32 733
    Points
    32 733
    Par défaut
    Je pense que c'est du aux sécurités des nouvelles versions de Mac OS. A regarder du coté de sécurité et confidentialité. Si tu passes par les tableaux de bord de Xamp, les droits devraient être correct.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutoriels/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  3. #3
    Futur Membre du Club
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    septembre 2015
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : septembre 2015
    Messages : 6
    Points : 5
    Points
    5
    Par défaut
    Merci chrtophe

    C'était bien un verrouillage d'accès au niveau des fichiers htdocs de XAMPP.
    Je les ai mis en lecture / écriture pour tous les sous-dossiers et ça fonctionne.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 11
    Dernier message: 25/10/2019, 08h46
  2. move_uploaded_file failed to open stream
    Par dubitoph dans le forum Langage
    Réponses: 2
    Dernier message: 27/05/2013, 16h29
  3. failed to open stream: Permission denied
    Par HEDDI dans le forum Langage
    Réponses: 1
    Dernier message: 31/07/2010, 01h45
  4. Warning: move_uploaded_file : failed to open stream sur IIS
    Par van___fanel dans le forum Langage
    Réponses: 1
    Dernier message: 03/03/2010, 23h15
  5. Réponses: 1
    Dernier message: 02/09/2007, 14h45

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo