IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    autre
    Inscrit en
    avril 2020
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : autre

    Informations forums :
    Inscription : avril 2020
    Messages : 4
    Points : 1
    Points
    1
    Par défaut Serveur Apache inaccessible en IP locale uniquement
    Bonjour,

    Sur mon serveur Apache 2.4+Centos 8, j'ai plusieurs sites (xxx.monsite.fr yyy.monsite.fr monsite.fr) accessibles depuis le web , depuis mon réseau local (loopback) et en tapant l'adresse ip local de mon serveur : 192.168.55.55/xxx ; 192.168.55.55/yyy et 192.168.55.55 .

    Mes pages sont stockées dans /var/www/html/xxx , /var/www/html/yyy et dans /var/www/html/


    Tout fonctionne bien depuis plusieurs années.

    Hier j'ai voulu ajouter un dossier zzz pour un nouveau site zzz.monsite.fr mais pour me faciliter son développement sur un pc windows sur le même réseau local j'ai voulu partager ce dossier /var/www/html/zzz/ en installant un serveur Samba.

    Le serveur de fichier samba fonctionne mais j'ai cassé quelque chose dans la configuration apache (ou autre ???) et depuis je n'accède plus à mes sites depuis l'IP de mon serveur sur mon réseau local:
    - ils sont toujours accessible depuis le web (testé en passant par proton vpn)
    - ils sont toujours accessibles depuis mon réseau local avec leurs adresses de type xxx.monsite.fr
    - ils ne sont plus accessibles depuis mon réseau local avec leur IP ( 192.168.55.55/xxx )
    - quand je tape l'IP du serveur (192.168.55.55) j'accède au site zzz et quand je saisis 192.168.55.55/zzz (ou xxx ou yyy) j'ai une page d'erreur (The requested URL was not found on this serveur)


    J'ai cherché un peu partout sur le web mais généralement c'est plutôt l'inverse qui se produit comme problème.

    Quelles sont les voies d'investigation que vous me conseillez pour identifier et résoudre ce problème ?

    Bonne soirée,

  2. #2
    Nouveau Candidat au Club
    Homme Profil pro
    autre
    Inscrit en
    avril 2020
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : autre

    Informations forums :
    Inscription : avril 2020
    Messages : 4
    Points : 1
    Points
    1
    Par défaut
    J'ai supprimé mes fichiers de configuration du virtual host pour le site zzz.monsite.fr (zzz.conf et zzz-le-ssl.conf) qui j'avais mis avec les autres dans /etc/httpd/conf.d/ et tous est revenu comme avant ... sauf que pour l'instant zzz n'est plus accessible ...forcément.

    Comment dois-je faire pour accéder au site zzz (sur /var/www/html/zzz/) en passant en local et en externe ?

  3. #3
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    8 102
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 8 102
    Points : 12 607
    Points
    12 607
    Par défaut
    quand vous remettez en place l'ancienne configuration d'Apache, tout refonctionne comme avant ?

  4. #4
    Nouveau Candidat au Club
    Homme Profil pro
    autre
    Inscrit en
    avril 2020
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : autre

    Informations forums :
    Inscription : avril 2020
    Messages : 4
    Points : 1
    Points
    1
    Par défaut
    oui voilà ! en fait je n'ai pas su lier le dossier zzz qui contient mon site et l'adresse du site zzz.monsite.com .

    Ce n'est pas ma partie et j'avais touché à ça il y a trop longtemps ... pour que je m'en souvienne ...

    Il faut définir un virtual host c'est ça ? mais comment faut-il faire dans les règles de l'art ?

  5. #5
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    8 102
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 8 102
    Points : 12 607
    Points
    12 607
    Par défaut
    montrez nous les fichiers de configuration que vous avez essayé pour zzz.

  6. #6
    Nouveau Candidat au Club
    Homme Profil pro
    autre
    Inscrit en
    avril 2020
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : autre

    Informations forums :
    Inscription : avril 2020
    Messages : 4
    Points : 1
    Points
    1
    Par défaut
    le voici : j'ai simplement copié celui de yyy !

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    <VirtualHost *:80>
            ServerName zzz.monsite.fr
     
            DocumentRoot "/var/www/html/zzz/"
            <Directory "/var/www/html/zzz/">
                    Options Indexes FollowSymLinks
                    AllowOverride All
            </Directory>
    RewriteEngine on
    RewriteCond %{SERVER_NAME} =zzz.monsite.fr
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    </VirtualHost>

Discussions similaires

  1. Apache inaccessible depuis le réseau local
    Par chaying dans le forum Apache
    Réponses: 4
    Dernier message: 11/04/2010, 14h32
  2. livebox reseau local pc serveur apache
    Par mapmip dans le forum Administration
    Réponses: 2
    Dernier message: 25/07/2009, 16h41
  3. Problème avec Blast sur serveur Apache local
    Par jobim08 dans le forum Apache
    Réponses: 6
    Dernier message: 20/02/2009, 10h19
  4. Réponses: 1
    Dernier message: 28/05/2008, 17h00
  5. Serveur Apache problème uniquement au port 80
    Par Phoenix0007 dans le forum Apache
    Réponses: 1
    Dernier message: 27/05/2008, 21h03

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo