IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Bases de données Delphi Discussion :

Delphi7, Zeos DB et Postgres


Sujet :

Bases de données Delphi

  1. #1
    Membre actif
    Inscrit en
    décembre 2004
    Messages
    376
    Détails du profil
    Informations forums :
    Inscription : décembre 2004
    Messages : 376
    Points : 286
    Points
    286
    Par défaut Delphi7, Zeos DB et Postgres
    Bonsoir,

    Je veens d'avoir un soucis de connexion en design-time. En effet, qd j'essaie d'ouvrir une simple requête telle : j'ai un message m'indiquant que la table ARTICLE n'existe pas alors qu'elle existe bel et bien, d'ailleurs qd j'exécute le pgm, la requête s'ouvre le plus normalement du monde.

    Je signale que Le TZConnection se connecte bien à la base PostGres en design-Time.


    Une idée ??

    W10, Delphi 7, Zeos 7.2.6, PostgresSQL

  2. #2
    Expert éminent sénior
    Avatar de Paul TOTH
    Homme Profil pro
    Freelance
    Inscrit en
    novembre 2002
    Messages
    8 269
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Freelance
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2002
    Messages : 8 269
    Points : 26 775
    Points
    26 775
    Par défaut
    tu ne fais aucun paramétrage au démarrage de l'appli ?

    si mon souvenir est bon, sous Postgres tu as une notion de schema au dessus des tables, tu dois avoir une différence sur ce point entre le designtime et le runtime.
    Developpez.com: Mes articles, forum FlashPascal
    Entreprise: Execute SARL
    Le Store Excute Store

  3. #3
    Membre actif
    Inscrit en
    décembre 2004
    Messages
    376
    Détails du profil
    Informations forums :
    Inscription : décembre 2004
    Messages : 376
    Points : 286
    Points
    286
    Par défaut
    Je fais exactement les mêmes requêtes à savoir : A l'exécution, ça fonctionne bien mais en design-time, y a le message : Unknown table article.

    J'ai même essayé, en design-time, de faire ceci :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    SELECT * FROM PUBLIC.ARTICLE
    Le résultat est le même.

    Le hic c'est que quand j'utilise un composant TZTable, le problème ne se pose pas !

  4. #4
    Membre actif
    Inscrit en
    décembre 2004
    Messages
    376
    Détails du profil
    Informations forums :
    Inscription : décembre 2004
    Messages : 376
    Points : 286
    Points
    286
    Par défaut
    Bonjour,

    Le mystère Delphi-Zeos-Postgres s'épaissit encore un peu !

    Tenez-vous bien, je viens d'ajouter une table à la base de données et, curieusement, celle-ci est accessible en design-time contrairement aux autres tables de la même base,bien sûr !!

    Quelqu'un a une idée ??

Discussions similaires

  1. Perte de données firebird zeos delphi7
    Par mina24 dans le forum Bases de données
    Réponses: 8
    Dernier message: 13/10/2016, 21h24
  2. ZEOS delphi7 pas de connexion
    Par tarmo57 dans le forum Débuter
    Réponses: 9
    Dernier message: 01/09/2013, 08h53
  3. Réponses: 5
    Dernier message: 09/12/2002, 23h23
  4. [Kylix] Requetes Kylix pour postgres
    Par Miltown dans le forum EDI
    Réponses: 1
    Dernier message: 29/05/2002, 21h22
  5. [Kylix] Kylix - Postgres
    Par Miltown dans le forum EDI
    Réponses: 1
    Dernier message: 29/05/2002, 21h19

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo