IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Apache Discussion :

Error AH00526 dans httpd.conf


Sujet :

Apache

  1. #1
    Nouveau membre du Club
    Profil pro
    Inscrit en
    octobre 2005
    Messages
    44
    Détails du profil
    Informations personnelles :
    Âge : 63
    Localisation : France, Tarn (Midi Pyrénées)

    Informations forums :
    Inscription : octobre 2005
    Messages : 44
    Points : 33
    Points
    33
    Par défaut Error AH00526 dans httpd.conf
    Bonjour à tous,

    Je suis entrain de tester le non listage des fichiers et dossiers. Dans mon cas, je prends le dossier "test"
    J’exécute ceci dans httpd.conf :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    <Directory "/share/Web/htdocs/test/">
       Options -Indexes -FollowSymLinks
       AllowOverride None
       Order allow,deny
       allow from all 
    </Directory>
    Or dans la version 2.4.4.6, j'ai l'erreur suivante :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    AH00526: Syntax error on line 268 of /share/etc/httpd.conf:
    Either all Options must start with + or -, or no Option may.
    Si je comprends bien, toutes les options doivent commencer par + ou -.
    Mais alors d'ou vient cette erreur ? Quelqu'un pourrait-il m'orienter ?

    Par avance merci
    -------------
    - Apache serveur 2.4.4.6
    - Php 8.0.2 / 7.4.15
    - 5.5.57-MariaDB / 10.5.8-MariaDB
    - Qnap serveur TS-473

  2. #2
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    8 102
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 8 102
    Points : 12 607
    Points
    12 607
    Par défaut
    est ce que vous utilisez "Options" à un autre endroit du fichier ? par exemple pour configurer le répertoire "/share/Web/htdocs/" ?

  3. #3
    Nouveau membre du Club
    Profil pro
    Inscrit en
    octobre 2005
    Messages
    44
    Détails du profil
    Informations personnelles :
    Âge : 63
    Localisation : France, Tarn (Midi Pyrénées)

    Informations forums :
    Inscription : octobre 2005
    Messages : 44
    Points : 33
    Points
    33
    Par défaut
    Bonjour Mathieu,

    oui, dans =>

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    <Directory "/share/Web/htdocs">    
        Options Indexes FollowSymLinks    
        AllowOverride None
        Require all granted
    </Directory>
    -------------
    - Apache serveur 2.4.4.6
    - Php 8.0.2 / 7.4.15
    - 5.5.57-MariaDB / 10.5.8-MariaDB
    - Qnap serveur TS-473

  4. #4
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    8 102
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 8 102
    Points : 12 607
    Points
    12 607
    Par défaut
    essayez de rajouter des "+" à ces options pour voir si cela change le message d'erreur.

Discussions similaires

  1. [mod_rewrite] marche dans httpd.conf pas avec .htaccess
    Par __fabrice dans le forum Apache
    Réponses: 3
    Dernier message: 08/05/2007, 21h12
  2. [Apache/WebDAV] Problème dans httpd.conf
    Par shadowmic dans le forum Subversion
    Réponses: 3
    Dernier message: 19/04/2007, 15h54
  3. Erreur dans httpd.conf
    Par PhiberOptik dans le forum Apache
    Réponses: 1
    Dernier message: 07/12/2006, 22h22
  4. [VirtualHost] dans httpd.conf
    Par polo55 dans le forum Apache
    Réponses: 3
    Dernier message: 03/10/2005, 11h20
  5. pas de trace de php dans httpd.conf ?
    Par ludophil dans le forum Apache
    Réponses: 2
    Dernier message: 27/08/2005, 10h06

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo