IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Rédacteur

    Avatar de naute
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2009
    Messages
    691
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2009
    Messages : 691
    Points : 2 888
    Points
    2 888
    Par défaut Problème d'affichage en mode plein-écran au démarrage
    Bonjour .

    J'ai quelques petits problèmes mineurs à régler (si c'est possible) et je commence par celui-là.
    Contexte :
    • hôte : Debian 9 ;
    • invité : Debian 10 ;
    • VirtualBox 6.1.12 (avec toutes les options ).

    Quand je lance ma machine virtuelle, configurée pour s'afficher en plein-écran au démarrage, tout se passe bien jusqu'à la demande de mot de passe inclue, mais après validation de celui-ci, mon écran reste vide (noir), à l'exception de l'affichage du curseur de la souris qui, pour info, est bien celui de l'invité.
    Ma solution actuelle est de passer en mode fenêtré avec un <HOST-F> puis de repasser en mode plein-écran, à nouveau avec un <HOST-F>. Ça prend deux secondes, ce n'est pas le problème, mais ça fait touriste.
    Quelqu'un aurait-il une idée à ce sujet ?

    Merci d'avance.

    Amicalement,
    naute

  2. #2
    Expert éminent sénior
    Avatar de Jipété
    Profil pro
    Inscrit en
    juillet 2006
    Messages
    9 280
    Détails du profil
    Informations personnelles :
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations forums :
    Inscription : juillet 2006
    Messages : 9 280
    Points : 13 187
    Points
    13 187
    Par défaut
    Salut,
    Citation Envoyé par naute Voir le message
    VirtualBox 6.1.12 (avec toutes les options ).
    Quelqu'un aurait-il une idée à ce sujet ?
    Aucune, à part passer en 6.1.18 (valable depuis 2 ou 3 jours je crois), des fois que...

    Mais sinon, c'est toujours la misère ces histoires.
    Il a à vivre sa vie comme ça et il est mûr sur ce mur se creusant la tête : peutêtre qu'il peut être sûr, etc.
    Oui, je milite pour l'orthographe et le respect du trait d'union à l'impératif.
    Après avoir posté, relisez-vous ! Et en cas d'erreur ou d'oubli, il existe un bouton « Modifier », à utiliser sans modération
    On a des lois pour protéger les remboursements aux faiseurs d’argent. On n’en a pas pour empêcher un être humain de mourir de misère.
    Mes 2 cts,
    --
    jp

  3. #3
    Rédacteur

    Avatar de naute
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2009
    Messages
    691
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2009
    Messages : 691
    Points : 2 888
    Points
    2 888
    Par défaut
    Bonjour Jipété .

    Citation Envoyé par Jipété Voir le message
    Aucune, à part passer en 6.1.18 (valable depuis 2 ou 3 jours je crois), des fois que...
    Tu ne m'aides pas beaucoup là-dessus . Alors oui, mais c'est un peu galère de faire des mises à jour mineures avec réinstallation des options, et la quasi certitude que ça ne réglera pas le problème.

    Citation Envoyé par Jipété Voir le message
    Mais sinon, c'est toujours la misère ces histoires.
    Je confirme !

  4. #4
    Expert éminent sénior
    Avatar de Jipété
    Profil pro
    Inscrit en
    juillet 2006
    Messages
    9 280
    Détails du profil
    Informations personnelles :
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations forums :
    Inscription : juillet 2006
    Messages : 9 280
    Points : 13 187
    Points
    13 187
    Par défaut
    Salut, naute,

    le problème c'est que les choses dans ce bas monde (Linux et les distros qui en découlent) sont de + en + buggées et mal fichues, et en ce qui nous concerne là maintenant tout de suite, quand je demande à régler l'affichage dans une machine virtuelle ça le fait et si je veux enregistrer la config ça me le propose mais ça ne le fait pas -- c'est comme ça...
    Il a à vivre sa vie comme ça et il est mûr sur ce mur se creusant la tête : peutêtre qu'il peut être sûr, etc.
    Oui, je milite pour l'orthographe et le respect du trait d'union à l'impératif.
    Après avoir posté, relisez-vous ! Et en cas d'erreur ou d'oubli, il existe un bouton « Modifier », à utiliser sans modération
    On a des lois pour protéger les remboursements aux faiseurs d’argent. On n’en a pas pour empêcher un être humain de mourir de misère.
    Mes 2 cts,
    --
    jp

  5. #5
    Rédacteur

    Avatar de naute
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2009
    Messages
    691
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2009
    Messages : 691
    Points : 2 888
    Points
    2 888
    Par défaut
    Salut Jipété .

    C'est dû à la course aux armements, et on en est largement responsables. On en veut toujours plus.

    Quand je considère la complexité de nos environnements (informatiques, s'entend), tant sur le plan matériel que logiciel, je suis toujours stupéfait (et ravi) que mon PC démarre quand j'appuie sur le bouton .

  6. #6
    Expert éminent sénior
    Avatar de Jipété
    Profil pro
    Inscrit en
    juillet 2006
    Messages
    9 280
    Détails du profil
    Informations personnelles :
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations forums :
    Inscription : juillet 2006
    Messages : 9 280
    Points : 13 187
    Points
    13 187
    Par défaut
    Yop !

    tiens, j'ai trouvé ça dans le User Manual de la 6.1.16, au $ 9.6
    Citation Envoyé par manuel
    Advanced Display Configuration
    9.6.1 Custom VESA Resolutions
    Apart from the standard VESA resolutions, the Oracle VM VirtualBox VESA BIOS enables you to
    add up to 16 custom video modes which will be reported to the guest operating system. When
    using Windows guests with the Oracle VM VirtualBox Guest Additions, a custom graphics driver
    will be used instead of the fallback VESA solution so this information does not apply.

    Additional video modes can be configured for each VM using the extra data facility. The extra
    data key is called CustomVideoModex with x being a number from 1 to 16. Please note that
    modes will be read from 1 until either the following number is not defined or 16 is reached. The
    following example adds a video mode that corresponds to the native display resolution of many
    notebook computers:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    $ VBoxManage setextradata <VM-name> "CustomVideoMode1" "1400x1050x16"
    et donc j'ai fait ainsi, pour une mv MX Linux :
    $ VBoxManage setextradata <MX> "CustomVideoMode1" "1280x800x24" et ma foi, ça a fonctionné, jusqu'au logging où juste après la fenêtre se réduit à 800x600 puis revient à 1280x800 et termine sa course à 800x600 à nouveau.

    J'ai beau forcer la ligne GUI/LastNormalWindowPosition à la bonne valeur dans le .vbox concerné, quand je rouvre le fichier MX.vbox après ouverture-fermeture de la mv, je retombe sur 800x644...
    (et ça me gonfle, ces comportements chelous, je te dis pas !)

    J'ai pourtant précisé dans /etc/default/grub, en haut :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    GRUB_CMDLINE_LINUX_DEFAULT="quiet video=1280x800 splash"
    et plus bas :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    GRUB_GFXMODE=1280x800x24
    GRUB_GFXPAYLOAD_LINUX=keep
    plus update-grub pour la prise en compte.
    Il a à vivre sa vie comme ça et il est mûr sur ce mur se creusant la tête : peutêtre qu'il peut être sûr, etc.
    Oui, je milite pour l'orthographe et le respect du trait d'union à l'impératif.
    Après avoir posté, relisez-vous ! Et en cas d'erreur ou d'oubli, il existe un bouton « Modifier », à utiliser sans modération
    On a des lois pour protéger les remboursements aux faiseurs d’argent. On n’en a pas pour empêcher un être humain de mourir de misère.
    Mes 2 cts,
    --
    jp

  7. #7
    Rédacteur

    Avatar de naute
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2009
    Messages
    691
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2009
    Messages : 691
    Points : 2 888
    Points
    2 888
    Par défaut
    .

    Nos problèmes sont différents : en ce qui te concerne, si j'ai bien compris, tu n'arrives pas à forcer la définition qui te convient, ce qui n'est pas mon cas. Merci quand même .
    Essaye à tout hasard de remplacer la ligne :
    Citation Envoyé par Jipété Voir le message
    $ VBoxManage setextradata <MX> "CustomVideoMode1" "1280x800x24"
    par :
    Code bash : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    VBoxManage controlvm <machine_virtuelle> setvideomodehint 1280 800 24
    en simple utilisateur depuis la machine hôte avec l'invité en cours d'utilisation.
    setvideomodehint force le système invité à utiliser le mode vidéo spécifié.
    Ça nécessite l'installation des suppléments "invité" et ça ne fonctionne pas pour tous les systèmes invités.
    Je suis malgré tout étonné que tu n’aies pas la résolution 1280x800 à disposition. Avec les suppléments "invité", tu devrais l'avoir en stock . Je suis actuellement en 1920x1080 mais je peux passer à 1280x800 sans problème.

  8. #8
    Expert éminent sénior
    Avatar de Jipété
    Profil pro
    Inscrit en
    juillet 2006
    Messages
    9 280
    Détails du profil
    Informations personnelles :
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations forums :
    Inscription : juillet 2006
    Messages : 9 280
    Points : 13 187
    Points
    13 187
    Par défaut
    Salut camarade,

    Citation Envoyé par naute Voir le message
    Je suis malgré tout étonné que tu n’aies pas la résolution 1280x800 à disposition. Avec les suppléments "invité", tu devrais l'avoir en stock . Je suis actuellement en 1920x1080 mais je peux passer à 1280x800 sans problème.
    Ah mais je l'ai ! (j'ai dû mal m'exprimer). C'est juste que si je la choisis et que le système la met en œuvre, ça ne survit pas à un reboot, faut refaire le setting après chaque logging...

    Alors oui, peut-être que ça a besoin des additions invité pour que le réglage devienne permanent, mais d'une part j'ai autre chose à faire avec cette machine et d'autre part si c'est proposé par l'os et qu'il est capable d'accepter le réglage, je ne vois pas ce que les GA apporteraient de plus.

    Bref, à suivre ou pas, et toi, où en es-tu ?
    Il a à vivre sa vie comme ça et il est mûr sur ce mur se creusant la tête : peutêtre qu'il peut être sûr, etc.
    Oui, je milite pour l'orthographe et le respect du trait d'union à l'impératif.
    Après avoir posté, relisez-vous ! Et en cas d'erreur ou d'oubli, il existe un bouton « Modifier », à utiliser sans modération
    On a des lois pour protéger les remboursements aux faiseurs d’argent. On n’en a pas pour empêcher un être humain de mourir de misère.
    Mes 2 cts,
    --
    jp

  9. #9
    Rédacteur

    Avatar de naute
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2009
    Messages
    691
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2009
    Messages : 691
    Points : 2 888
    Points
    2 888
    Par défaut
    Salut Jipété .

    Citation Envoyé par Jipété Voir le message
    Ah mais je l'ai ! (j'ai dû mal m'exprimer).
    Non non ! Je viens de relire : c'est moi qui ai mal interprété .

    Citation Envoyé par Jipété Voir le message
    et toi, où en es-tu ?
    Ben ! avant d'ouvrir cette discussion, j'ai pas mal épluché la doc, sollicité l'ami Gogol (enfin, c'est plutôt DuckDuck en ce qui me concerne), et bien sûr ce forum, sans rien trouver sur le sujet. Donc toutes les nouveautés sont sur ce fil, et comme tu le suis (du verbe suivre, hein ), je n'ai pas besoin de te faire un dessin .

  10. #10
    Rédacteur

    Avatar de naute
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2009
    Messages
    691
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2009
    Messages : 691
    Points : 2 888
    Points
    2 888
    Par défaut
    Salut Jipété .

    Citation Envoyé par Jipété Voir le message
    Alors oui, peut-être que ça a besoin des additions invité pour que le réglage devienne permanent, mais d'une part j'ai autre chose à faire avec cette machine et d'autre part si c'est proposé par l'os et qu'il est capable d'accepter le réglage, je ne vois pas ce que les GA apporteraient de plus.
    J'ai fait une petite recherche sur ton cas : il semble pourtant bien que cela vienne de l'absence des GA. Tu peux jeter un œil ici et si ça te dit.
    En gros, le mix des deux donne :

  11. #11
    Expert éminent sénior
    Avatar de Jipété
    Profil pro
    Inscrit en
    juillet 2006
    Messages
    9 280
    Détails du profil
    Informations personnelles :
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations forums :
    Inscription : juillet 2006
    Messages : 9 280
    Points : 13 187
    Points
    13 187
    Par défaut
    Yep, naute !

    Merci infiniment pour le coup de main. Résultat des courses des manips :
    - install des GA = négatif.
    - lecture de ton lien, qui m'a envoyé ailleurs avec une ligne de commande bien bizarre : VBoxManage setextradata "MX" "GUI/LastGuestSizeHint" sans indiquer de valeurs et bien sûr ça a foiré, alors j'ai improvisé avec VBoxManage setextradata "MX" "GUI/LastGuestSizeHint" "1280,800" et c'est enfin tombé en marche !
    - vérification aussi en l2cde avec VBoxManage getextradata "MX" "GUI/LastGuestSizeHint".

    Noter la différence entre set et get !

    Mais je ne comprends pas que sur la page en question l'OP ait "quoté" le lendemain l'instruction incomplète avec "Problem solved now. Thanks!" comme commentaire,

    Merci encore et bon dimanche,
    Il a à vivre sa vie comme ça et il est mûr sur ce mur se creusant la tête : peutêtre qu'il peut être sûr, etc.
    Oui, je milite pour l'orthographe et le respect du trait d'union à l'impératif.
    Après avoir posté, relisez-vous ! Et en cas d'erreur ou d'oubli, il existe un bouton « Modifier », à utiliser sans modération
    On a des lois pour protéger les remboursements aux faiseurs d’argent. On n’en a pas pour empêcher un être humain de mourir de misère.
    Mes 2 cts,
    --
    jp

  12. #12
    Rédacteur

    Avatar de naute
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2009
    Messages
    691
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2009
    Messages : 691
    Points : 2 888
    Points
    2 888
    Par défaut
    Citation Envoyé par Jipété Voir le message
    - lecture de ton lien, qui m'a envoyé ailleurs
    Le "ailleurs" dont tu parles correspond au second lien que je te donnais .

    Citation Envoyé par Jipété Voir le message
    Merci encore et bon dimanche,
    Avec plaisir et bon dimanche à toi .

Discussions similaires

  1. Un petit problème de centrage en mode plein écran
    Par lanka133 dans le forum ActionScript 1 & ActionScript 2
    Réponses: 0
    Dernier message: 04/01/2011, 16h03
  2. Formulaires en mode plein écran
    Par PAUL87 dans le forum IHM
    Réponses: 18
    Dernier message: 26/11/2005, 11h45
  3. Presentation d'un formulaire en mode plein écran
    Par PAUL87 dans le forum Access
    Réponses: 4
    Dernier message: 13/11/2005, 20h04
  4. mode plein écran
    Par Rinoud dans le forum Agents de placement/Fenêtres
    Réponses: 8
    Dernier message: 30/09/2004, 01h04
  5. Réponses: 17
    Dernier message: 17/10/2002, 20h06

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo