IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

ODS et reporting Discussion :

Encoding dans SAS Studio 3.8 English version?


Sujet :

ODS et reporting

  1. #1
    Candidat au Club
    Homme Profil pro
    Développeur décisionnel
    Inscrit en
    Octobre 2015
    Messages
    5
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : Belgique

    Informations professionnelles :
    Activité : Développeur décisionnel
    Secteur : Service public

    Informations forums :
    Inscription : Octobre 2015
    Messages : 5
    Points : 4
    Points
    4
    Par défaut Encoding dans SAS Studio 3.8 English version?
    Bonjour à tous les passionnés du SAS.

    Mon problème est le suivant:
    J'ai créé la dataset Data_layout_coef_910

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    data Data_layout_coef_910;
    	set Data_coef_910;
    	ligne1 = "1- Budget octroyé aux hôpitaux généraux :";
    run;
    Ensuite, j'essaye de l'imprimer dans une procédure report de mon ODS:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    proc report data=Data_layout_coef_910 nowd
    	style(report)={rules = none frame = void};
    	title j=left color=blue bold italic "910 : Dossier patient informatisé : montant par hôpital";
    	columns ligne1 budg_hop_910;
    	define ligne1 / style(column)=[cellwidth=10cm] display '';
    	define budg_hop_910 / style(column)=[cellwidth=5cm] display '';
    	format budg_hop_910 nlmny18.2;
    run;
    J'obtiens le résultat:
    910 : Dossier patient informatisé : montant par hôpital
    
    1- Budget octroyé aux hôpitaux généraux :	7.664.157,51 €
    Comme vous pouvez le constater, les caractères accentués de la variable ligne1 ne s'affichent pas comme ils se doivent.

    Pourriez-vous m'aider à solutionner ce problème? Merci d'avance.

  2. #2
    Expert confirmé
    Avatar de olivier.decourt
    Homme Profil pro
    Formateur R/SAS/statistiques
    Inscrit en
    Avril 2008
    Messages
    2 064
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France

    Informations professionnelles :
    Activité : Formateur R/SAS/statistiques
    Secteur : Conseil

    Informations forums :
    Inscription : Avril 2008
    Messages : 2 064
    Points : 4 478
    Points
    4 478
    Par défaut
    Bonjour.
    Je n'arrive pas à reproduire le problème (mon SAS Studio est en français... ?).
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    data Data_layout_coef_910 (encoding=asciiany) ;
    	ligne1 = "1- Budget octroyé aux hôpitaux généraux :";
    	budg_hop_910=1000 ;
    run;
     
    proc report data=Data_layout_coef_910 nowd
    	style(report)={rules = none frame = void};
    	title j=left color=blue bold italic "910 : Dossier patient informatisé : montant par hôpital";
    	columns ligne1 budg_hop_910;
    	define ligne1 / style(column)=[cellwidth=10cm] display '';
    	define budg_hop_910 / style(column)=[cellwidth=5cm] display '';
    	format budg_hop_910 nlmny18.2;
    run;
    J'ai ajouté une option ENCODING à la table créée dans l'étape DATA, mais du coup je ne sais pas si ça change quelque chose.
    Peux-tu essayer et nous dire si ENCODING modifie la sortie ?

  3. #3
    Candidat au Club
    Homme Profil pro
    Développeur décisionnel
    Inscrit en
    Octobre 2015
    Messages
    5
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : Belgique

    Informations professionnelles :
    Activité : Développeur décisionnel
    Secteur : Service public

    Informations forums :
    Inscription : Octobre 2015
    Messages : 5
    Points : 4
    Points
    4
    Par défaut
    Merci pour l'intérêt accordé à ma question Olivier

    J'ai essayé ta proposition de solution, elle n'a pas fonctionné.
    Mais avant cela j'avais déjà localisé l'origine du problème dans mon programme;
    En fait, le programme dans lequel j'avais créé ma dataset était différent de celui dans lequel je faisais le proc report. C'est donc lors de l'appel du 1 er programme avec l'instruction %INCLUDE dans le 2 ème programme que j'obtenais alors ces caractères spéciaux à l'affichage.
    Je ne sais pas comment cela s'explique, mais j'ai ramené la création de ma dataset dans le même programme que celui du pro report et tout s'est donc bien imprimé (affiché, à l'écran et aussi bien dans mon pdf).

  4. #4
    Expert confirmé
    Avatar de olivier.decourt
    Homme Profil pro
    Formateur R/SAS/statistiques
    Inscrit en
    Avril 2008
    Messages
    2 064
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France

    Informations professionnelles :
    Activité : Formateur R/SAS/statistiques
    Secteur : Conseil

    Informations forums :
    Inscription : Avril 2008
    Messages : 2 064
    Points : 4 478
    Points
    4 478
    Par défaut
    OK. C'est probablement au niveau d'un FILENAME qu'il faudrait indiquer l'encodage, puis faire un %INCLUDE filenm ; où filenm serait le nom logique déclaré dans FILENAME.
    Mais si tout mettre dans le même programme solutionne le problème alors c'est parfait.

Discussions similaires

  1. Réponses: 0
    Dernier message: 11/09/2019, 11h40
  2. [Débutant] Question à propos des version et de l'assembly dans visual studio
    Par daerlnaxe dans le forum Général Dotnet
    Réponses: 3
    Dernier message: 09/09/2018, 16h35
  3. Version de JasperReports dans JasperSoft Studio
    Par fred33600 dans le forum Jasper
    Réponses: 2
    Dernier message: 10/09/2015, 10h07
  4. Réponses: 3
    Dernier message: 03/01/2011, 15h38
  5. Version de Windows dans Visual Studio !!!
    Par Jasmine dans le forum MFC
    Réponses: 3
    Dernier message: 18/03/2004, 17h40

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo