IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Futur Membre du Club
    Femme Profil pro
    Consultant SAP
    Inscrit en
    avril 2019
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Dordogne (Aquitaine)

    Informations professionnelles :
    Activité : Consultant SAP
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : avril 2019
    Messages : 6
    Points : 6
    Points
    6
    Par défaut Concaténer chaîne de caractères en conservant les espaces
    Bonjour,

    Je dois créer un modèle de fichier dans lequel les champs doivent être de longueur précis.

    Par exemple :

    Dans la cellule source A2, j'ai la valeur "TOTO" mais dans la cellule cible B2 je dois avoir "TOTO" complétée de quelques espaces pour atteindre 10 caractères soit "TOTO ". Pour faire cela, j'ai utilisé la fonction REPT pour répéter plusieurs fois un espace :

    Code Excel : Sélectionner tout - Visualiser dans une fenêtre à part
    =SI(NBCAR(A2)<10;A2&REPT( ;10-NBCAR(A2));A2)

    mais cela ne fonctionne pas tout à fait car quand je concatène ensuite ma cellule cible avec une autre cellule, il m'enlève les espaces normalement contenus dans la cellule cible.

    Une idée de comment faire tout ça ?

    Merci beaucoup !

  2. #2
    Membre éprouvé
    Homme Profil pro
    Formateur et développeur bureautique
    Inscrit en
    mars 2007
    Messages
    481
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Formateur et développeur bureautique
    Secteur : Conseil

    Informations forums :
    Inscription : mars 2007
    Messages : 481
    Points : 948
    Points
    948
    Par défaut
    Bonjour

    La formule y est presque
    Je propose : =SI(NBCAR(A2)<10;A2&REPT(" ";10-NBCAR(A2));A2)

    La seule chose qui était oubliée dans la formule de départ étaient les " autour de l'espace.

    En espérant que cela aide

    Bonne fin de journée

    Pierre Dumas
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  3. #3
    Futur Membre du Club
    Femme Profil pro
    Consultant SAP
    Inscrit en
    avril 2019
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Dordogne (Aquitaine)

    Informations professionnelles :
    Activité : Consultant SAP
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : avril 2019
    Messages : 6
    Points : 6
    Points
    6
    Par défaut
    Bonjour Pierre,

    C'est exactement ça !
    Merci beaucoup !!!

  4. #4
    Membre éprouvé
    Homme Profil pro
    Formateur et développeur bureautique
    Inscrit en
    mars 2007
    Messages
    481
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Formateur et développeur bureautique
    Secteur : Conseil

    Informations forums :
    Inscription : mars 2007
    Messages : 481
    Points : 948
    Points
    948
    Par défaut
    Rebonjour

    On peut même faire encore plus court :
    =A2&REPT(" ";10-MIN(NBCAR(A2);10))

    On fait directement 10 moins la plus petite valeur entre NBCAR(A2) et 10. C'est à dire que tant que NBCAR(A2) est inférieur à 10, Excel fait 10 - NBCAR(A2). Quand NBCAR(A2) est supérieur à 10, Excel fait 10-10, donc 0 et ne répète donc pas les espaces

    Belle fin de journée

    Pierre Dumas
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  5. #5
    Responsable
    Office & Excel


    Homme Profil pro
    Formateur et développeur informatique indépendant
    Inscrit en
    novembre 2003
    Messages
    16 589
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 54
    Localisation : Belgique

    Informations professionnelles :
    Activité : Formateur et développeur informatique indépendant
    Secteur : Enseignement

    Informations forums :
    Inscription : novembre 2003
    Messages : 16 589
    Points : 47 771
    Points
    47 771
    Billets dans le blog
    88
    Par défaut
    Salut.

    Autre approche, dans la mesure où l'on voudra toujours 10 caractères, quitte à tronquer la valeur: =GAUCHE(A1 & REPT(" ";10);10)(1)


    (1) Dans la mesure où l'on doit probablement préparer les données de cette manière en vue de la création d'un txt délimité en colonnes fixes ou quelque chose du genre, il me semble risqué de pouvoir renvoyer une chaine plus longuqe.
    "Plus les hommes seront éclairés, plus ils seront libres" (Voltaire)
    ---------------
    Mes remarques et critiques sont purement techniques. Ne les prenez jamais pour des attaques personnelles...
    Le VBA ne palliera jamais une mauvaise conception de classeur ou un manque de connaissances des outils natifs d'Excel...
    Ce ne sont pas des bonnes pratiques parce que ce sont les miennes, ce sont les miennes parce que ce sont des bonnes pratiques
    VBA pour Excel? Pensez D'ABORD en EXCEL avant de penser en VBA...
    ---------------

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [WD10] Erreur concaténation chaîne de caractères
    Par COLOMBAT dans le forum WinDev
    Réponses: 6
    Dernier message: 20/04/2010, 11h28
  2. XSL FO Conserver les espaces
    Par jeb001 dans le forum XSL/XSLT/XPATH
    Réponses: 1
    Dernier message: 22/08/2008, 11h13
  3. Réponses: 16
    Dernier message: 10/07/2008, 16h55
  4. Concaténation chaîne de caractères
    Par vince29 dans le forum Cobol
    Réponses: 19
    Dernier message: 21/12/2007, 15h46
  5. concaténation, chaîne de caractères
    Par bul dans le forum C++
    Réponses: 8
    Dernier message: 28/02/2005, 08h03

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo