IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2019
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 21
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : novembre 2019
    Messages : 61
    Points : 44
    Points
    44
    Par défaut Mon Composer requiert une version de PHP supérieure à celle utilisée
    Bonjour,

    Je suis débutant en Laravel, et j'utilise ce langage pour créer un site. Je travaille avec FileZilla pour transférer les changements de mon Laravel local vers le site de préproduction.

    Mon site de préproduction a rencontré un problème, Cherchant à faire une mise à jour et suite à une mauvaise modification que j'ai dû faire sur le dossier vendor/composer, j'ai eu à chaque fois que je tente de me connecter sur le site de préprod, l'erreur suivante : un écran tout blanc avec marqué
    Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.3.0". You are running 7.0.15-1.
    .

    J'ai alors décidé de récupérer le projet original sur bitbucket pour m'en débarrasser (le projet original n'ayant aucun problème).

    Pour ce faire, j'ai suivi les étapes suivantes :

    1) j'ai téléchargé le repository de bitbucket sur mon ordinateur, puis, avec l'invite de commande, j'ai fait : composer update dans le chemin de mon projet. L'installation du dossier vendor s'est bien faite et le fichier composer.lock a eu un changement.

    2) j'ai généré une nouvelle clé APP_KEY pour mon fichier .env en faisant la commande : php artisan key:generate. Le fichier .env a bien été modifié.

    3) j'ai supprimé le projet précédent de FileZilla,

    4) j'ai transféré à la place le projet que je venais de créer.

    Mais, suite à cela, je rencontre toujours le même problème.

    Auriez-vous une idée concernant ce problème. Quelle devrait être la marche à suivre afin de le régler ?

    En vous souhaitant une excellente journée et en vous remerciant par avance pour votre réponse,

    Bien cordialement,

  2. #2
    Modérateur

    Avatar de MaitrePylos
    Homme Profil pro
    DBA
    Inscrit en
    juin 2005
    Messages
    5 379
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : Belgique

    Informations professionnelles :
    Activité : DBA
    Secteur : Service public

    Informations forums :
    Inscription : juin 2005
    Messages : 5 379
    Points : 11 990
    Points
    11 990
    Par défaut
    Bonsoir,

    Ce n'est pas votre projet qui pose souci, mais bien votre composer, vous avez certainement la dernière version.

    Voyez si il vous est possibloe de télécharger une version précédente.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [2.x] composer forcer une version de commit
    Par jejeman dans le forum Symfony
    Réponses: 1
    Dernier message: 06/11/2014, 15h15
  2. Réponses: 0
    Dernier message: 06/02/2012, 09h08
  3. Réponses: 7
    Dernier message: 04/08/2010, 10h02
  4. Réponses: 3
    Dernier message: 09/04/2010, 09h18
  5. Réponses: 5
    Dernier message: 14/08/2009, 09h24

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo