IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Ruby Discussion :

Création de projet qui se loupe


Sujet :

Ruby

  1. #1
    Nouveau membre du Club
    Homme Profil pro
    Ticketman Webdeveloppeur
    Inscrit en
    juin 2009
    Messages
    44
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France

    Informations professionnelles :
    Activité : Ticketman Webdeveloppeur
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juin 2009
    Messages : 44
    Points : 27
    Points
    27
    Par défaut Création de projet qui se loupe
    Bonjour, ou bonsoir !

    Je commence à potasser un livre sur Ruby on Rails et j'ai donc commencé à me constituer l'environnement de travail avec RailsInstaller.
    Mon souci, c'est que quand je veux créer un nouveau projet, au départ ca va. Mais en cours de création, y a quelque chose qui capote, comme le montrent ces lignes :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    ...
    Fetching rack-test 1.1.0
    Installing rack-test 1.1.0
    Fetching sprockets 3.7.2
    Installing sprockets 3.7.2
    Gem::InstallError: nio4r requires Ruby version >= 2.4.
    An error occurred while installing nio4r (2.5.4), and Bundler cannot continue.
    Make sure that `gem install nio4r -v '2.5.4'` succeeds before bundling.
     
    In Gemfile:
      rails was resolved to 5.1.7, which depends on
        actioncable was resolved to 5.1.7, which depends on
          nio4r
    Ce que j'ai compris, c'est que la version de Ruby incluse dans le package est en dessous de la version demandée. Du coup, je suis un peu dubitatif. Le package est dépassé ? Y a-t-il un moyen de mettre à jour Ruby dans tout çà ? Et si oui, comment ? Est-ce le seul problème rencontré ? Je demande parce que d'après le site Ruby on Rail n'a plus bougé de version depuis plus de trois ans, donc j'ai un peu peur de m'être gourré de méthode pour m'initier à Rails.

    Merci à tous ceux qui pourront m'aider, parce que j'avoue que je patauge pas mal depuis une semaine !

    A très vite !

  2. #2
    Membre expérimenté
    Avatar de Madmac
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    juin 2004
    Messages
    991
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : Alimentation

    Informations forums :
    Inscription : juin 2004
    Messages : 991
    Points : 1 447
    Points
    1 447
    Billets dans le blog
    3
    Par défaut
    Une gemme est manquante. Possiblement une gemme qui doit être compilée. Ouvre un terminal en mode administrateur, et tape gem install nio4r -v '2.5.4'.

    il est probable que cela ne suffira pas, si ton installation Ruby est incomplète.

    Sous une distro basée sur Debian pour compléter ton installation tu dois avoir un environnement complet de programmation C:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo apt-get update && sudo apt-get install build-essential gcc g++ make nginx mysql-server ruby ruby-bundler nodejs git yarn ruby-dev composer vagrant
    Ils ne sont pas tous essentiels pour débuter, mais tôt ou tard, ils le deviendront.

    Le combo pour professionnel comprend Ruby 2.6 et la version 5 de Rails.
    intel i7
    Mint 20
    Plasma et Cinnamon

Discussions similaires

  1. [IIS] problème de création un projet Web
    Par kouta20 dans le forum IIS
    Réponses: 20
    Dernier message: 02/05/2007, 17h10
  2. [CV] Projets qui peuvent figurer sur un CV
    Par afrikha dans le forum CV
    Réponses: 20
    Dernier message: 09/12/2005, 06h34
  3. Projet qui marche sous Eclipse ne marche plus en JAR
    Par leminipouce dans le forum Eclipse Java
    Réponses: 7
    Dernier message: 26/10/2005, 18h59
  4. [eclipse 3.0.1] Création de projet avec sous-projet
    Par whilecoyote dans le forum Eclipse Java
    Réponses: 5
    Dernier message: 11/07/2005, 10h31
  5. [Création nouveau projet] - Référencer un autre projet
    Par TexAvery dans le forum Eclipse Java
    Réponses: 5
    Dernier message: 17/08/2004, 12h55

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo