Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Architecture Discussion :

Installer Cisco Router 2900 derrière Livebox


Sujet :

Architecture

  1. #1
    Futur Membre du Club
    Installer Cisco Router 2900 derrière Livebox
    Bonjour à tous,

    Je cherche à installer un router cisco 2901 derrière ma livebox.

    J'ai commencé ma conf dont voici mes paramètres

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    version 15.7
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip domain name ataworld.fr
    ip name-server 8.8.8.8
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    !
    !
    !
    !
    license udi pid CISCO2901/K9 sn FCZ1749C153
    !
    !
    !
    redundancy
    !
    !
    !
    !
    !
    !
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     ip address 192.168.1.254 255.255.255.0
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     ip address 192.168.2.254 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     duplex auto
     speed auto
    !
    ip default-gateway 192.168.1.1
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip nat inside source list 1 interface GigabitEthernet0/1 overload
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    !
    !
    access-list 1 permit 192.168.0.0 0.0.255.255
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     login
     transport input none
    !
    scheduler allocate 20000 1000
    !
    end
    J'ai configurer un PC branché sur mon port 0/1 avec une adresse IP fixe en 192.168.2.10/24 passerelle 192.168.2.254

    Ce PC ping bien les IP des interfaces de mon router : 192.168.1.254 et 2.254 mais ne ping pas ma livebox qui elle est en 192.168.1.1

    Mon router ping sans soucis www.google.fr par contre il ping pas mon PC en 192.168.2.10

    Qu'est ce qu'il me manque pour que mes réseaux puisse aller sur le net ?

    Merci

  2. #2
    Expert confirmé
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    
    access-list 1 permit 192.168.2.0 0.0.0.255

  3. #3
    Futur Membre du Club
    Nickel ça fonctionne

    Voila ce que j 'aimerai réaliser pour mon réseau



    Pour cela suis je obligé de passer par l'activation de "IP routing" dans mon switch, car je rencontre un soucis, lorsque je tape la commande IP routing il me dit que mon sdm utilise un mauvais template alors que je l'ai bien passer sur "lanbase_routing" et que j'ai rebooté.

    Merci bien pour le coup de main

  4. #4
    Expert confirmé
    La solution la plus simple consiste à utiliser le 2600s comme swich layer 2 ( VLAN & Trunk ) et le 2901 comme router / filtrage / nat / ... etc

  5. #5
    Futur Membre du Club
    OK merci pour le conseil je vais me pencher la dessus.

    Le router pourra se charger de router les vlan presents sur le switch ?

  6. #6
    Expert confirmé
    Pour autant que tu puisses faire des sous-interfaces 802.1q ou des vlan layer 3 sur le 2901 : oui.

  7. #7
    Futur Membre du Club
    Bonjour,

    Voilà la conf de mon router

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    version 15.7
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    enable secret 5 $1$BChv$x/QL8i6nA4ca9zwO9qUCe.
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    aaa authorization exec default local
    !
    !
    aaa session-id common
    !
    !
    ip domain name ataworld.fr
    ip name-server 8.8.8.8
    ip name-server 8.8.4.4
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    !
    !
    license udi pid CISCO2901/K9 sn FCZ1749C153
    !
    !
    username one privilege 15 password 0 xxxxxxxx
    username atalec privilege 15 password 0 xxxxxxxxx
    !
    redundancy
    !
    !
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     ip address 192.168.1.254 255.255.255.0
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     ip address 192.168.2.254 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     duplex auto
     speed auto
    !
    ip default-gateway 192.168.1.1
    ip forward-protocol nd
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    !
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    !
    !
    access-list 1 permit 192.168.0.0 0.0.255.255
    !
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     transport input none
    !
    scheduler allocate 20000 1000
    !
    end
    Et la conf de mon switch

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    104
    105
    106
    107
    108
    109
    110
    111
    112
    113
    114
    115
    116
    117
    118
    119
    version 15.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Switch
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    switch 2 provision ws-c2960s-48fps-l
    ip routing
    !
    ip dhcp pool vlan10
     network 192.168.10.0 255.255.255.0
     default-router 192.168.10.250
     dns-server 8.8.8.8
    !
    ip dhcp pool vlan20
     network 192.168.20.0 255.255.255.0
     default-router 192.168.20.250
     dns-server 8.8.8.8
    !
    ip dhcp pool vlan30
     network 192.168.30.0 255.255.255.0
     default-router 192.168.30.250
     dns-server 8.8.8.8
    !
    ip dhcp pool vlan40
     network 192.168.40.0 255.255.255.0
     default-router 192.168.40.250
     dns-server 8.8.8.8
    !
    !
    ip domain-name ataworld.fr
    ip name-server 8.8.8.8
    !
    !
    crypto pki trustpoint TP-self-signed-111219328
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-111219328
     revocation-check none
     rsakeypair TP-self-signed-111219328
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    !
    vlan internal allocation policy ascending
    !
    !
    interface FastEthernet0
     no ip address
     no ip route-cache
     shutdown
    !
    interface GigabitEthernet2/0/1-11
     switchport access vlan 10
     switchport mode access
    !
    interface GigabitEthernet2/0/12-24
     switchport access vlan 10
     switchport mode access
    !
    interface GigabitEthernet2/0/25-36
     switchport access vlan 30
     switchport mode access
    !
    interface GigabitEthernet2/0/37-47
     switchport access vlan 40
     switchport mode access
    !
    interface GigabitEthernet2/0/48
     switchport access vlan 40
     switchport mode trunk
    !
    interface GigabitEthernet2/0/49
    !
    interface GigabitEthernet2/0/50
    !
    interface GigabitEthernet2/0/51
    !
    interface GigabitEthernet2/0/52
    !
    interface Vlan1
     ip address 192.168.2.251 255.255.255.0
    !
    interface Vlan10
     ip address 192.168.10.250 255.255.255.0
    !
    interface Vlan20
     ip address 192.168.20.250 255.255.255.0
    !
    interface Vlan30
     ip address 192.168.30.250 255.255.255.0
    !
    interface Vlan40
     ip address 192.168.40.250 255.255.255.0
    !
    ip default-gateway 192.168.1.250
    ip http server
    ip http secure-server
    !
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    ip route 0.0.0.0 0.0.0.0 192.168.20.251
    !
    !
    !
    line con 0
    line vty 0 4
     login
    line vty 5 15
     login
    !
    end
    J'ai configuré mes vlans sur mon switch par contre comment je dois m'y prendre sur mon router pour déclarer ces mêmes vlan et faire le routage inter vlan ?

    Je précise que mon router ping bien ma box et internet.

    Par constre au niveau de mon switch j'ai mis un poste en prise 1 qui reçoit bien une addresse DHCP, celui ci ping bien l'adresse IP du Vlan 10 (192.168.10.250) mais ne peut pinger aucune autre adresse des vlans. Je ne peux pas pinger non plus l'adresse de mon interface router 0/1 relié au switch.

    Merci d'avance pour votre aide, la mise en place des vlan et la dernière étape avant d'avoir terminé ma conf pour mon réseau.

  8. #8
    Expert confirmé
    Tu choisis la solution "compliquée" mais soit.

    Sur ton switch, tu as :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    ip default-gateway 192.168.1.250
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    ip route 0.0.0.0 0.0.0.0 192.168.20.251
    Tu n'as pas d'interface dans 192.168.1.0/24.
    Tu n'as pas d'ip configurée 192.168.20.251 ( ni switch, ni routeur )


    Donc, tu dois avoir du coté switch :

    ip default-gateway 192.168.2.250

    et tu coté routeur

    ip route 192.168.0.0 255.255.0.0 192.168.2.251

  9. #9
    Futur Membre du Club
    Compliquée ?

    Quelle serait la solution la plus simple pour toi ?

    Chose bizarre sur mon routeur, il ping bien son GE0/0 en 192.168.1.254 mais il ne ping pas son GE 0/1 en 192.168.2.254, bizarre non ?

    J'ai brancher ma borne wifi sur une des prises du vlan20, elle se connecte sans soucis au vlan, et mon pc en Wifi ping bien les adresses IP de mes vlan 10 et 20 par contre il ne ping pas l'IP du vlan1

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    Interface              IP-Address      OK? Method Status                Protocol
    Vlan1                  192.168.2.250   YES manual up                    down
    Vlan10                 192.168.10.250  YES NVRAM  up                    up
    Vlan20                 192.168.20.250  YES NVRAM  up                    up
    Vlan30                 192.168.30.250  YES NVRAM  up                    down
    Vlan40                 192.168.40.250  YES NVRAM  up                    down
    FastEthernet0          unassigned      YES NVRAM  administratively down down
    Petite question en passant. La version du firmware de mon switch est une universal et j'ai vu qu'il existe des version lanbase. Ne serait-ce pas pour cette raison que l'ip routing de mon switch ne s'active pas et me mette une erreur de template ?

  10. #10
    Expert confirmé
    La solution la plus simple consiste a n'utiliser que les fonctions de couche 2 de ton switch . C'est à dire qu'il ne fait pas de routage et n'est donc pas la passerelle par défaut des pc

    Donc sur le switch :

    - tu crées tous tes vlan
    - tu raccordes les machines en fonction de leur vlan
    - tu crées un trunk avec tous les vlan qui va connecter le routeur

    Sur le routeur :

    - Tu connectes le trunk du switch sur une porte du routeur
    - Tu crées des sous-interfaces taguées qui vont correspondre aux différents VLAN sur cette porte de ton routeur.

    Pour la non réponse sur 2.254 : logique, ta route pointe de l'autre coté
    Pour le firmware, je connais pas la différence entre ces deux firmwares, je n'utilise pas ce type de matériel

  11. #11
    Futur Membre du Club
    ok du coup pour ce genre de fonctionnement.

    Dois-je définir une IP pour chacun de mes Vlan y compris le 1 ?

    Default gateway de mon switch je met l'adresse IP de l'interface de mon router relié au switch ?

    La conf de mon port trunk du switch
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    interface GigabitEthernet2/0/48
     switchport mode trunk
    Correct ou dois-je ajouter qqchose ?

    Mon port Ethernet du router qui est relié au switch et le GE 0/1, donc pour créer mes sous interface je créé GE 0/1.1, 0/1.10, 0/1.20..... ?et je leur attribut aussi une ip chacun ?

    Merci pour ton aidee, grace à toi je sens que je touche le bout du projet et que j'en apprends un peu plus ;-)

  12. #12
    Expert confirmé
    Citation Envoyé par atalec Voir le message
    ok du coup pour ce genre de fonctionnement.

    Dois-je définir une IP pour chacun de mes Vlan y compris le 1 ?

    Oui

    Citation Envoyé par atalec Voir le message

    Default gateway de mon switch je met l'adresse IP de l'interface de mon router relié au switch ?

    Oui

    Citation Envoyé par atalec Voir le message

    La conf de mon port trunk du switch
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    interface GigabitEthernet2/0/48
     switchport mode trunk
    Correct ou dois-je ajouter qqchose ?
    Oui, tu dois préciser les vlans que tu laisses passer ( switchport trunk allowed vlan )



    Citation Envoyé par atalec Voir le message

    Mon port Ethernet du router qui est relié au switch et le GE 0/1, donc pour créer mes sous interface je créé GE 0/1.1, 0/1.10, 0/1.20..... ?et je leur attribut aussi une ip chacun ?
    Oui et ces ip que tu vas définir sera à chaque fois, sera l'ip de la passerelle par défaut du vlan correspondant

  13. #13
    Futur Membre du Club
    Ok j'ai avancé dans ma conf

    voici celle du router

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    version 15.7
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    enable secret 5 $1$BChv$x/QL8i6nA4ca9zwO9qUCe.
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    aaa authorization exec default local
    !
    !
    aaa session-id common
    !
    !
    ip domain name ataworld.fr
    ip name-server 8.8.8.8
    ip name-server 8.8.4.4
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    !
    !
    license udi pid CISCO2901/K9 sn FCZ1749C153
    !
    !
    username one privilege 15 password 0 
    username atalec privilege 15 password 0 
    !
    redundancy
    !
    !
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     ip address 192.168.1.254 255.255.255.0
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     ip address 192.168.2.254 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1.1
     encapsulation dot1Q 1 native
     ip address 192.168.3.251 255.255.255.0
    !
    interface GigabitEthernet0/1.10
     encapsulation dot1Q 10
     ip address 192.168.10.251 255.255.255.0
    !
    interface GigabitEthernet0/1.20
     encapsulation dot1Q 20
     ip address 192.168.20.251 255.255.255.0
    !
    ip default-gateway 192.168.1.1
    ip forward-protocol nd
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    !
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    !
    !
    access-list 1 permit 192.168.0.0 0.0.255.255
    !
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     transport input none
    !
    scheduler allocate 20000 1000
    !
    end
    Après test : mon router ping toutes les interfaces et même internet. Mon switch et mon PC sur vlan10 ping toutes les interfaces sauf ma livebox 192.168.1.1


    Ma conf de switch
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    version 15.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Switch
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$FUmg$byeg7yuO1e2/.xRr9Lqsz.
    !
    no aaa new-model
    switch 2 provision ws-c2960s-48fps-l
    !
    ip dhcp pool vlan10
     network 192.168.10.0 255.255.255.0
     default-router 192.168.10.251
     dns-server 8.8.8.8
    !
    ip dhcp pool vlan20
     network 192.168.20.0 255.255.255.0
     default-router 192.168.20.251
     dns-server 8.8.8.8
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    !
    vlan internal allocation policy ascending
    !
    !
    interface FastEthernet0
     no ip address
    !
    interface GigabitEthernet2/0/48
     switchport trunk allowed vlan 1,10,20,30,40
     switchport mode trunk
    !
    interface Vlan1
     ip address 192.168.2.250 255.255.255.0
    !
    interface Vlan10
     ip address 192.168.10.250 255.255.255.0
    !
    interface Vlan20
     ip address 192.168.20.250 255.255.255.0
    !
    ip default-gateway 192.168.2.254
    
    ip http server
    ip http secure-server
    !
    !
    line con 0
    line vty 5 15
    !
    end

  14. #14
    Expert confirmé
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    interface GigabitEthernet0/1.10
     encapsulation dot1Q 10
    et le ip nat inside ??

    Tu peux également déplacer le serveur dhcp, il n'y aucune raison de laisser cela sur le switch

  15. #15
    Futur Membre du Club
    Ha oui un petit ip Nat inside sur chaque vlan sauf le 1 je met un outside ?

    OK je vais mettre le serveur dhcp sur le router, c'est mieux ?

    MERCIIIIII

  16. #16
    Expert confirmé
    C'est plus cohérent de mettre cela sur le router

  17. #17
    Futur Membre du Club
    Bonjour bienfaiteur ;-)

    J'ai corrigé ce que tu m'as conseillé, je ping toujours jusqu'à mon interface de router G0/0 mais je ne peux aller sur le net car impossible de pinger ma livebox 192.168.1.1

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    104
    105
    106
    107
    108
    109
    110
    111
    112
    113
    114
    115
    116
    117
    118
    119
    120
    121
    122
    123
    124
    125
    126
    127
    128
    129
    130
    131
    132
    133
    134
    135
    136
    137
    138
    139
    140
    141
    142
    143
    144
    145
    146
    147
    148
    149
    150
    151
    152
    153
    154
    155
    156
    157
    158
    159
    160
    version 15.7
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    enable secret 5 $1$BChv$x/QL8i6nA4ca9zwO9qUCe.
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    aaa authorization exec default local
    !
    !
    !
    !
    !
    !
    aaa session-id common
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip dhcp pool vlan10
     network 192.168.10.0 255.255.255.0
     default-router 192.168.10.251
     dns-server 8.8.8.8
    !
    ip dhcp pool vlan20
     network 192.168.20.0 255.255.255.0
     default-router 192.168.20.251
     dns-server 8.8.8.8
    !
    ip dhcp pool vlan30
     network 192.168.30.0 255.255.255.0
     default-router 192.168.30.251
     dns-server 8.8.8.8
    !
    ip dhcp pool vlan40
     network 192.168.40.0 255.255.255.0
     default-router 192.168.40.251
     dns-server 8.8.8.8
    !
    !
    !
    ip domain name ataworld.fr
    ip name-server 8.8.8.8
    ip name-server 8.8.4.4
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    !
    !
    !
    !
    license udi pid CISCO2901/K9 sn FCZ1749C153
    !
    !
    username one privilege 15 password 0 
    username atalec privilege 15 password 0 
    !
    redundancy
    !
    !
    !
    !
    !
    !
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     ip address 192.168.1.254 255.255.255.0
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     ip address 192.168.2.254 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1.1
     encapsulation dot1Q 1 native
     ip address 192.168.3.251 255.255.255.0
     ip nat outside
     ip virtual-reassembly in
    !
    interface GigabitEthernet0/1.10
     encapsulation dot1Q 10
     ip address 192.168.10.251 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    !
    interface GigabitEthernet0/1.20
     encapsulation dot1Q 20
     ip address 192.168.20.251 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    !
    interface GigabitEthernet0/1.30
     encapsulation dot1Q 30
     ip address 192.168.30.251 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    !
    interface GigabitEthernet0/1.40
     encapsulation dot1Q 40
     ip address 192.168.40.251 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    !
    ip default-gateway 192.168.1.1
    ip forward-protocol nd
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    !
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     transport input none
    !
    scheduler allocate 20000 1000
    !
    end

  18. #18
    Expert confirmé
    Tu as deux ip nat outside

  19. #19
    Futur Membre du Club
    Oui effectivement

    d'après toi que manque t il à mes interfaces?

    La problème se situe surement là

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     ip address 192.168.1.254 255.255.255.0
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/0.1
     encapsulation dot1Q 1 native
    !
    interface GigabitEthernet0/1
     ip address 192.168.2.254 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1.1
     encapsulation dot1Q 1 native
     ip address 192.168.3.251 255.255.255.0
     ip nat outside
     ip virtual-reassembly in
    !
    Le fait que la 0/0.1 n'est pas d'IP est un problème non? si je lui mets 192.168.1.251 il me met une erreur overlaps avec la 0/0

  20. #20
    Expert confirmé
    Je n'ai pas de matériel pour tester mais je placerais tout en sous-interface ( avec le dot1Q 1 native ) et je supprimerais ce double ip nat outside

###raw>template_hook.ano_emploi###