Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre émérite
    [Delphi 10] Problème avec le certificat de sécurité du site
    Pour info : Il y a un problème de sécurité général sur le lancement de Delphi 10 aujourd'hui.


  2. #2
    Membre expert
    C'est un problème de certificat sur la page d’accueil, sans doute un certificat TLS qui a expiré et n'a pas été renouvelé...
    Cela n'affecte pas le fonctionnement de l'IDE, cela c'était déjà produit il y a quelques mois de mémoire...
    Il suffit de fermer la page d'accueil après avoir chargé ton projet

  3. #3
    Membre expérimenté
    Je confirme : certificat SSL expiré. Il est possible que des alertes apparaissent dans l'IDE selon la version utilisée car il y avait un chargement des flux en page d'accueil. Ca pacte GetIt et d'autres sites utilisés en interne.

    Ils sont au courant, ça devrait se régler rapidement (sous réserve des temps de renouvellement et d'installation de certificats ne provenant pas de sources automatisées comme Let's Encrypt).

    La version 10.4.x devrait être épargnée par le problème une fois le premier avertissement lancé, les autres risquent de l'afficher plusieurs fois en cours d'utilisation.

    Conseil pour être tranquilles : prenez votre lundi ou ne fermez pas l'IDE de la journée.

  4. #4
    Rédacteur/Modérateur

    Je croise les doigts, rien de mon côté [10.3,10.4] pour l'instant, pour la 10.2 en revanche c'est le cas
    Pour la 10.3 peut-être que ma manipulation dans la base de registre (pour une soit-disant licence expirée (HKEY_CURRENT_USER\Software\Embarcadero\BDS\20.0\Globals LicenseNotificationEnabled=0) joue.
    En tout cas Get-it "plante" avec ce problème de certificat pour 10.2, 10.3. Je me souviens d'un problème de Get-it lors d'une mise à jour, là aussi il y avait une maipulation qui arrangeait ça.

    J'ai lu aussi que désactiver la "welcome page" pouvait régler le problème ?

    Conseil pour être tranquilles : prenez votre lundi
    J'ai habitué mes utilisateurs au Lundi "c'est mon jour kiné, pas la peine de me joindre après 15H00" , il va falloir que j'avance ma séance
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  5. #5
    Membre actif
    Citation Envoyé par pprem Voir le message

    Conseil pour être tranquilles : prenez votre lundi ou ne fermez pas l'IDE de la journée.
    oupssss, j'ai fait mon utilisateur de base dimanche (ou samedi ?)... j'ai cliqué oui, et j'ai oublié le message

  6. #6
    Rédacteur/Modérateur

    À se demander s'il y a quelqu'un au bout de la ligne d'Embarcadero Community ! C'est quand même signalé depuis 3 jours minimum.
    Ah, mais c'est vrai, j'oubliai () Embarcadero Community est en fin de vie (cf. https://www.developpez.net/forums/d2...e-embarcadero/)

    Citation Envoyé par SergioMaster
    J'ai lu aussi que désactiver la "welcome page" pouvait régler le problème ?
    Remy Lebeau propose de carrément supprimer une clé de registre
    HKEY_CURRENT_USER\SOFTWARE\Embarcadero\BDS\20.0\Known IDE Packages la valeur $(BDS)\Bin\startpageide???.bpl (où ??? est le numéro de version Tokyo 250, Rio 260)

    j'ai essayé pour 10.2 (et gardé) et 10.3 (mais restauré ensuite ) cela semble OK
    conseil : sauvegarder la base de registre (ou du moins la clé) avant histoire de pouvoir la remettre une fois le problème réglé (à moins que vous pouviez vous passer de cette page )
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  7. #7
    Membre émérite
    J'ai renommé de fichier "startpageide???.bpl" cela convient aussi

###raw>template_hook.ano_emploi###