Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #21
    Responsable Systèmes

    Il est logique qu'ubuntu 20, plus récent, soit plus gourmand qu'ubuntu 18. Augmentes peut-être les ressources de la VM.

    Si tu mets ta VM sur le SSD tu auras de meilleures perfs.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutor...s/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  2. #22
    Candidat au Club
    Citation Envoyé par chrtophe Voir le message
    Si tu mets ta VM sur le SSD tu auras de meilleures perfs.
    Et si je défragmente mon disque dur, c'est meilleur ?

    J''étais pas mal occupé aujourd'hui, du coup comme je vous l'avez dit je comptais copier le disque virtuelle "Ubuntu_20.04_LTS.vdi" ( via l'interface graphique de Virtualbox dans Fichier puis Gestionnaire de Médias, puis copier le disque dur virtuelle souhaité) puis je supprimerai la version qui ne marche pas "Ubuntu_20.04_LTS", après mettre assuré que la nouvelle machine que j'aurai créée marche ! J'espère que mon disque dur virtuelle n'est pas "contaminé", avec tous les écrans bleus que j'ai eu !

    Mais je me demande, est-ce que le résultat serait le même si je faisais un clone intégrale (surtout pas lié) de la machine "Ubuntu_20.04_LTS" ?

    C'est la même chose dans le fond ? Dans les deux cas, je copie le disque dur virtuelle, non ?

  3. #23
    Responsable Systèmes

    Et si je défragmente mon disque dur, c'est meilleur ?
    c'est le disque virtuel qu'il faudrait défragmenter.

    Le mieux reste le clone, ceci copiera la VM correctement et le clone ne sera pas fragmenté. Dans une des photos d'un de tes posts on voir "clone de...", comme je le disait on ne sais pas toutes les opérations effectués. Le clone de la VM, pas d'un de ces disques est la meilleure solution.

    Une fois ok, tu pourra supprimer les anciennes VM et éventuellement changer les réglages de la VM clonée comme augmenter sa RAM, etc.

    Et comme dis, déplacer la VM sur le SSD pourra améliorer les perfs.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutor...s/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  4. #24
    Membre averti
    Je penses qu'il nous faudrait les informations suivantes :
    type de processeur + nombre de coeur
    Type carte graphique + ram dédié. L'image posté plutôt dans la discussion montre une carte intel UHD630 avec 128 mo de RAM prise sur 8 Go de RAM. Ce type n'est pas une carte mais un cœur graphique incorporé dans les processeurs intel de 8 et 9 génération. C'est léger pour de la virtualisation de poste de travail.
    RAM totale du pc.

    Un certain nombres de paramètres me semblent incohérent.
    Il est important de bien configuré les VM en fonction des capacités réelles du pc qui les héberge. Par exemple un nombre élevé de cœur peut avoir des conséquences désastreuses sur la rapidité d'une VM.
    "Les cons, ça ose tout. C'est même à ça qu'on les reconnaît." Michel Audiard - Les tontons flingueurs

  5. #25
    Candidat au Club
    Citation Envoyé par chrtophe Voir le message

    Le mieux reste le clone, ceci copiera la VM correctement et le clone ne sera pas fragmenté. Dans une des photos d'un de tes posts on voir "clone de...", comme je le disait on ne sais pas toutes les opérations effectués. Le clone de la VM, pas d'un de ces disques est la meilleure solution.
    Oui y a "Clone de Ubuntu 18.04.2 LTS" car j'avais une machine virtuelle qui s'appelait "Ubuntu 18.04.2 LTS" avec laquelle j'ai rencontré des problèmes ( et que j'ai supprimée par la suite) , du coup j'avais fait un clonage de cette machine qui est "Ubuntu_20.04_LTS". Sur cette dernière j'avais fait une mise à jour pour passer de 18.04 à 20.04. Et là, ça marchait bien, avant que tout ne marche plus... Je me dis que ça doit vraiment être un problème de configuration (comme vous me l'avez signalé). Parce que c'est pas possible qu'à chaque fois que je fais une nouvelle machine, ça plante au bout d'un certain temps! (pourtant j'ai suivi des tutos...)
    Mais je ne vois pas en quoi mes configurations de ma vm ne seraient pas corrects...

    Comme gabriel21 l'a mentionné, je vous donne les informations demandées !

    Processeur : Intel® Core™ i7-8750H CPU @ 2.20 GHz 2.21 GHz
    Mémoire RAM installée 16,0 Go (15.9 Go utilisable)
    Cœurs : 6
    Processeurs logiques : 12
    Cartes graphiques : NVIDIA GeForce GTX 1050 et Intel® UHD Graphics 630


  6. #26
    Candidat au Club
    Ok alors j'ai réalisé un 'Clone Intégral' de "Ubuntu_20.04_LTS", qui s'appelle "Ubuntu-20.04" mais j'ai toujours la même erreur...


    D'ailleurs pourquoi quand je clone mon disque dur virtuelle, il ne s'appelle pas "Clone de Clone de Ubuntu 18.04.2 LTS.vdi" ? Enfin, c'est ce qu'on obtient quand on clone d'habitude! Là c'est "Ubuntu-20.04-disk1.vdi".

  7. #27
    Responsable Systèmes

    Commences par mettre la mémoire vidéo sur un truc standard comme 16 Mo. Si après ça déconne toujours, mets-nous les logs en pièce jointe.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutor...s/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  8. #28
    Candidat au Club
    Ok, j'ai l'impression que ça fonctionne presque, je n'ai plus l'erreur du 'Guru Meditation' MAIS une fois que je me log, j'ai un écran noir. Je me suis dit que ça va passer mais ça fait 20 mins que l'écran est noir.

    Je vous joins le log:
    (qui vient d'être cloné)

    D'ailleurs j'ai aussi appliqué votre conseil pour ma machine virtuelle initiale, j'avais 256 Mo ( je l'avais changé via le shell windows 128->256 Mo, je crois que c'est ça qui a entraîné des complications...), je suis repassé à 16 Mo (plus standard) et je n'ai plus le 'Guru Meditation' sauf qu'après mettre loguer j'ai un écran noir aussi.

    Je vous joins le log:

  9. #29
    Responsable Systèmes

    Donc la VM fonctionne au sens VirtualBox.

    Ton pilote vidéo doit planter, déjà il n'a pas du aimer tous les changements

    Commences par essayer de lancer startx depuis une console.
    Accès aux consoles par ctrl-alt-F1 F2 etc.
    indiques-nous les erreurs
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutor...s/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  10. #30
    Candidat au Club
    J'a tapé ctrl-alt-f1 (ou f2) pour lancer la commande startx, avant de me loguer parce que sinon l'écran resté toujours noir. J'ai obtenu ça :


    Juste l'image est un peu flou sur les bords mais quand j'ai rebooté ma machine virtuelle, et que j'ai refait ctrl-alt-f2 pour vous prendre une nouvelle photo sans tâche lumineuse, j'ai eu :
    Hint num lock on

  11. #31
    Responsable Systèmes

    Suivi d'une erreur ou pas ?
    Merci de nous envoyer le fichier Xorg0.log dans le chemin indiqué.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutor...s/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  12. #32
    Candidat au Club
    Citation Envoyé par chrtophe Voir le message
    Suivi d'une erreur ou pas ?
    Après le Hint num lock on ? Si c'est ça, non y a pas d'erreur. Juste je ne peux faire aucune commande.

    Citation Envoyé par chrtophe Voir le message
    Merci de nous envoyer le fichier Xorg0.log dans le chemin indiqué.


    (ps : ma vm a fonctionné l'espace d'un instant j'ai pu récupéré le fichier, d'ailleurs en faisant ctrl-alt-f2, il m'indiquait que ce fichier était vide, c'est bizarre...)

  13. #33
    Responsable Systèmes

    Ta console indique qu'il y a des mises à jour à faire, je commencerais par ça.

    Il y a eu une erreur de droits d'accès à fbdev, je ne sais pas si c'est une erreur bloquante.

    Tu peux tenter ceci :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    sudo service gdm stop
    sudo dpkg-reconfigure xserver-xorg
    suivi d'un redémarrage.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutor...s/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  14. #34
    Membre averti
    Clairement, ta carte graphique ne supporte pas l'allocation de 256mo par VirtualBox.

    Bon, concernant xorg, je suis surpris de la présence d'un drivers VmWare pour gérer l'affichage. Est ce qu'à l'origine, cette machine a été fabriquée sous VmWare (workstation, player ou esxi)?
    Je serai d'avis de dégager les paquets VmWare.

    En théorie, Ubuntu fonctionne sans les add-ons invité de VirtualBox, mais tu peux les installer. Par contre, il te faudra une chaîne de compilation complète. Personnellement, je n'ai pas d'interface graphique sur mes VM, donc je ne m'en suis jamais préoccupé.

    Autre bizarrerie, ta webcam est détecté comme un clavier avant d'être supprimer.
    le client vidéo initialise toujours avec 256mo de ram.

    un reconfigure de xorg est nécessaire....

    Concernant le nombre de VCPU, j'ai l'habitude de n'en mettre que 2 de bases. Je ne les augmente que si nécessaire.
    "Les cons, ça ose tout. C'est même à ça qu'on les reconnaît." Michel Audiard - Les tontons flingueurs

  15. #35
    Responsable Systèmes

    Bon, concernant xorg, je suis surpris de la présence d'un drivers VmWare pour gérer l'affichage
    Je me suis aussi posé la question, mais je me demande si le pilote est pas présent mais pas forcément chargé. A moins que la VM était d’origine sous VMWare puis basculé sur Virtualbox, ce qui expliquerait aussi la suite de problèmes.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutor...s/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  16. #36
    Membre averti
    Pour ce que je sais, il est réellement chargé par le kernel.
    Par contre, est ce qu'il est utilisé? Ça, je n'en sait rien. Mais je penses que cela ne fera pas de mal de le supprimer. Voir cela supprimera des risques de conflits...
    "Les cons, ça ose tout. C'est même à ça qu'on les reconnaît." Michel Audiard - Les tontons flingueurs

  17. #37
    Candidat au Club
    Citation Envoyé par chrtophe Voir le message

    Tu peux tenter ceci :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    sudo service gdm stop
    sudo dpkg-reconfigure xserver-xorg
    suivi d'un redémarrage.
    Rien ne se passe :


    Et pour les pilotes j'ai ça (photo prise avant que ma vm ne me lâche et déjà je me disais que ce n'était pas normal et que j'allais y remédier c'est peut-être ça ?...) :


    Pourquoi je n'ai pas NVIDIA , ok c'est une carte émulée mais pourquoi sur des vidéos, on trouve que les pilotes proposés sont Nvidia ?
    D'ailleurs pour le contôleur graphique j'ai "VMSVGA" par défaut. Autrement dit ça correspond au contrôleur graphique fourni par VmWare. Comment c'est possible ?

    Citation Envoyé par gabriel21 Voir le message

    Bon, concernant xorg, je suis surpris de la présence d'un drivers VmWare pour gérer l'affichage. Est ce qu'à l'origine, cette machine a été fabriquée sous VmWare (workstation, player ou esxi)?
    Absolument pas !

    Citation Envoyé par gabriel21 Voir le message
    Clairement, ta carte graphique ne supporte pas l'allocation de 256mo par VirtualBox.

    Ni 16Mo j'ai l'impression, parce que j'ai le droit à un bel écran noir après me loguer.

    Citation Envoyé par gabriel21 Voir le message
    Concernant le nombre de VCPU, j'ai l'habitude de n'en mettre que 2 de bases. Je ne les augmente que si nécessaire.
    J'ai tenté de mettre 2 au lieu de 6 (avec 16 Mo), je ne peux même plus me loguer, j'ai cette interface :s



    Ps: Par contre si je mets 2 CPU et 55 Mo, je peux me loguer ( mais écran noir toujours), en dessous de 50 Mo j'ai l'image du haut.

    Est-ce que ça peut venir du fait que ma carte graphique n'est peut-être pas activée sous Windows ? Je pense qu'elle l'est mais pas sûr :







  18. #38
    Membre averti
    Configuration matérielle graphique exotique. C'est un vrai nid à bug sous Ubuntu...
    Je m'explique : par défaut tant que tu ne lances pas d’application demandant de bonne performance vidéo, Windows utilise le GPU intégré au CPU (Intel UHD 630). sinon, il bascule sur la carte graphique nvidia 1050. Du coup, je ne sais pas comment cela se passe pour Virtualbox lors de la bascule de GPU.
    Il va falloir regarder le manuel de Virtualbox pour voir quelle est la configuration proposée. Je serai d'avis de forcer virtualbox à utiliser la carte graphique.
    je te conseille de supprimer le paquet vmware et de redémarrer. Il est possible qu'il y est un conflit entre les deux paquets ( ceux de virtualbox et ceux de vmware)
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo apt remove open-vm-tools-desktop
    Sinon sur quelle version de VirtualBox es tu? Quelle est la version du paquet virtualbox-guest-dkms ?
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    dpkg -l | grep virtualbox-guest-dkms
    Le problème peut venir si tu as des pilotes non aligné à ta version de Virtualbox.
    "Les cons, ça ose tout. C'est même à ça qu'on les reconnaît." Michel Audiard - Les tontons flingueurs

  19. #39
    Candidat au Club
    quote
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo apt remove open-vm-tools-desktop
    Le paquet «*open-vm-tools-desktop*» n'est pas installé, et ne peut donc être supprimé


    Citation Envoyé par gabriel21 Voir le message
    Je serai d'avis de forcer virtualbox à utiliser la carte graphique.
    Oui je suis d'accord j'avais voulu faire ça avant que ma machine ne me lâche...

    Citation Envoyé par gabriel21 Voir le message

    Sinon sur quelle version de VirtualBox es tu? Quelle est la version du paquet virtualbox-guest-dkms ?
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    dpkg -l | grep virtualbox-guest-dkms
    dpkg -l | grep virtualbox-guest-dkms
    ii virtualbox-guest-dkms 6.1.10-dfsg-1~ubuntu1.20.04.1 all x86 virtualization solution - guest addition module source for dkms


    Juste entre parenthèse est ce que quelqu'un peut m'aider avec l'affichage svp ? Je travaille sous une machine virtuelle "de secours" parce que j'ai pleins de tp à rendre en ce moment. L'affichage est juste archi petit là où j'ai entouré en bleu. Le truc c'est que ça me fait ça avec toutes les applications que j'ouvre. J'ai le droit à un affichage tellement petit que je ne vois rien. Ca ne m'a jamais fait ça sous mon ancienne machine, le texte, les icônes tout était bien. Je n'arrive pas à voir où faut modifier ça dans l'éditeur de configuration. Si vous avez une idée parce que là j'ai pleins de choses à rendre.


  20. #40
    Responsable Systèmes

    Si tu ne peux pas sélectionner la résotution dans le panneau de configuration, tu peux essayer de la forcer dans /etc/default/grub :
    Exemple :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    GRUB_GFXMODE=1024x768x32
    GRUB_GFXPAYLOAD_LINUX=keep
    Mais tu peux aussi jouer avec les options mode mise à l’échelle/ajuster à la fenêtre dans le menu écran de la VM.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutor...s/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

###raw>template_hook.ano_emploi###