Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Scilab Discussion :

échelle log avec plo2d problème


Sujet :

Scilab

  1. #1
    Membre à l'essai
    échelle log avec plo2d problème
    Bonsoir,
    J'ai un petit souci avec la fonction plot2d .... Quand je mets l'index "n1", j'ai bien ce que je veux (échelle log).
    Exemple :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
     
    clear
    x = linspace(0,10,11);
    y = 10.^(-x);
    // Plot
    scf(5);
    clf(5);
    plot2d("nl", x, y, style=2);


    Si je change "n1" en "nn", j'ai bien mon axe linéaire. Mais si ensuite je change "nn" en "n1", la figure est vide et je suis obligé de ctrl+Z avant la modification pour que la fonction marche ...

    Avez-vous une idée du souci s'il vous plait ?

    Merci

  2. #2
    Membre à l'essai
    Un screenshot pour illustrer le problème.

    J'ai copié collé le plot2d :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
     
    clear
    x = linspace(0,10,11);
    y = 10.^(-x);
    // Plot
    scf(5);
    clf(5);
    //logg=string('n1');
    plot2d("nl", x, y);
     
    scf(6);
    clf(6);
    plot2d("n1", x, y);


    Je lance la 1er fois : j'ai bien les deux fenêtres, figure 6 et 7 à la bonne échelle.
    Je lance une 2eme fois en remplaçant n1 par nn sur la figure 7: ça marche
    Je lance une 3eme fois en remettant n1 sur la figure 7 :

###raw>template_hook.ano_emploi###