Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Apache Discussion :

VirtualHost erreur 403


Sujet :

Apache

  1. #1
    Membre régulier
    VirtualHost erreur 403
    Bonjour,

    j'essaye de mettre 2 sites sur ma VM de dev.

    Donc j'ai créé 2 virtualHost :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    <VirtualHost *>
            ServerAdmin webmaster@localhost
            DocumentRoot /home/toto/webSocietaire/src/public/
            ServerName soc.toto.fr
     
    <Directory /home/toto/webSocietaire/src/public/>
            Options Indexes FollowSymLinks
            AllowOverride None
            Require all granted
            RewriteEngine On
            RewriteCond %{REQUEST_FILENAME} !-d
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteRule ^((?s).*)$ index.php?_url=/$1 [QSA,L]
    </Directory>
    </VirtualHost>
    <VirtualHost *>
            ServerAdmin webmaster@localhost
            DocumentRoot /home/toto/store/src/public/
            ServerName store.toto.fr
     
    <Directory /home/toto/store/src/public/>
            Options Indexes FollowSymLinks
            AllowOverride None
            Require all granted
            RewriteEngine On
            RewriteCond %{REQUEST_FILENAME} !-d
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteRule ^((?s).*)$ index.php?_url=/$1 [QSA,L]
    </Directory>
    </VirtualHost>


    soc.toto.fr fonctionne correctement.
    store.toto.fr retourne une erreur 403.

    J'ai mis tous les droits sur les dossiers et sous dossiers (chmod -R 777).
    Mais j'ai toujours l'erreur 403 :
    Forbidden
    You don't have permission to access this resource.
    EDIT : J'ai du loupé quelques chose dans la config, car quand je mets l'adresse IP de la VM dans le navigateur, j'arrive sur le site "soc.toto.fr" alors qu'il ne devrait rien trouvé (si je comprends bien les VHs)

  2. #2
    Membre régulier
    Résolu

    Le chemin du second site n'était pas bon...

###raw>template_hook.ano_emploi###