IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Futur Membre du Club
    Homme Profil pro
    responsable Organisation et systèmes d'information
    Inscrit en
    mai 2014
    Messages
    12
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 55
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : responsable Organisation et systèmes d'information
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : mai 2014
    Messages : 12
    Points : 7
    Points
    7
    Par défaut Application ASP.MVC Erreur 404 sur serveur de production
    bonjour j'ai une application ASP.net MVS qui fonctionne correctement sous visual studio et iis express.
    j'ai déployé celle-ci sur le serveur de production
    W2012 R2
    IIS 8.5
    Sql Server Express 2014
    l'application se lance correctement. dans mes formulaires, j'ai un bouton qui me redirige sur un formulaire de création et lorsque je clique sur celui-ci j'ai une erreur 404.
    copie d'écran en pièce jointe

    si je copie l'URL et que je mets le chemin du formulaire, j'ai bien accès à la page.
    j'ai regardé un peu partout, mais je ne vois pas d'anomalie.
    quelqu'un aurait il une idée pour ce type d'erreur.

    Merci pour vos retours
    Fichiers attachés Fichiers attachés

  2. #2
    Expert confirmé

    Homme Profil pro
    Développeur .NET
    Inscrit en
    novembre 2010
    Messages
    1 958
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : novembre 2010
    Messages : 1 958
    Points : 4 002
    Points
    4 002
    Par défaut
    C'est le système de routage qui ne doit pas fonctionner, comment sont défini tes routes, peut être aussi que dans ton web.config il te manque des librairies, je sais qu'un IISserver de par sa configuration ne demande pas forcément les mêmes paramètres que IIS express de visual studio.

  3. #3
    Futur Membre du Club
    Homme Profil pro
    responsable Organisation et systèmes d'information
    Inscrit en
    mai 2014
    Messages
    12
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 55
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : responsable Organisation et systèmes d'information
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : mai 2014
    Messages : 12
    Points : 7
    Points
    7
    Par défaut erreur 404 non resolu
    bonjour,
    désolé pour le retour tardif
    j'ai fait des recherches sur ma route, mais je ne vois pas de souci.
    cf code ci-dessous
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
     
    namespace OMEGA
    {
        public class RouteConfig
        {
            public static void RegisterRoutes(RouteCollection routes)
            {
                routes.IgnoreRoute("{resource}.axd/{*pathInfo}");            
     
                routes.MapRoute(
                    name: "Default",
                    url: "{controller}/{action}",
                    defaults: new { controller = "Connexion", action = "Index" }
                );
     
                routes.MapRoute(
                    name: "Modifier",
                    url: "{controller}/{action}/{id}",
                    defaults: new { controller = "Individu", action = "Modifier", id = 0 }
                );
            }
        }
    }

  4. #4
    Membre habitué
    Profil pro
    Développeur informatique
    Inscrit en
    mars 2010
    Messages
    315
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : mars 2010
    Messages : 315
    Points : 184
    Points
    184
    Par défaut
    Bonjour,

    peut-être tout bête comme solution. Pour l'attribut .id mettre UrlParameter.Optional
    C'est du VB mais il doit certainement y avoir la même chose sous C#

    Code VB : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    routes.MapRoute(
                name:="Default",
                url:="{controller}/{action}/{id}",
                defaults:=New With {.controller = "Authentification", .action = "Login", .id = UrlParameter.Optional}
            )

Discussions similaires

  1. Réponses: 17
    Dernier message: 19/02/2013, 18h21
  2. erreur 404 sur serveur 1&1
    Par lefrangin dans le forum 1&1
    Réponses: 2
    Dernier message: 01/03/2012, 10h27
  3. [IIS6] Erreur 404 sur les scripts asp
    Par Maximil ian dans le forum IIS
    Réponses: 2
    Dernier message: 06/07/2007, 12h38
  4. erreur 404 sur serveur tomcat
    Par sg.forums dans le forum Tomcat et TomEE
    Réponses: 2
    Dernier message: 30/10/2006, 14h16
  5. erreur 404 sur serveur tomcat
    Par sg.forums dans le forum Servlets/JSP
    Réponses: 2
    Dernier message: 27/10/2006, 12h11

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo