Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Raspberry Pi Discussion :

Serveur PI4 PHP5.6


Sujet :

Raspberry Pi

  1. #1
    Membre du Club
    Serveur PI4 PHP5.6
    A l'heure actuelle, j'ai un serveur PI2 avec PHP5.6 MySql

    J'essaie de passer en PI4 afin de gagner de la mémoire vive, port USB3 pour disque SSD externe
    Mais le nouvel OS Buster Raspbian10 installe PHP7.3 qui n'est pas compatible avec la 5.6
    Des milliers de lignes sont à vérifier...
    Qui a déjà été confronté à cette problématique ?
    A+

  2. #2
    Expert éminent sénior
    Salut Apicultrice.

    Citation Envoyé par Apicultrice
    A l'heure actuelle, j'ai un serveur PI2 avec PHP5.6 MySql
    Dois-je comprendre que vous utilisez une carte micro SD ?
    Si oui, pourquoi ne pas la recopier sur votre disque SSD ?

    Il n'est pas nécessaire d'installer la dernière version de Raspberry Pi OS (peut-être la 64 bits) sur un disque SSD si vous utilisez RPi 4.
    J'utilise la version 32 bits que j'ai sur mon disque dure non SSD.

    Si la version php7.3 ne vous convient pas, qu'est-ce qui vous empêche de la désinstaller et de mettre php5.6 ?

    Les versions php encore maintenues sont la 7.4, 7.3 et 7.2.
    Je vous conseille, par contre, de migrer petit à petit php afin d'avoir les dernière fonctionnalité.

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

###raw>template_hook.ano_emploi###