Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Lazarus Pascal Discussion :

Comment installer Lazarus sous Mac OS


Sujet :

Lazarus Pascal

  1. #1
    Nouveau membre du Club
    Comment installer Lazarus sous Mac OS
    Bonjour

    ayant bcp développé sous Delphi mais ayant arrêté depuis 10ans ai téléchargé Lazarus pour Mac
    j arrive à l installer, ouvrir l edu mais après impossible de compiler quoi que ce soit il me manque compilateur

    que faire ??
    merci de votre aide
    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  2. #2
    Modérateur

    Bonjour,
    Ne convient-il pas de télécharger FPC (Free Pascal Compiler) d'abord ?

    Sinon, un installeur comme fpcupdeluxe fonctionne-t-il sous cet environnement ?

    Y a-t-il d'autres contraintes ? Je ne sais !

    Bon courage et bonne chance !
    Delphi 5 Pro - Delphi 10.3.2 Rio Community Edition - CodeTyphon 6.90 sous Windows 10 ; CT 6.40 sous Ubuntu 18.04 (VM)
    . Ignorer la FAQ Delphi et les Cours et Tutoriels Delphi nuit gravement à notre code !

  3. #3
    Nouveau membre du Club
    J ai récupéré les 3 fichiers d Install sur leur site mais dans quel ordre les installer ??
    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  4. #4
    Membre expert
    Citation Envoyé par PHCM64310 Voir le message
    Bonjour

    ayant bcp développé sous Delphi mais ayant arrêté depuis 10ans ai téléchargé Lazarus pour Mac
    j arrive à l installer, ouvrir l edu mais après impossible de compiler quoi que ce soit il me manque compilateur

    que faire ??
    merci de votre aide

    Citation Envoyé par tourlourou Voir le message
    Bonjour,
    Ne convient-il pas de télécharger FPC (Free Pascal Compiler) d'abord ?

    Sinon, un installeur comme fpcupdeluxe fonctionne-t-il sous cet environnement ?

    Y a-t-il d'autres contraintes ? Je ne sais !

    Bon courage et bonne chance !
    Salut oui, FPCUpdeluxe fonctionne sous Mac et oui il y a des contraintes, comme installer les outils "X-Codes", il faut signer le débugger (DBG) je crois qu'avec LLDB ce n'est pas la peine.

    Pour plus d'aide tu peux regarder du coté de ce tuto

    Et tu trouvera sur le wiki (en anglais) ici et la d'autres informations relative à l'installation de Lazarus sous cet OS

    A+

    Jérôme

    EDIT en 1er il faut installer les sources de FPC puis FPC en enfin Lazarus
    • "L'Homme devrait mettre autant d'ardeur à simplifier sa vie qu'il met à la compliquer" - Henri Bergson
    • "Bien des livres auraient été plus clairs s'ils n'avaient pas voulu être si clairs" - Emmanuel Kant
    • "La simplicité est la sophistication suprême" - Léonard De Vinci
    • "Ce qui est facile à comprendre ou à faire pour toi, ne l'est pas forcément pour l'autre." - Mon pèrei

    Mes projets sur Github - Blog - Site DVP

  5. #5
    Nouveau membre du Club
    merci mais ca fonctionne pas

    "Ce qui est facile à comprendre ou à faire pour toi, ne l'est pas forcément pour l'autre."
    c est bien vrai ...
    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  6. #6
    Membre expert
    Bonjour, je vais essayer de t'aider alors,

    Reprenons depuis le début et commençons par le commencement.

    Quelle est ta version de MacOS ? 10.4 Mojave ? 10.5 Catalanina ? autre ?

    Ensuite désinstalles correctement tout ce que tu as installés précédemment en rapport avec Lazarus et FPC.

    Après la suite cela va dépendre de ta réponse

    A+

    Jérôme
    • "L'Homme devrait mettre autant d'ardeur à simplifier sa vie qu'il met à la compliquer" - Henri Bergson
    • "Bien des livres auraient été plus clairs s'ils n'avaient pas voulu être si clairs" - Emmanuel Kant
    • "La simplicité est la sophistication suprême" - Léonard De Vinci
    • "Ce qui est facile à comprendre ou à faire pour toi, ne l'est pas forcément pour l'autre." - Mon pèrei

    Mes projets sur Github - Blog - Site DVP

  7. #7
    Nouveau membre du Club
    Merci Jerome

    a savoir que je n ai pas de but précis sauf faire marcher mon vieux cerveau.... (Avais créé un soft de Généalogie sous Delphi)

    Suis sur Mac OSX Big Sur
    Ai un MacBook Pro 13'' de 2020

    Ai tout désinstalle de ce que j avais installé de Lazarus

    Faut il d abord que j installe Xcode ?
    A++
    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  8. #8
    Membre expert
    Citation Envoyé par PHCM64310 Voir le message
    Merci Jerome

    a savoir que je n ai pas de but précis sauf faire marcher mon vieux cerveau.... (Avais créé un soft de Généalogie sous Delphi)

    Suis sur Mac OSX Big Sur
    Ai un MacBook Pro 13'' de 2020

    Ai tout désinstalle de ce que j avais installé de Lazarus

    Faut il d abord que j installe Xcode ?
    A++
    Ok, Donc :

    Etape 1 : Installer Xcode 11.4.x minimulm ou la dernière version depuis le store. Mais avant cela tu dois d'abord déplacer toutes les anciennes versions de Xcode du dossier Applications vers la corbeille ou renommer l'application Xcode

    Etape 2 : Dans un terminal tu dois executer les commandes suivantes :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    sudo xcode-select --install
    sudo xcodebuild -license accept


    Etape 3 : Tu télécharges les fichiers d'installation de FPC et Lazarus ici et tu les installes dans l'ordre suivant :
    1. Sources FPC
    2. FPC
    3. Lazarus


    Etape 4 :
    1. Lances Lazarus
    2. Diriges toi dans le menu "Outils" --> "Options" et dans "Débogueur"
    3. En haut il faut choisir "LLDB debugger (with fpdebug) (Beta)"
      Si cette options n'est pas présente dans la liste diriges toi dans le menu "Paquet"--> Installer/désinstaller des paquets" puis tu choisis (dans la liste à droite) le paquet "LazDebuggerFpLldb" et tu cliques sur "Enregistrer et recréer l'EDI" et tu reviens à la sous-étapes précédente.


    Etape 5 : Dans les options de tes projets menu "projet" --> "Options du projets". Diriges toi dans la branche "Options du compilateur" --> "Débogage" et tu définis l'option "Type d'informations du débogage" sur "Dwarf3 beta (-gw3)"

    Voila en principes cela devrais fonctionner.

    Notes que sous BIG tu ne peux pas compiler sans débogage

    A+

    Jérôme
    • "L'Homme devrait mettre autant d'ardeur à simplifier sa vie qu'il met à la compliquer" - Henri Bergson
    • "Bien des livres auraient été plus clairs s'ils n'avaient pas voulu être si clairs" - Emmanuel Kant
    • "La simplicité est la sophistication suprême" - Léonard De Vinci
    • "Ce qui est facile à comprendre ou à faire pour toi, ne l'est pas forcément pour l'autre." - Mon pèrei

    Mes projets sur Github - Blog - Site DVP

  9. #9
    Nouveau membre du Club
    Ok Jerome Xcode est en route je fais lez reste après et te dis
    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  10. #10
    Nouveau membre du Club
    Depuis 15h ai lancé la première commande sudo et ca n avance pas

    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  11. #11
    Nouveau membre du Club
    Mon XCodr fonctionne et il a même ouvert un tres vieux projet que j avais
    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  12. #12
    Nouveau membre du Club
    Bon finalement ai pu faire tout ce que tu as dit

    j ouvre Lazarus sur la fenêtre par défaut je pose juste un bouton je compile et erreur

    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  13. #13
    Membre expert
    Il te met qu'il ne trouve pas le framework cocoa, il y a surement une option à activer dans les outils Xcodes pour rendre accessible l'interface Cocoa
    • "L'Homme devrait mettre autant d'ardeur à simplifier sa vie qu'il met à la compliquer" - Henri Bergson
    • "Bien des livres auraient été plus clairs s'ils n'avaient pas voulu être si clairs" - Emmanuel Kant
    • "La simplicité est la sophistication suprême" - Léonard De Vinci
    • "Ce qui est facile à comprendre ou à faire pour toi, ne l'est pas forcément pour l'autre." - Mon pèrei

    Mes projets sur Github - Blog - Site DVP

  14. #14
    Membre expert
    J'ai posé la question sur le forum anglais, on verra leur retour

    Bonne soirée
    • "L'Homme devrait mettre autant d'ardeur à simplifier sa vie qu'il met à la compliquer" - Henri Bergson
    • "Bien des livres auraient été plus clairs s'ils n'avaient pas voulu être si clairs" - Emmanuel Kant
    • "La simplicité est la sophistication suprême" - Léonard De Vinci
    • "Ce qui est facile à comprendre ou à faire pour toi, ne l'est pas forcément pour l'autre." - Mon pèrei

    Mes projets sur Github - Blog - Site DVP

  15. #15
    Nouveau membre du Club
    Je vois pas ou cette option , sinon je peux désinstaller Xcode v11 et mettre la Beta V12 s il faut

    merci Jerome

    A priori ca a installé les lignes de commandes de la beta 12 !!!

    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  16. #16
    Membre expert
    Citation Envoyé par PHCM64310 Voir le message
    Je vois pas ou cette option , sinon je peux désinstaller Xcode v11 et mettre la Beta V12 s il faut

    merci Jerome

    A priori ca a installé les lignes de commandes de la beta 12 !!!
    Bonjour attention "XCode" et "XCode Command line tools" sont deux choses différentes. D'après une réponse sur le forum anglais il semblerai que le SDK "XCode" ne soit pas installé correctement.

    Voici ce que dit la doc (traduite avec google)

    Vous avez besoin des outils Apple Developer, qui font partie de l'environnement de développement Xcode.

    Xcode 11.3.1 pour une utilisation sur macOS 10.14 Mojave doit maintenant être installé en le téléchargeant depuis Apple Developer Connection (ADC), qui nécessite une inscription gratuite. Xcode 11.4.x pour une utilisation sur macOS 10.15 Catalina peut être installé à partir du Mac App Store. Notez que vous devez d'abord déplacer toutes les anciennes versions de Xcode du dossier Applications vers la corbeille ou renommer l'application Xcode (par exemple Xcode.app en Xcode_1014.app). Vous pouvez sélectionner la version de Xcode à utiliser avec l'utilitaire de ligne de commande xcode-select.

    Anciens systèmes:

    Les outils de développement peuvent être installés à partir des disques d'installation d'origine de macOS ou d'une copie plus récente téléchargée à partir d'Apple Developer Connection (ADC), ce qui nécessite une inscription gratuite. Téléchargez le fichier Xcode, il se retrouvera dans votre répertoire Téléchargements sous forme de fichier zip. Cliquez dessus. Il est désarchivé dans votre répertoire Téléchargements. Vous en serez peut-être satisfait, mais peut-être pas. Les autres utilisateurs verront le chemin d'accès mais ne pourront pas l'utiliser. Et c'est désordonné là-bas. J'ai donc déplacé le mien puis j'ai dit à xcode-select où il avait été déplacé (dans un terminal) -

    Téléchargements mv / Xcode.app / Developer /.
    Sudo xcode-select -s /Developer/Xcode.app/Contents/Developer
    Essayes le lien Mac App Store pour voir et dis moi.

    A+

    Jérôme
    • "L'Homme devrait mettre autant d'ardeur à simplifier sa vie qu'il met à la compliquer" - Henri Bergson
    • "Bien des livres auraient été plus clairs s'ils n'avaient pas voulu être si clairs" - Emmanuel Kant
    • "La simplicité est la sophistication suprême" - Léonard De Vinci
    • "Ce qui est facile à comprendre ou à faire pour toi, ne l'est pas forcément pour l'autre." - Mon pèrei

    Mes projets sur Github - Blog - Site DVP

  17. #17
    Nouveau membre du Club
    Bonjour Jerome

    comme te disais plus haut ai installé Xcode 11.6 pris sur le AppStore et ai pu compiler avec un petit projet que j avais

    mais la ligne de commande que tu m as fait taper sur terminal installe la version 12 beta des lignes de commandes

    y a t il qq part un lien pour télécharger ces outils ??

    Si tu veux je peux aussi te donner la main sur mon Mac via Message
    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  18. #18
    Membre expert
    Citation Envoyé par PHCM64310 Voir le message
    Bonjour Jerome

    comme te disais plus haut ai installé Xcode 11.6 pris sur le AppStore et ai pu compiler avec un petit projet que j avais

    mais la ligne de commande que tu m as fait taper sur terminal installe la version 12 beta des lignes de commandes

    y a t il qq part un lien pour télécharger ces outils ??

    Si tu veux je peux aussi te donner la main sur mon Mac via Message
    Oui via ADC tu peux télécharger le fichier ZIP de XCode je te conseille une version stable et non beta pour les 2 au lieu des "command line tools" en beta comme te le propose le XCode-select
    • "L'Homme devrait mettre autant d'ardeur à simplifier sa vie qu'il met à la compliquer" - Henri Bergson
    • "Bien des livres auraient été plus clairs s'ils n'avaient pas voulu être si clairs" - Emmanuel Kant
    • "La simplicité est la sophistication suprême" - Léonard De Vinci
    • "Ce qui est facile à comprendre ou à faire pour toi, ne l'est pas forcément pour l'autre." - Mon pèrei

    Mes projets sur Github - Blog - Site DVP

  19. #19
    Nouveau membre du Club
    ai trouvé la version 11.5 arrive
    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

  20. #20
    Nouveau membre du Club
    rejet de la version 11.5 OS trop récent je charge la dernière en date alors
    Quand ils auront coupé le dernier arbre, pollué le dernier ruisseau, pêché le dernier poisson. Alors ils verront que l'argent ne se mange pas
    Citation de Sitting Bull - Chef des Indiens Sioux
    _______________________________
     MacBookPro 13" TouchBar - OS X : 10.16 Big Sur
     Iphone XR - IOS 14

    https://www.youtube.com/channel/UCMJ...IsRN_OA/videos

###raw>template_hook.ano_emploi###