Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Unity Discussion :

bug unity en lançant un jeu hors éditeur


Sujet :

Unity

  1. #1
    Candidat au Club
    bug unity en lançant un jeu hors éditeur
    bonjour a tous, voila mon problème : je suis en train de creer un jeux sur unity 3d. lorsque je lance le jeu dans unity, tous se passe très bien mais après avoir fait le build et que je lance le jeu, il bug beaucoup. merci d'avance a celui ou celle qui m'aidera

  2. #2
    Membre expérimenté
    Laisse moi sortir ma boule magique



    Je vois ... oui je vois des bugs aussi, de vilains bugs ... il y en a partout.




    Non plus sérieusement, c'est quoi que tu appelles bug ? Des ralentissements ? Des objets qui ne se comportent pas comme il faut ? Des bugs graphiques ?
    Keep calm and debug it

  3. #3
    Candidat au Club
    bonjour
    excusez moi de ne pas avoir précisé. et en effet ce sont des ralentissement (ce n'est pas fluide).

  4. #4
    Membre expérimenté
    Merci de ne pas nous noyer sous les informations. On sens que le problème te tient à cœur mais essaye de faire des paragraphes plus courts et focusés sur ton problème car il y a beaucoup trop de détail, c'est très long à lire.

    Plus sérieusement, comment veux tu qu'on t'aide avec si peu d'info? Décris plus en profondeur ton problème.

    Suggestion de ma boule de cristal spécial ralentissement™: es-tu sur d'avoir un PC assez puissant pour faire tourner ta démo de manière fluide, ton jeu est il lancé avec la carte graphique (et pas le chipset integré?).

  5. #5
    Candidat au Club
    en fait, lorsque je fais la demo dans unity aucun ralentissement se produit, mais lorsque je build le jeu et que je le lance, les alentissements se produisent.
    processeur : 2.90 GHz
    ram : 4 GOdont 3,89GO disponible.
    et oui le jeu est lancé avec la carte graphique

  6. #6
    Membre expérimenté
    Merci pour les précisions, du coup j'ai plusieurs questions :

    - Le jeu en question est-il assez gourmand ? Shaders, calculs assez lourds, etc ...
    - Les ralentissements sont-ils constants ?
    - Tu as testé le jeu sur d'autres machines ?
    - Est ce que tu travailles sur 2 écrans ?

    Si ça tourne parfaitement dans l'éditeur, c'est que ça peut venir des préférences de qualité, qui sont différentes quand tu build le jeu. Regarde de ce côté là.



    Sinon il faudrait voir un peu a quoi ressemble ton jeu
    Keep calm and debug it

  7. #7
    Expert éminent
    Citation Envoyé par clemdc Voir le message
    en fait, lorsque je fais la demo dans unity aucun ralentissement se produit, mais lorsque je build le jeu et que je le lance, les alentissements se produisent.
    processeur : 2.90 GHz
    ram : 4 GOdont 3,89GO disponible.
    et oui le jeu est lancé avec la carte graphique
    On peut pas faire mieux niveau précision
    Alors que tu as 3,89 Go de disponible, (sur 4 Go) j'ai envie de dire "impossible" aucun OS ne prend 110Mo (sauf si tu es sur Windows XP).
    " 2.90 GHz" , ça veut rien dire , un pentium4 ça monte à 4 GHz est c'est globalement de la merde
    (et une précision de la CG est toujours mieux parce que bon avoir un nvidia 650 et 1050 c'est pas le même délire :p )

  8. #8
    Candidat au Club
    merci a tous de vos réponse je viens de régler le problème

###raw>template_hook.ano_emploi###