Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Futur Membre du Club
    savoir le statut d un caractère arabe dans un mot
    Bonjour tout le monde
    je veux savoir si il y'a une fonction ou macro qui permet de me renseigner sur le statut d un caractère arabe dans un mot par exemple le mot "اتبع"
    la lecture se fait de droite à gauche
    le résultat souhaité devra être la suivante
    premier caractère à droite "ا" donne isolé
    deuxième caractère à partir de la droite "ت" donne début
    troisième caractère à partir de la droite "ب" donne milieu
    quatrième caractère à partir de la droite "ع" donne final
    et merci d'avance de vos idées et coordinations

  2. #2
    Membre expert
    Bonjour,

    Si j'ai bien compris


    Cdlt

  3. #3
    Futur Membre du Club
    Par défaut savoir le statut d un caractère arabe dans un mot
    merci Monsieur ARTUR083
    mais ce n'est pas ça ce que je veux commevrésultat
    j m'explique vous voyer que le mot arabe "اتبع" se compose de quatre lettres qui viennent respectivement
    "ا"
    "ت"
    "ب"
    "ع"
    alors vous voyez que la premiere lettre est isolée donc excel avec une macro ou fonction doivent verifier qu'elle est isolée en verifiant s'il y a un espace devant la lettre et derriere la lettre ou si la lettre et le commencement du mot et il y'a un espace devant
    la deuxieme lettre vous voyez qu elle est attachée à d'autres(2 lettres) donc excel doit dtecter qu ilest le debut de mot
    et la troisieme se situe entre deux lettres excel doit detecter qu elle est au milieu et ainssi de suite
    merci pour ta reponse

  4. #4
    Membre expert
    bonjour,

    alors vous voyez que la premiere lettre est isolée
    non, je ne la vois pas isolée, mais pour les essais j'ai inséré un espace, me dire si ça vous convient.


    Voici la proposition avec formules


    Formules utilisées
    - en colonne C, pour détecter la position de chaque caractère
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    =TROUVE($B2;$F$2;1)


    -en Colonne E, le résultat attendu
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    =SI(OU(ET(GAUCHE($C2;1)=" ";STXT($F$2;$C2;1)<>"";STXT($F$2;$C2+1;1)=" ");ET(STXT($F$2;$C2;1)<>"";STXT($F$2;$C2+1;1)=" "));"Isolé";
    SI(ET(STXT($F$2;$C2-1;1)=" ";STXT($F$2;$C2+1;1)<>"");"Début";
    SI(ET(STXT($F$2;$C2-1;1)<>"";STXT($F$2;$C2-1;1)<>" ";STXT($F$2;$C2+1;1)<>"");"Milieu";
    SI(ET(STXT($F$2;$C2-1;1)<>"";STXT($F$2;$C2-1;1)<>" ";STXT($F$2;$C2+1;1)="");"Final"))))


    le fichier


    Cdlt

  5. #5
    Futur Membre du Club
    savoir le statut d un caractère arabe dans un mot
    merci pour la reponse c'est une bonne piste reste à l'appliquer sur des mots qui se composent de plusieurs caractere
    st voici le résultat en appliquant le formule de votre fichier envoyé sur ce mot dans le fichier ci-joint
    merci encore

  6. #6
    Membre expert
    Bonjour,

    Bien sûr, ne connaissant pas l'arabe, les propositions faites ci-dessous, avec manipulation du texte en arabe, ne peuvent correspondre en rien à la réalité cependant, cela vous donne une approche et il suffira de quelques ajustements de votre part pour que ça colle à la réalité.
    La présentation des formules avec renvoi à la ligne pour chaque condition permet une lecture plus aisée et de ce fait, plus facile à modifier ou à ajuster si nécessaire.

    Voici une présentation avec les 4 options possibles:
    1)-pas d'espace avant et après le premier caractère
    2)-1 espace après le premier caractère
    3)-1 espace avant et après le premier caractère
    4)-1 espace avant le premier caractère

    Vue des 4 options


    Le fichier en exemple


    La formule utilisée en colonne C
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    =SIERREUR(SI(OU(ET(GAUCHE($D2;1)=" ";STXT($D$2;$B2;1)<>"";STXT($D$2;$B2+1;1)=" ");ET(STXT($D$2;$B2;1)<>"";STXT($D$2;$B2+1;1)=" "));"Isolé";
    SI(ET(STXT($D$2;$B2-1;1)=" ";STXT($D$2;$B2+1;1)<>"");"Début";
    SI(ET(STXT($D$2;$B2-1;1)<>"";STXT($D$2;$B2-1;1)<>" ";STXT($D$2;$B2+1;1)<>"");"Milieu";
    SI(ET(STXT($D$2;$B2-1;1)<>"";STXT($D$2;$B2-1;1)<>" ";STXT($D$2;$B2+1;1)="");"Final"))));"Début")


    Cdlt

  7. #7
    Futur Membre du Club
    savoir le statut d un caractère arabe dans un mot
    Merci beaucoup pour la collaboration fructueuse
    cordialement