Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

OpenOffice & LibreOffice Discussion :

calc ne veut pas afficher le résultat d'un calcul


Sujet :

OpenOffice & LibreOffice

  1. #1
    Membre à l'essai
    calc ne veut pas afficher le résultat d'un calcul
    Bonjour à tous,

    Je souhaite obtenir le résultat de'=sommeprod(nbrecar(A1:B1))' en C1 et le résultat de '=nbrecar(A1)' en C2
    Actuellement seule la formule s'affiche et voici mon paramétrage calc : Outils/Options Afficher Formule ; décocher

    Je suis bloqué et je ne comprends pas.
    Voici mon fichier

    Merci de votre support.


  2. #2
    Membre éclairé
    Bonjour Muay74,

    le résultat de'=sommeprod(nbrecar(A1:B1))' en C1 et le résultat de '=nbrecar(A1)' en C2
    La fonction nbrecar() n'existe pas, c'est NBCAR() qui renvoie le nombre de caractères d'une ou d'un groupe de cellules.

    Utilisez les formules suivantes:
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    =SOMMEPROD(NBCAR(A1:B1))

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    =NBCAR(A1)


    Voyez si le fichier joint peut vous aider



    LibreOffice 6.3.5.2 (x64) FR-YT 07-03-20
    OS : Windows 10.0

  3. #3
    Membre à l'essai
    Bonsoir,

    merci pour cette réponse.
    Le problème c'est que je n'ai aucun résultat, le problème reste entier puisque en C1 j'ai =SOMMEPROD(NBCAR(A1:B1)) et en C2 j'ai =NBCAR(A1)

    Avez-vous 1 idée ?

    Merci de votre support

  4. #4
    Membre éclairé
    Bonsoir Muay74,

    Vous avez sans doute vu que les formules fonctionnent dans le fichier que j'ai posté à votre attention.

    L'idée est que les propriétés de vos cellules contiennent des éléments perturbateurs.
    Effacez les cellules concernées, mettez les au format par défaut, insérez les formules et tout devrait fonctionner

    Sinon, utilisez le fichier fonctionnel
    LibreOffice 6.3.5.2 (x64) FR-YT 07-03-20
    OS : Windows 10.0

  5. #5
    Membre à l'essai
    Bonjour njhub,

    Merci de votre aide, même votre fichier original, chez moi cela ne fonctionne pas.
    Je vous mets le Printscreen.
    Je n'ai pas le résultat de la formule en C1 ou en C2....

    Je vous reconfirme la configuration : Outils / Options / LibreOffice Calc / Affichage / Formules décochée

    Dois-je d'après vous réinitialiser mon profil LibreOffice, en ultime recours...

    Merci de votre support.

  6. #6
    Membre éclairé
    Bonjour Muay74,

    Il est regrettable qu'on ne voie pas quel fichier est en impression écran.
    Ni s'il est en lecture seule...

    Si vous avez enregistré le fichier que je vous ai fait parvenir, il devrait fonctionner.

    S'il ne fonctionne pas, faites une analyse antivirale de votre système,
    sinon on pourrait incriminer la configuration de LibreOffice,
    ou réinstallez la suite LibreOffice avec les valeurs par défaut.

    LibreOffice 6.3.5.2 (x64) FR-YT 07-03-20
    OS : Windows 10.0

  7. #7
    Membre à l'essai
    Rebonjour,

    c'était votre fichier.
    Je vais explorer les différentes pistes évoquées et reviens vers vous.

    En tout cas Merci pour tout.

  8. #8
    Membre du Club
    Bonjour,
    Vérifie que dans le Style par défaut, le format Nombres ne soit pas Texte (@), et efface tout formatage direct des cellules (Ctrl+M).
    Cordialement,

  9. #9
    Membre à l'essai
    Merci,
    je regarde et reviens vers vous.......
    Merci de votre aide

  10. #10
    Membre à l'essai
    Bonjour à tous,

    comme promis, voici les résultats de mes tests
    Outils / Options … / LibreOffice Calc / Afficher / Décocher Formules
    Appliquer + OK

    Je n'avais pas cliquer sur 'Appliquer' avant de cliquer sur 'OK' mais juste sur 'OK.

    Ca me semble fou mais cela fonctionne maintenant.

    1) Trouvez vous cela étrange ?
    Peut-on conclure systématiquement (Nous avons au préalable Outils / Options … / LibreOffice Calc / Afficher / Décocher Formules) que :
    2) Si nous faisons une faute de syntaxe dans la formule, le résultat erroné de celle-ci ne s'affichera pas et nous aurons à l'écran la formule elle-même ?
    3) Quelque soit la fonction utilisée, faut il s'assurer que la feuille soit formatée en Nombre standard ? En d'autre mot, les fonctions ne sont elles que valide pour des nombres et non des textes ?

    J'attends vos réponses sur les points 1.2 et 3 avant de clore le post

    Merci encore pour votre aide précieuse

  11. #11
    Membre du Club
    1/2/3 = oui/non/non
    Je ne reproduis pas l'obligation d'utiliser Appliquer. Ok suffit (version LibreOffice 6.3.6.2).
    Tente une purge de ton profil.
    Cordialement,

  12. #12
    Membre à l'essai
    Merci