Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Futur Membre du Club
    comment enlever le "0" zone de texte en lien avec une cellule feuille précédente
    Bonjour
    j'ai un classeur avec plusieurs feuilles relier avec une base locale, sur la feuille "Comités" j'ai insérer une carte de France avec tous les départements, sur chaque département j'ai une zone de texte qui est renseigné "='Total STATS'!D23" sur la page "Total STATS" si la cellule recherchée est vide elle retourne un "0" comment afficher ma zone texte vide pour plus de lisibilités
    j'ai bien entendu essayé plusieurs fonctions "est vide , sommeSi, ect..." sans résultats
    merci d'avance pour votre aide


  2. #2
    Expert éminent sénior
    Si je ne me trompe pas, il n'est pas possible de mettre une formule dans une zone de texte. On peut seulement mettre une référence de cellule (comme ce que tu montres).

    Donc, si tu dois ajouter une formule, il faut le faire dans ton tableau source.
    S'il s'agit de données copiée dans lesquelles tu ne peux pas mettre de formule, il va falloir créer une nouvelle colonne (ou même un onglet supplémentaire) pour mettre cette formule.
    La formule en question pourrait être une simple formule SI du type : =SI(A1=0;"";A1)
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  3. #3
    Futur Membre du Club
    Bonjour
    merci pour la réponse bien entendu ma zone texte fait référence a une cellule celle-ci est bien vide mais elle renvoie un "0" même avec ta formule

    peut-être une autre solution??

    merci

  4. #4
    Futur Membre du Club
    re bonjour
    j'ai essayé d'appliquer ta formule : créer une nouvelle colonne avec la fonction =SI(A1=0;"";A1) effectivement la sa fonctionne

    ma cellule de base est formatée comme cela: =SOMME(Feuil1!B7+Feuil2!B7+Feuil3!B7+Feuil4!B7+Feuil5!B7+Feuil6!B7) c'est feuilles sont en liens avec une base locale

    comment adapter ta formule a ma cellule

    merci

  5. #5
    Expert éminent sénior
    Tu remplaces les "A1" de ma formule par ta formule (sans le "=").
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  6. #6
    Futur Membre du Club
    merci pour la réponse jetait en train justement d’appliquer cette fonction ne marche pas correctement 1 sur 2 reste a "0"

  7. #7
    Expert éminent sénior
    Analyse quelle est la différence entre ceux qui restent à 0 et ceux qui fonctionne.
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  8. #8
    Futur Membre du Club
    je ne sais pas la formule est la même sur toutes les cellules les liens sur les zones textes sont bon !!!!!!!

  9. #9
    Expert éminent sénior
    Si les formules sont les mêmes mais que les résultats sont différents, c'est forcément qu'il y a une différence dans les données d'entrées.
    C'est toi qui a le fichier sous les doigts. A toi d'analyser tes données d'entrée en comparant celles qui sont fonctionnelles à celles qui ne le sont pas.
    Perso, je commencerais pas supprimer les alignements pour voir si certaines ne s'alignent pas d'elles-même à gauche...
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  10. #10
    Futur Membre du Club
    Bonsoir Menhir

    J'ai résolue le problème j'ai simplement fait comme tu me le disait dans ta première réponse un peux de travail mais le résultat est correct

    merci pour ton aide



    Citation Envoyé par Menhir Voir le message
    Si je ne me trompe pas, il n'est pas possible de mettre une formule dans une zone de texte. On peut seulement mettre une référence de cellule (comme ce que tu montres).

    Donc, si tu dois ajouter une formule, il faut le faire dans ton tableau source.
    S'il s'agit de données copiée dans lesquelles tu ne peux pas mettre de formule, il va falloir créer une nouvelle colonne (ou même un onglet supplémentaire) pour mettre cette formule.
    La formule en question pourrait être une simple formule SI du type : =SI(A1=0;"";A1)