Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Apache Discussion :

public_html ne fonctionne pas


Sujet :

Apache

  1. #1
    Candidat au Club
    public_html ne fonctionne pas
    Ce message n'a pas pu être affiché car il comporte des erreurs.

  2. #2
    Candidat au Club
    Complément d'information
    Bonjour,
    Ce problème concerne Firefox, j'ai installé Opéra et tout fonctionne bien !! Quelqu'un a une idée quoi faire avec firefox (le problème n'est pas avec l'add blocker) ?
    Merci, John

  3. #3
    Candidat au Club
    Problème résolu
    Je ne suis pas maintenant certain que PHP fonctionnait avec Opera à ce moment-là. Dans tout état de cause quand j'ai mis à jour le paquet opera-stable jusqu'à la version 67.0.3575.137, tous les fichiers php, y compris http://localhost rédirigé à index.php, présentaient des listings des programmes au lieu de les executer.

    Alors j'ai fait les deux modifications suivantes (toutes les deux prises de https://stackoverflow.com/questions/...d-of-executing) :

    1) editer /etc/apache2/mods-enabled/php7.2.conf pour inactiver 5 lignes comme ci-dessous :

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    # Running PHP scripts in user directories is disabled by default
    # 
    # To re-enable PHP in user directories comment the following lines
    # (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
    # prevents .htaccess files from disabling it.
     
    # marquer comme commentaire <IfModule mod_userdir.c>
    # marquer comme commentaire     <Directory /home/*/public_html>
    # marquer comme commentaire        php_admin_flag engine Off
    # marquer comme commentaire    </Directory>
    # marquer comme commentaire </IfModule>


    A ce moment http://localhost fonctionnait avec Opera mais les appels directs aux fichiers php donnaient toujours des listings des fichiers.

    2) editer /etc/apache2/mods-enabled/mime.conf et ajouter après ces lignes :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    # AddType allows you to add to or override the MIME configuration
    # file mime.types for specific file types.


    les lignes suivantes :

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    AddType application/x-httpd-php .php
    AddHandler application/x-httpd-php .php


    Après redemarrage d'Apache mon site web local basé sur PHP semble bien fonctionner et avec Opera et avec Firefox 75.0 64 bits.