Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre du Club
    Connexion à mon site intranet via une url dans le fichier hosts de windows
    Bonsoir à tous,

    J'aurais besoin de votre aide pour un soucis de configuration d'Apache 2.

    J'ai une machine virtuelle que laquelle j'ai installé une distribution Debian (10) sans interface graphique (Suite LAMP installée) en IP fixe 192.168.1.50.

    J'ai dupliqué plusieurs fois le même site pour faire une formation à mon boulot.

    Chaque site se trouve dans le dossier /var/www/ puis intra01.urlsociete.org, intra02.urlsociete.org etc...

    J'ai configuré, pour chaque site mes virtualhosts d'apache que j'ai placé dans /etc/apache2/sites-available/ de cette manière : intra01.urlsociete.org.conf (1 pour chaque site, j'en ai 8)

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    <VirtualHost *:80>
     
    	ServerName intra01.urlsociete.org
    	DocumentRoot /var/www/intra01.urlsociete.org
     
    	CustomLog /var/log/apache2/intra01.urlsociete.org.log vhost_combined
    	ErrorLog /var/log/apache2/intra01.urlsociete.org.log
     
    </VirtualHost>


    J'ai activé chaque site avec la commande :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    sudo a2ensite /etc/apache2/sites-available/intra01.urlsociete.org.conf


    Le service apache a été redémarré ainsi que le serveur.

    Sur mes clients Windows 10, j'ai ajouté dans le fichier hosts les lignes suivantes :

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    192.168.1.50 intra01.urlsociete.org
    192.168.1.50 intra02.urlsociete.org
    192.168.1.50 intra03.urlsociete.org
    192.168.1.50 intra04.urlsociete.org
    192.168.1.50 intra05.urlsociete.org
    192.168.1.50 intra06.urlsociete.org
    192.168.1.50 intra07.urlsociete.org
    192.168.1.50 intra08.urlsociete.org


    Mon problème :
    Lorsque je saisi l'URL intra01.urlsociete.org dans le navigateur de mon client, j'arrive à la racine de mon serveur /var/www/ alors que je voudrais arriver directement dans le dossier /var/www/intra01.urlsociete.org

    Je ne sais pas où j'ai pêché.

    Merci de votre aide.

  2. #2
    Membre du Club
    N'ayant pas eu de succès avec ma question, je vous apporte la réponse...

    J'ai été obligé de désactiver 000-default.conf en utilisant la commande :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    sudo a2dissite 000-default.conf
    .

    Maintenant lorque je saisi l'url de mon site sur le PC client, j'accède au site sans aucun problème.

    Si cela peut aider quelqu'un.