Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Futur Membre du Club
    Synthétiser l'un des tableaux dans un tableaux
    (Aucun préfixe)

    Bonjour


    Dans le fichier ci joint


    Un tableau en ligne P14:AC23


    Ce tableau doit récupérer les données de l'un des tableaux situés situé au dessus (A; B; C;D) récupéré via la liste déroulate en P13


    J'ai également (nom en forme de liste Gestionnaire de noms :

    AA - Tableau A

    BB - Tableau B

    CC - Tableau C
    DD - Tableau D


    Je bataille avec l'intégration de EQUIV INDEX RECHERCHEH ou RECHERCHE V et DECALER mais je n'arrives pas a trouver la finalite de la formule


    MOn
    Code vb :Sélectionner tout -Visualiser dans une fenêtre à part
    =EQUIV(P13;A1:BG1;FAUX)
    me renvoie bien la bonne position de colonne du tableau mais aprés je séche


    Pouvez vous m'aider merci


    PS : Est il possible d'inclure dans les formules le nom des listes lié aux gestionnaires de noms (a faire a part)

  2. #2
    Membre expert
    Bonjour,

    Si j'ai bien compris, vous voulez récupérer les valeurs d'un des 4 tableaux (en fonction de la sélection de la liste déroulante.
    Si c'est bien cela, la formule suivante devrait faire l'affaire, à copier en Q15 et collage spécial formules sur la plage (Q13:AB20)
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    =SI($P$13="A";B3;SI($P$13="B";Q3;SI($P$13="C";AF3;SI($P$13="D";AU3;""))))


    le fichier


    Cdlt

  3. #3
    Futur Membre du Club
    Meri pour ton retour
    Merci Arturo

    Je vais clôturer le sujet de discussion. Je vais prendre peux-être ta solution car je dois exporter certaines informations

    Je joins d'autres solutions issues d'autres forums.

    Merci à toi