Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse Java Discussion :

erreur sur l’accessibilité à un package


Sujet :

Eclipse Java

  1. #1
    Membre du Club
    Femme Profil pro
    Étudiant
    Inscrit en
    octobre 2012
    Messages
    58
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : octobre 2012
    Messages : 58
    Points : 62
    Points
    62
    Par défaut erreur sur l’accessibilité à un package
    Bonjour tout le monde,
    Voilà, je suis en train de me former sur de l'automatisation de test via WebDriver de selenium, j'ai donc suivi toutes les étapes d'installation de l'environnement, à la lettre.
    Le JDK est installé, éclipse IDE aussi , Version: 2019-12 (4.14.0)
    J'ai téléchargé les jar nécessaires à savoir le selenium-java-3.141.59 et le geckodriver-v0.26.0-win64, et j'ai bien entendu rajouté le chemin à ces jars sur le java build path , sous le Modulepath, ils y figurent bien, et je les vois aussi sur l'onglet de navigation sous le Referenced Libraries...
    Le soucis , c'est que mon import org.openqa.selenium.firefox; m'affiche une erreur de type : The package org.openqa.selenium.firefox is not accessible
    Je ne comprend vraiment rien, j'ai tut essayé 1001 fois , sans trouver le problème !!
    vous pourriez m'aider svp??? c'est un problème de jar???

    merci beaucoup!!

  2. #2
    Modérateur
    Avatar de joel.drigo
    Homme Profil pro
    Ingénieur R&D - Développeur Java
    Inscrit en
    septembre 2009
    Messages
    12 373
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Ingénieur R&D - Développeur Java
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2009
    Messages : 12 373
    Points : 29 312
    Points
    29 312
    Billets dans le blog
    2
    Par défaut
    Salut,

    Je suppose que tu as télécharger le jar selenium-java-3.141.59 directement depuis un repository Maven au lieu d'utiliser Maven. Et donc tu n'as aucune des dépendances nécessaires. Si tu n'utilises pas Maven, il faut télécharger manuellement toutes les dépendances (des jar) ainsi que leurs dépendances, en cascade. Tu peux voir ces dépendances en regardant le pom :

    Nom : Capture.PNG
Affichages : 10
Taille : 21,1 Ko

    Code xml : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    <dependencies>
        <dependency>
            <groupId>org.seleniumhq.selenium</groupId>
            <artifactId>selenium-api</artifactId>
            <version>3.141.59</version>
            <classifier/>
            </dependency>
        <dependency>
         <...>
        <dependency>
            <groupId>org.seleniumhq.selenium</groupId>
            <artifactId>selenium-firefox-driver</artifactId>
            <version>3.141.59</version>
            <classifier/>
        </dependency>
         <...>
    Tu peux dans Maven Central chercher sur le l'id de groupe, l'id d'artifact, voire le jar directement. Mais lorsqu'il y a beaucoup de dépendances, c'est plutôt fastidieux.
    Donc utiliser Maven est peut-être la meilleure option. Dans ton tutoriel, on ne te parle pas de ça ?

    Tu peux chercher sur Internet "maven eclipse selenium" : on trouve de nombreux tutoriels.

    Quelques liens qui pourront t'être utiles :

    Importer un project Maven dans Eclipse en 5 minutes
    A quoi sert maven concrètement (liens diverses et explications)
    Tests Selenium sous Eclipse
    Tutoriel pour tester une webapp à l'aide de FluentLenium, en 5 minutes
    L'expression "ça marche pas" ne veut rien dire. Indiquez l'erreur, et/ou les comportements attendus et obtenus, et donnez un Exemple Complet Minimal qui permet de reproduire le problème.
    La plupart des réponses à vos questions sont déjà dans les FAQs ou les Tutoriels, ou peut-être dans une autre discussion : utilisez la recherche interne.
    Des questions sur Java : consultez le Forum Java. Des questions sur l'EDI Eclipse ou la plateforme Eclipse RCP : consultez le Forum Eclipse.
    Une question correctement posée et rédigée et vous aurez plus de chances de réponses adaptées et rapides.
    N'oubliez pas de mettre vos extraits de code entre balises CODE (Voir Mode d'emploi de l'éditeur de messages).
    Nouveau sur le forum ? Consultez Les Règles du Club.

Discussions similaires

  1. Réponses: 0
    Dernier message: 20/11/2019, 15h54
  2. [ADA][Erreur] Sur un package et un tableau
    Par Dwaper dans le forum Ada
    Réponses: 3
    Dernier message: 13/03/2018, 10h17
  3. erreur sur mvn -e package
    Par pcouas dans le forum Maven
    Réponses: 2
    Dernier message: 20/11/2009, 14h35
  4. Erreur sur Package Mail_tools
    Par laury dans le forum Forms
    Réponses: 1
    Dernier message: 17/04/2007, 18h26
  5. Erreur sur la packaging d'un plugin
    Par elitost dans le forum Maven
    Réponses: 2
    Dernier message: 23/09/2006, 12h42

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo