Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Administration MySQL Discussion :

Je n'arrive pas à reseter mon mon de passe root


Sujet :

Administration MySQL

  1. ###raw>post.musername###
    Débutant
    Je n'arrive pas à reseter mon mon de passe root
    Bonjour à tous,

    C'est un problème un petit peu urgent.
    J'ai perdu le mot de passe root, mais j'ai accès au serveur, en tant qu'admin.

    J'ai aussi lu ceci https://dev.mysql.com/doc/mysql-wind...s-windows.html

    Donc,
    1. j'ai arrêté le service MySQL, plus précisément 'MySQL57'
    2. Créé un fichierC:\mysql-init.txt
    3. j'y ai mis le code ALTER USER 'root'@'localhost' IDENTIFIED BY 'MyNewPass'; (avec un autre mot de passe)
    4. je suis allé dans le dossier C:\Program Files\MySQL\MySQL Server 5.7\bin\
    4. Puis j'ai lancé la commande mysqld --init-file=C:\\mysql-init.txt

    Ce qui me surprend, c'est lorsque j'ai arrêté le service MYSQL57, j'arrive toujours à accéder phpmyadmin.

    En tout premier, il m'indique une erreur car il ne trouvait pas le dossier data


    J'ai donc cherché un peu et là, j'ai sûrement commis une erreur en lançant la commande

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    mysqld --initialize


    Le dossier a été créé avec des dossiers/fichiers enfants.

    J'ai relancé la commande

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    mysqld --init-file=C:\\mysql-init.txt

    Cette fois ci je n'ai pas d'erreur mais il ne me retourne pas le prompt.

    Aussi quand j'essaye de redémarrer MySQL, j'ai ce message d'erreur


    J'ai redémarré mon serveur et j'ai constaté que MySQL était bien redémarré.
    J'ai donc répété les opérations:

    1. j'ai arrêté le service MySQL, plus précisément 'MySQL57'
    2. Puis j'ai lancé la commande mysqld --init-file=C:\\mysql-init.txt

    Mais rien y fait, ca patauge.

    Qu'est-ce que j'ai fait de faux?
    Ai-je bien fait d'avoir lancé la commande mysqld --initialize ?

    Merci pour vos lumières
      0  0

  2. ###raw>post.musername###
    Débutant
    Ce n'est pas moi qui est installé MySQL sur ce serveur mais je me demande si la solution n'est pas en peut plus bas

    If you installed MySQL using the MySQL Installation Wizard, you may need to specify a --defaults-file option. For example:
    C:\> mysqld
    --defaults-file="C:\\ProgramData\\MySQL\\MySQL Server 5.7\\my.ini"
    --init-file=C:\\mysql-init.txt
    J'ose pas trop essayé sans avis
      0  0

  3. #3
    Expert éminent sénior
    Salut Pierrot10.

    La méthode que vous utilisez est fait pour la version 8.0.

    Pour MySql 5.7 :
    --> https://dasini.net/blog/2009/01/16/j...de-passe-root/

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  4. #4
    Membre régulier
    1) Ton répertoire "C:\Program Files\MySQL\MySQL Server 5.7\data" ne semble pas exister.
    2) utilise l'argument --defaults-file="C:\Quelque\Chose\Quelque\Part\my.ini" pour initialiser les variables de MySQL (un fichier exemple est créé par défaut lors de l'installation. Fais une copie de l'original puis modifie à ta guise). Laisse tomber le --init-file et utilise plutôt --defaults-file
    3) N'oublie pas que sous Windows tu dois mettre les chemins d'accès entre ""