IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Excel Discussion :

Nombre d'occurrences selon 2 critères


Sujet :

Excel

  1. #1
    Modérateur

    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    avril 2007
    Messages
    1 996
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 1 996
    Points : 3 105
    Points
    3 105
    Par défaut Nombre d'occurrences selon 2 critères
    Bonjour à tous,

    je cherche à identifier le nombre d'occurrences de cellules d'une ligne qui matchent avec deux critères combinés.
    J'ai essayé plusieurs choses avec SOMMEPROD et NB.SI.ENS sans parvenir à mes fins.

    Mon fichier est structuré ainsi :
    Nom : EXCEL.PNG
Affichages : 84
Taille : 7,5 Ko

    Je cherche à identifier le nombre de cellules dont le type est "RR" au cours de l'année 2019.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =NB.SI.ENS(B2:M2;"=RR";B2:M2;">"&DATE(31;12;2018))
    me renvoie 0
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =NB.SI.ENS(B2:M2;"=RR";B2:M2;">31/12/2018")
    me renvoie 0
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMMEPROD((B2:M2="RR")*(B2:M2 > "31/12/2018"))
    me renvoie 3 là où seules 2 cellules devraient matcher

    Je ne vois pas ce que je loupe.
    Si quelqu'un a une idée, je suis preneur

    Merci d'avance.

  2. #2
    Expert confirmé Avatar de Patrice740
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2007
    Messages
    2 256
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 67
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2007
    Messages : 2 256
    Points : 4 948
    Points
    4 948
    Par défaut
    Bonjour,

    Tu peux utiliser BDNB()
    Cordialement,
    Patrice
    Personne ne peut détenir tout le savoir, c'est pour ça qu'on le partage.

    Pour dire merci, cliquer sur et quand la discussion est finie, penser à cliquer sur

  3. #3
    Modérateur

    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    avril 2007
    Messages
    1 996
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 1 996
    Points : 3 105
    Points
    3 105
    Par défaut
    Merci pour cette réponse Patrice740 mais je ne vois pas comment utiliser BDND puisque je cherche à ce que mon critère de date soit appliqué sur plusieurs colonnes.

  4. #4
    Expert confirmé Avatar de Patrice740
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2007
    Messages
    2 256
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 67
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2007
    Messages : 2 256
    Points : 4 948
    Points
    4 948
    Par défaut
    Bonjour,
    Citation Envoyé par calagan99 Voir le message
    Merci pour cette réponse Patrice740 mais je ne vois pas comment utiliser BDND puisque je cherche à ce que mon critère de date soit appliqué sur plusieurs colonnes.
    C'est justement le rôle de la fonction BDNB : compter, dans une base de données (un tableau), le nombre de lignes répondant à des critères multiples, sans limite du nombre de critères.
    Pour l'utiliser, le plus simple est de créer une zone de critères sur une autre feuille dédiée.

    C'est simple à utiliser, si comme c'est demandé, il s'agit de compter le nombre d'occurrences de cellules d'une ligne qui matchent avec deux critères combinés.

    C'est moins évident lorsque la formule doit être tirée sur toutes les lignes d'un tableau : il faut alors utiliser des critères formulés dont la syntaxe n'est pas des plus évidentes (mais, à priori ce n'est pas le cas).

    Un vieil exemple d'utilisation : Recherche dans une base de données.xls
    Cordialement,
    Patrice
    Personne ne peut détenir tout le savoir, c'est pour ça qu'on le partage.

    Pour dire merci, cliquer sur et quand la discussion est finie, penser à cliquer sur

  5. #5
    Membre expert

    Homme Profil pro
    Retraité
    Inscrit en
    juin 2012
    Messages
    1 557
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Retraité
    Secteur : Enseignement

    Informations forums :
    Inscription : juin 2012
    Messages : 1 557
    Points : 3 536
    Points
    3 536
    Billets dans le blog
    1
    Par défaut
    Bonjour,
    =NB.SI.ENS(B2:M2;"=RR";B2:M2;">"&DATE(31;12;2018)) me renvoie 0
    Il y a une première erreur sur la syntaxe de la fonction DATE dont les paramètres doivent être dans l'ordre année,mois et jour en dernier.
    Il faut donc écrire DATE(2018;12;31).
    Mais surtout, Excel parcourt la plage 1 et la plage 2 dans le même ordre pour tester si, simultanément, la première cellule de la plage 1 vérifie le critère 1 et la première cellule de la plage 2 vérifie le critère 2, puis Excel passe à la deuxième cellule de chaque plage ...
    Or dans la formule les deux plages sont identiques; cela revient donc à se demander si une même cellule peut être simultanément du texte égal à RR et une date supérieure au 31/12/2018.
    On comprend le résultat de la formule.
    La formule la plus simple serait :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =NB.SI.ENS(D2:M2;"RR";C2:L2;">"&DATE(2018;12;31))
    Si l'on a la plage globale B2:M2 sur laquelle doit se faire le travail et que l'on sait seulement que la date est écrite une colonne avant le type, on peut écrire aussi :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =NB.SI.ENS(B2:M2;"RR";DECALER(B2:M2;0;-1);">"&DATE(2018;12;31))
    Cordialement
    Claude

  6. #6
    Expert confirmé Avatar de Patrice740
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2007
    Messages
    2 256
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 67
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2007
    Messages : 2 256
    Points : 4 948
    Points
    4 948
    Par défaut
    Bonjour,

    Une autre possibilité avec DECALER(), qui ne teste que les cellules concernées :
    =SOMME(NB.SI.ENS(DECALER(D2;0;{0;3;6;9});"RR";DECALER(C2;0;{0;3;6;9});">"&DATE(2018;12;31)))
    Cordialement,
    Patrice
    Personne ne peut détenir tout le savoir, c'est pour ça qu'on le partage.

    Pour dire merci, cliquer sur et quand la discussion est finie, penser à cliquer sur

Discussions similaires

  1. Nombre de personnes selon certains critères
    Par Swarin78 dans le forum Excel
    Réponses: 2
    Dernier message: 31/10/2018, 19h11
  2. Réponses: 19
    Dernier message: 31/05/2010, 10h51
  3. [XL-2007] Nombre de valeurs différentes selon un critère
    Par neiluj26 dans le forum Excel
    Réponses: 5
    Dernier message: 27/01/2010, 12h09
  4. [MySQL] Compter/classer selon le nombre d'occurrence
    Par AIexis dans le forum PHP & Base de données
    Réponses: 1
    Dernier message: 31/10/2008, 19h39
  5. recherche du nombre de cellule selon 2 critères
    Par lee.tsunamy dans le forum Excel
    Réponses: 1
    Dernier message: 18/06/2008, 02h48

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo