Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Access Discussion :

OODBC enregistrement #supprimé#


Sujet :

Access

  1. #1
    Nouveau membre du Club
    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    31
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Loire (Auvergne)

    Informations forums :
    Inscription : janvier 2013
    Messages : 31
    Points : 28
    Points
    28
    Par défaut OODBC enregistrement #supprimé#
    Bonjour,

    J'ai une base de donnée mariaDB chez OVH (cloudDB) reliée à MSAccess par odbc mysql connector.
    Lorsque je lies les tables j'ai une dizaines d'enregistrement marqués #supprimé# sur certaines tables.
    Ils sont par contre toujours dans la base MariaDB.
    Si j' importe les données je n'ai pas ce problème. Mais dès que que je "lie" les tables j'ai le problème.
    Si quelqu'un pouvait me sortir de là ...
    Merci

  2. #2
    Nouveau membre du Club
    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    31
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Loire (Auvergne)

    Informations forums :
    Inscription : janvier 2013
    Messages : 31
    Points : 28
    Points
    28
    Par défaut
    Suite à mon problème.
    Ce sont toujours les 10 premieres lignes de la table qui sont marquées #suprimé dans la table liée d'ACCESS.
    voila voila..

  3. #3
    Candidat au Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    février 2014
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : février 2014
    Messages : 3
    Points : 4
    Points
    4
    Par défaut La même chose...
    Bonjour
    Comme vous j'utilise les connexions ODBC surdu MySQL depuis Access
    et comme vous j'ai ce problème bizarre : les 10 premières lignes sont "supprimées"
    et autre phénomène que vous n'avez peut etre pas encore remarqué : probleme de transmigration unicode.
    J'ai tout essayé (mise à jour Office, utilisation de diverses versions du connector, 64 ou 32, etc...)
    rien n'y fait.
    Quand même une piste : sur Windows 10 PRO, ça a l'air de marcher ... il y aurait donc peut-être un problème structurel plus profond que prévu...

    Si vous avez des pistes, dites moi, j'ai perdu un client à cause de ça...

    A+

    YLM

  4. #4
    Nouveau membre du Club
    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    31
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Loire (Auvergne)

    Informations forums :
    Inscription : janvier 2013
    Messages : 31
    Points : 28
    Points
    28
    Par défaut
    Bonjour,

    J'ai windows 10 pro et le problème est bien apparu.
    Par contre je viens je pense de trouver le problème par hasard :
    J'avais utilisé le type de donnée TEXT et le souci est là; J'ai remplcé par du VARCHAR et tout est ok.
    Mais bon peut etre plutôt du à un "réglage" dans odbc ou MS Access.
    Dites moi si ça a résolu votre problème..

  5. #5
    Nouveau membre du Club
    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    31
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Loire (Auvergne)

    Informations forums :
    Inscription : janvier 2013
    Messages : 31
    Points : 28
    Points
    28

  6. #6
    Candidat au Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    février 2014
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : février 2014
    Messages : 3
    Points : 4
    Points
    4
    Par défaut
    Non, hélas, j'ai transformé mes TEXT en VARCHAR(5000) ça n'a pas résolu le problème. Seules 2 lignes sont réapparues (bizarrement) et c'est tout.
    Je me perds en conjecture. Et ça ne date pas d'hier, j'ai eu le problème il y a déjà 1 an. ça fait la deuxième fois.

  7. #7
    Candidat au Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    février 2014
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : février 2014
    Messages : 3
    Points : 4
    Points
    4
    Par défaut
    J'ai trouvé quelque chose (peut etre) :
    J'ai trois postes, le seul qui fonctionne est WIndows10 PRO, comme je vous l'avais dit (et il continue à très bien fonctionner).
    Mais c'est également le seul qui est en Office 32-bits...

  8. #8
    Nouveau membre du Club
    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    31
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Loire (Auvergne)

    Informations forums :
    Inscription : janvier 2013
    Messages : 31
    Points : 28
    Points
    28
    Par défaut
    Peut etre que c'est un autre type de donnée qui pose probleme..
    Peut etre faire afficher une table test avec 1 champ défini avec un type de données que vous avez utilisé dans votre table qui pose problème.
    Si ça marche pas essayez avec un autre type pour voir si ça peut venir de là.
    J'ai aussi office 32-bits

Discussions similaires

  1. [ADO] Nombre d'enregistrements supprimés
    Par Lawyer666 dans le forum VB 6 et antérieur
    Réponses: 6
    Dernier message: 19/07/2007, 19h23
  2. Récupération Enregistrements Supprimés
    Par random dans le forum Access
    Réponses: 2
    Dernier message: 03/08/2006, 12h04
  3. Compter le nombre d'enregistrement supprimer dans une jsp
    Par DarkWark dans le forum Servlets/JSP
    Réponses: 2
    Dernier message: 26/05/2006, 12h36
  4. Réponses: 2
    Dernier message: 12/05/2006, 13h00
  5. [MySQL] Plusieurs enregistrement à supprimer depuis un checkbox
    Par psychoBob dans le forum PHP & Base de données
    Réponses: 21
    Dernier message: 26/12/2005, 15h08

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo