Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

R Discussion :

La fonction Plot ne fonctionne plus


Sujet :

R

  1. #1
    Membre habitué
    Inscrit en
    janvier 2003
    Messages
    468
    Détails du profil
    Informations forums :
    Inscription : janvier 2003
    Messages : 468
    Points : 175
    Points
    175
    Par défaut La fonction Plot ne fonctionne plus
    Bonjour, j'ai un plantage de la fonction plot dans R et Rstudio depuis ce matin.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
     
    x<-c(1,2,3)
    y<-c(2,4,5)
    plot(x,y)
    J'ai utilisé Python sur mon poste avec Rstudio et j'ai notamment utilisé plot de matplotlib , est ce que cela peut provoquer cette erreur ?

    *** caught segfault ***
    address 0x0, cause 'memory not mapped'

    Traceback:
    1: py_call_impl(callable, dots$args, dots$keywords)
    2: plot(x, y)

    Possible actions:
    1: abort (with core dump, if enabled)
    2: normal R exit
    3: exit R without saving workspace
    4: exit R saving workspace
    Merci d'avance de vos idées ?

  2. #2
    Membre averti
    Homme Profil pro
    Data scientist
    Inscrit en
    février 2017
    Messages
    201
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Data scientist
    Secteur : Conseil

    Informations forums :
    Inscription : février 2017
    Messages : 201
    Points : 336
    Points
    336
    Par défaut
    Oui ca peut causer des conflits.

    Tu peux fermer ta session Rstudio et ressayer , normalement ça doit remarcher.

    A+.

  3. #3
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2019
    Messages
    22
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Hauts de Seine (Île de France)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Agroalimentaire - Agriculture

    Informations forums :
    Inscription : novembre 2019
    Messages : 22
    Points : 23
    Points
    23
    Par défaut
    Bonjour, je pense juste le redémarrage de la session va régler ton problème, ça doit marcher normalement.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 1
    Dernier message: 02/03/2015, 13h43
  2. Fonction mktime ne fonctionne plus
    Par Blade dans le forum Langage
    Réponses: 1
    Dernier message: 02/06/2010, 21h43
  3. [PHP 4] fonction mail ne fonctionne plus
    Par goofyto8 dans le forum Langage
    Réponses: 0
    Dernier message: 25/04/2010, 15h41
  4. [WD-2007] Fonction AutoClose ne fonctionne plus sous Word 2007
    Par iloyer dans le forum VBA Word
    Réponses: 2
    Dernier message: 20/05/2009, 01h32
  5. même la fonction "Date" ne fonctionne plus
    Par cyber_cobra_net dans le forum VB 6 et antérieur
    Réponses: 5
    Dernier message: 21/10/2007, 14h44

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo