IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Réseau Discussion :

Impossible d'ouvrir une connexion SSL alors que la bibliothèque est chargée


Sujet :

Réseau

  1. #1
    Membre actif
    Avatar de katanaenmousse
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    215
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2008
    Messages : 215
    Points : 226
    Points
    226
    Par défaut Impossible d'ouvrir une connexion SSL alors que la bibliothèque est chargée
    Bonjour,
    je voulais tester l'exemple fourni par Qt mapviewer.
    Quand je le lance l'appli fonctionne mais pas pour tous les providers de carto.
    J'ai plusieurs messages d'erreur à l'exécution :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
     qt.network.ssl: QSslSocket: cannot resolve OPENSSL_init_ssl
    
     qt.network.ssl: QSslSocket: cannot resolve OPENSSL_init_crypto
     qt.network.ssl: QSslSocket: cannot resolve ASN1_STRING_get0_data
     qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_reset
     qt.network.ssl: QSslSocket: cannot resolve RSA_bits
     qt.network.ssl: QSslSocket: cannot resolve OPENSSL_sk_new_null
     qt.network.ssl: QSslSocket: cannot resolve OPENSSL_sk_push
     qt.network.ssl: QSslSocket: cannot resolve OPENSSL_sk_free
     qt.network.ssl: QSslSocket: cannot resolve OPENSSL_sk_num
     qt.network.ssl: QSslSocket: cannot resolve OPENSSL_sk_pop_free
     qt.network.ssl: QSslSocket: cannot resolve OPENSSL_sk_value
     qt.network.ssl: QSslSocket: cannot resolve DH_get0_pqg
     qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_options
     qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_ciphersuites
     qt.network.ssl: QSslSocket: cannot resolve SSL_set_psk_use_session_callback
     qt.network.ssl: QSslSocket: cannot resolve SSL_get_client_random
     qt.network.ssl: QSslSocket: cannot resolve SSL_SESSION_get_master_key
     qt.network.ssl: QSslSocket: cannot resolve SSL_session_reused
     qt.network.ssl: QSslSocket: cannot resolve SSL_set_options
     qt.network.ssl: QSslSocket: cannot resolve TLS_method
     qt.network.ssl: QSslSocket: cannot resolve TLS_client_method
     qt.network.ssl: QSslSocket: cannot resolve TLS_server_method
     qt.network.ssl: QSslSocket: cannot resolve X509_STORE_CTX_get0_chain
     qt.network.ssl: QSslSocket: cannot resolve X509_getm_notBefore
     qt.network.ssl: QSslSocket: cannot resolve X509_getm_notAfter
     qt.network.ssl: QSslSocket: cannot resolve X509_get_version
     qt.network.ssl: QSslSocket: cannot resolve X509_STORE_set_ex_data
     qt.network.ssl: QSslSocket: cannot resolve X509_STORE_get_ex_data
     qt.network.ssl: QSslSocket: cannot resolve OpenSSL_version_num
     qt.network.ssl: QSslSocket: cannot resolve OpenSSL_version
     qt.network.ssl: Incompatible version of OpenSSL
    quand j'ajoute
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
        qDebug() << QSslSocket::supportsSsl() << QSslSocket::sslLibraryBuildVersionString() << QSslSocket::sslLibraryVersionString();
    j'obtiens :
    false "OpenSSL 1.1.1b 26 Feb 2019" ""

    Je précise que je suis sur ubuntu.
    Je pense qu'il y a un souci d'openSSL mais je ne vois pas comment le régler...
    Merci
    KatanaEnMousse
    Une fois qu'une réponse qui vous convient a été trouvée à votre sujet, pensez à le mettre en résolu.

  2. #2
    Responsable Qt & Livres


    Avatar de dourouc05
    Homme Profil pro
    Ingénieur de recherche
    Inscrit en
    août 2008
    Messages
    26 107
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur de recherche
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2008
    Messages : 26 107
    Points : 185 845
    Points
    185 845
    Par défaut


    Je dirais, sans certitude, qu'il te manque la version exécutable d'OpenSSL. Tu dois avoir un paquet OpenSSL 1.1 à installer (attention, pas un 1.0 ou un 0.9). J'ai l'impression que tu as déjà une version, mais trop vieille.

    Peut-être un truc comme "sudo apt-get install libssl1.1" en ligne de commande ? Selon https://packages.ubuntu.com/bionic/libssl1.1, ça pourrait marcher (à voir ta version d'Ubuntu).
    Vous souhaitez participer aux rubriques Qt (tutoriels, FAQ, traductions) ou HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  3. #3
    Membre actif
    Avatar de katanaenmousse
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    215
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2008
    Messages : 215
    Points : 226
    Points
    226
    Par défaut
    Merci Dourouc
    Je vais tenter ça.
    Mais je viens de voir que j ai le même problème avec Windows 10...
    Je vous tiens au courant
    Merci
    KatanaEnMousse
    Une fois qu'une réponse qui vous convient a été trouvée à votre sujet, pensez à le mettre en résolu.

  4. #4
    Membre actif
    Avatar de katanaenmousse
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    215
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2008
    Messages : 215
    Points : 226
    Points
    226
    Par défaut
    J ai fait comme ça pour installer OpenSSL
    http://www.projets-mars.fr/phpbbMARS....php?f=18&t=19
    C’était un peu plus complexe que prévu.
    Me reste à trouver la solution pour Windows
    J ai pas encore cherché.
    KatanaEnMousse
    Une fois qu'une réponse qui vous convient a été trouvée à votre sujet, pensez à le mettre en résolu.

  5. #5
    Membre éprouvé Avatar de gabriel21
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    315
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : février 2007
    Messages : 315
    Points : 1 097
    Points
    1 097
    Par défaut
    Pour Windows, regarde l'installateur QT.
    Dans la partie "Developer and Designer Tools"
    Tu as "OpenSSL 1.1.1d Toolkit"
    Il y a "OpenSSL binaries"
    Après je développe surtout sous Linux mais j'ai une VM et l'option était disponible pour moi (ainsi que sous Linux).
    Je n'ai pas encore testé l'intégration SSL dans Qt
    "Les cons, ça ose tout. C'est même à ça qu'on les reconnaît." Michel Audiard - Les tontons flingueurs

  6. #6
    Membre actif
    Avatar de katanaenmousse
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    215
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2008
    Messages : 215
    Points : 226
    Points
    226
    Par défaut
    Bah Maintenance Tools ne fonctionne plus chez moi... je ne sais pas pourquoi...
    Je n'ai pas avancé pour windows....

    Citation Envoyé par gabriel21 Voir le message
    Pour Windows, regarde l'installateur QT.
    Dans la partie "Developer and Designer Tools"
    Tu as "OpenSSL 1.1.1d Toolkit"
    Il y a "OpenSSL binaries"
    Oui mais ça n est pas que si tu compiles avec MSVC?
    KatanaEnMousse
    Une fois qu'une réponse qui vous convient a été trouvée à votre sujet, pensez à le mettre en résolu.

  7. #7
    Membre éprouvé Avatar de gabriel21
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    315
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : février 2007
    Messages : 315
    Points : 1 097
    Points
    1 097
    Par défaut
    Citation Envoyé par katanaenmousse Voir le message
    Oui mais ça n est pas que si tu compiles avec MSVC?
    Je viens de tester avec minGW64, j'ai effectivement une erreur ssl.
    Donc c'est possible. Il faudrait tester...
    J'ai MSVC installé, mais pas pour qt, je verrai ça ce weekend...
    Ah Windows et sa configuration parfois bizarre...
    "Les cons, ça ose tout. C'est même à ça qu'on les reconnaît." Michel Audiard - Les tontons flingueurs

  8. #8
    Membre éprouvé Avatar de gabriel21
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    315
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : février 2007
    Messages : 315
    Points : 1 097
    Points
    1 097
    Par défaut
    Mon visual studio est trop récent à première vu. Pas réussi à utiliser le compilateur MSVC à partir de QT Creator.

    Je vais pas chercher plus, désolé.

    Bon courage pour ta recherche
    "Les cons, ça ose tout. C'est même à ça qu'on les reconnaît." Michel Audiard - Les tontons flingueurs

  9. #9
    Membre actif
    Avatar de katanaenmousse
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    215
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2008
    Messages : 215
    Points : 226
    Points
    226
    Par défaut
    Pour ma part j ai installé les binaires déjà compilés pour Windows
    Je reviendrai ici pour poster la solution pour compiler avec mingw dès que j aurai le temps de chercher.
    Merci d avoir essayé
    KatanaEnMousse
    Une fois qu'une réponse qui vous convient a été trouvée à votre sujet, pensez à le mettre en résolu.

Discussions similaires

  1. Réponses: 5
    Dernier message: 26/02/2016, 19h40
  2. impossible d'ouvrir une connexion à la BD
    Par caro_caro dans le forum JDBC
    Réponses: 1
    Dernier message: 10/04/2008, 16h05
  3. Réponses: 0
    Dernier message: 04/03/2008, 17h58
  4. Réponses: 3
    Dernier message: 30/10/2007, 16h14
  5. Impossible d'ouvrir une connexion à SQL Server
    Par lamiruth dans le forum Accès aux données
    Réponses: 1
    Dernier message: 18/02/2007, 16h40

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo