Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

OpenOffice & LibreOffice Discussion :

Perte contrôles de formulaire et problème macro


Sujet :

OpenOffice & LibreOffice

  1. #1
    Futur Membre du Club
    Profil pro
    Inscrit en
    mai 2004
    Messages
    7
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2004
    Messages : 7
    Points : 8
    Points
    8
    Par défaut Perte contrôles de formulaire et problème macro
    Bonjour
    J'ai voulus faire des macros, comme il y a eu des erreurs j'ai du les annuler et aller dans : macro=> Gérer des macro =>Libreoffice et j'ai supprimé des modules.
    Je me retrouve avec :Contrôles de formulaire , impossible de le faire apparaitre.
    J'ai le message suivant si je clique sur le bouton qui devait être associé à la macro :
    une erreur de structure de script s'est produite lors de l’exécution du script vnd.sun.script :standard.module 1.dimension d700 ?
    language =basic&location =document en basic
    Message : the following basic script could not be found
    library :'standard'
    module: 'module 1'
    method :'dimension D700'
    location: 'Document'
    Version LibreOffice 6.2.8.2 (X64) système Windows 10
    Désinstallation et réinstallation de LibreOffice et nettoyage des base de registres ne donne rien !!!!!
    que faire ? d'avance merci
    Images attachées Images attachées  

  2. #2
    Membre habitué
    Homme Profil pro
    Retraité
    Inscrit en
    septembre 2009
    Messages
    93
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Vendée (Pays de la Loire)

    Informations professionnelles :
    Activité : Retraité
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : septembre 2009
    Messages : 93
    Points : 127
    Points
    127
    Par défaut Perte contrôles de formulaire et problème macro
    Bonjour,
    Au vu de ce que tu expliques, en cliquant sur ton bouton libre office cherche la macro associée à ce bouton. Il cherche dans la bibliothèque STANDARD de ton document, dans le MODULE1 la macro qui se nomme dimension D700. Comme il ne le trouve pas, il te renvoie ce message d'erreur. Trois solutions :
    - soit la macro a purement été supprimée.
    - soit la macro a été renommée
    - soit la macro a été déplacée


    C'est logique que :
    Désinstallation et réinstallation de LibreOffice et nettoyage des base de registres ne donne rien !!!!!
    ne serve à rien.

    Cordialement
    Libre Office Version: 6.0.1.1 (x64)
    Windows 10

Discussions similaires

  1. [XL-2013] Problèmes de renommage dynamique de contrôles de formulaire
    Par CognitiKom dans le forum Macros et VBA Excel
    Réponses: 4
    Dernier message: 01/03/2016, 12h35
  2. [AC-2013] Problème d'insertion d'image dans un formulaire avec une macro
    Par DrizztUrden dans le forum Macros Access
    Réponses: 0
    Dernier message: 05/05/2014, 10h25
  3. Perte des données formulaires si contrôle validation
    Par dodo14 dans le forum MkFramework
    Réponses: 4
    Dernier message: 10/11/2013, 18h09
  4. accéder à un contrôle de formulaire avec un nom de tableau
    Par jibouze dans le forum Général JavaScript
    Réponses: 5
    Dernier message: 01/07/2005, 00h57
  5. [JSP] [STRUTS] Contrôle de formulaire
    Par babylone7 dans le forum Servlets/JSP
    Réponses: 5
    Dernier message: 13/07/2004, 18h51

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo