Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Bibliothèques tierces Python Discussion :

Installation de TextBlob


Sujet :

Bibliothèques tierces Python

  1. #1
    Futur Membre du Club
    Installation de TextBlob
    Bonjour,

    je travaille sous python 3.4.1
    j'ai essayé d'installer textblob avec la commande
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    pip install -U textblob

    mais j'ais les messages d'erreurs suivants:

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    C:\Python34\Scripts>pip install -U textblob
    Downloading/unpacking textblob
    Downloading/unpacking nltk>=3.1 (from textblob)
      Real name of requirement nltk is nltk
      Running setup.py (path:C:\Users\ADMINI~1\AppData\Local\Temp\pip_build_Administ
    rateur\nltk\setup.py) egg_info for package nltk
        error in nltk setup command: 'install_requires' must be a string or list of
    strings containing valid project/version requirement specifiers
        Complete output from command python setup.py egg_info:
        error in nltk setup command: 'install_requires' must be a string or list of
    strings containing valid project/version requirement specifiers
     
    ----------------------------------------
    Cleaning up...
    Command python setup.py egg_info failed with error code 1 in C:\Users\ADMINI~1\A
    ppData\Local\Temp\pip_build_Administrateur\nltk
    Storing debug log for failure in C:\Users\Administrateur\pip\pip.log


    toute aide de votre part est précieuse

  2. #2
    Membre éclairé
    aucun soucis avec python 3.8 sur windows, (pip 19.3.1 et setuptools 41.6.0)
    Code x :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    Collecting textblob
      Downloading https://files.pythonhosted.org/packages/60/f0/1d9bfcc8ee6b83472ec571406bd0dd51c0e6330ff1a51b2d29861d389e85/textblob-0.15.3-py2.py3-none-any.whl (636kB)
         |████████████████████████████████| 645kB 409kB/s
    Collecting nltk>=3.1
      Downloading https://files.pythonhosted.org/packages/f6/1d/d925cfb4f324ede997f6d47bea4d9babba51b49e87a767c170b77005889d/nltk-3.4.5.zip (1.5MB)
         |████████████████████████████████| 1.5MB 3.3MB/s
    Requirement already satisfied: six in c:\users\deveaux\appdata\local\programs\python\python38\lib\site-packages (from nltk>=3.1->textblob) (1.13.0)
    Installing collected packages: nltk, textblob
        Running setup.py install for nltk ... done
    Successfully installed nltk-3.4.5 textblob-0.15.3


    pouvez vous essayer sur une version plus récente de python ? de même est ce que pip/setuptools sont à jour ?

  3. #3
    Expert éminent sénior
    Salut,

    Citation Envoyé par mouncef Voir le message
    j'ai toujours le meme probleme aidez moi svp
    On ne peut pas se déplacer chez vous pour vérifier que vous avez bien fait les mises à jour suggérées et voir si on a le même genre de message d'erreur ou pas.

    - W
    Architectures post-modernes.
    Python sur DVP c'est aussi des FAQs, des cours et tutoriels

  4. #4
    Membre éclairé
    comme je l'ai dit sans faire de test croisé ça va être difficile de vous aidez...

    installer une version plus récente de python pour voir, mettez à jour pip et setuptools ? ect

###raw>template_hook.ano_emploi###