Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

WinDev Discussion :

Ma saisie ne s'affiche dans ma table [WD22]


Sujet :

WinDev

  1. #1
    Nouveau Candidat au Club
    Femme Profil pro
    ide
    Inscrit en
    octobre 2019
    Messages
    123
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : ide
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2019
    Messages : 123
    Points : 0
    Points
    0
    Par défaut Ma saisie ne s'affiche dans ma table
    Pièce jointe 520862

    J'ai un nouveau petit problème, j'ouvre ma table Prévoyance, je clique sur modifier ce qui ouvre ma fiche Prévoyance. Jusque la tout fonctionne.

    Mais si je saisie dans ma fiche au niveau de la carence un chiffre (ex. 10) et que je valide, ce chiffre ne s'affiche pas dans ma table dans carence.

    J'ai essayé avec un TableAffiche, sans résultat. Peut-être dois je intervenir via ma requête ou d'une autre manière. Pouvez-vous me donner une piste pour solutionner ce problème d'affichage.

    Encore merci

  2. #2
    Membre éprouvé
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    juin 2017
    Messages
    720
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Chef de projet en SSII

    Informations forums :
    Inscription : juin 2017
    Messages : 720
    Points : 1 183
    Points
    1 183
    Par défaut
    Je suppose que la valeur n'est pas dans ta table.
    Il me semble que tu as déjà eu le même problème non ?
    Il y a peut être plus simple, mais ça tourne

  3. #3
    Nouveau Candidat au Club
    Femme Profil pro
    ide
    Inscrit en
    octobre 2019
    Messages
    123
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : ide
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2019
    Messages : 123
    Points : 0
    Points
    0
    Par défaut
    Citation Envoyé par Voroltinquo Voir le message
    Je suppose que la valeur n'est pas dans ta table.
    Il me semble que tu as déjà eu le même problème non ?
    Effectivement tu as raison, quelle mémoire. J'ai donc modifier le code du bouton valider

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
     
    // Lecture des informations saisies
    EcranVersFichier()
     
    // Ajoute / Modifie l'enregistrement
    Requête_Prévoyance.Nbr_Carence=Nbr_Carence
    HEnregistre(Requête_Prévoyance)
     
    // Ferme la fenêtre
    Ferme("",Vrai)
    La saisie s'affiche bien dans ma table, mais lorsque je quitte ma table et que j'y reviens ma saisie a disparu, même avec un TableAffiche

  4. #4
    Membre éprouvé
    Profil pro
    Inscrit en
    avril 2010
    Messages
    679
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2010
    Messages : 679
    Points : 1 080
    Points
    1 080
    Par défaut
    A quelle rubrique est liee la colonne?

  5. #5
    Nouveau Candidat au Club
    Femme Profil pro
    ide
    Inscrit en
    octobre 2019
    Messages
    123
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : ide
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2019
    Messages : 123
    Points : 0
    Points
    0
    Par défaut
    Citation Envoyé par Yusep Voir le message
    A quelle rubrique est liee la colonne?
    La rubrique est Nbr_Carence

  6. #6
    Membre éprouvé
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    juin 2017
    Messages
    720
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Chef de projet en SSII

    Informations forums :
    Inscription : juin 2017
    Messages : 720
    Points : 1 183
    Points
    1 183
    Par défaut
    Maintenant, je me méfie.

    A priori, tu as utilisé la requête suivante pour remplir ton champ table
    Code SQL : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    SELECT 
    Liste_Salariés.Nom AS Nom,	
    Liste_Salariés.NomJF AS NomJF,	
    Liste_Salariés.Prénom AS Prénom,		
    Ijss.AR_Du AS AR_Du,	
    Ijss.AR_Au AS AR_Au,
    Motif.Motif AS Motif_Mo,
    Prévoyance.Nbr_Carence AS Nbr_Carence,	
    Prévoyance.Nbr_JoursTotal AS Nbr_JoursTotal,	
    Prévoyance.Sub_Du AS Sub_Du,	
    Prévoyance.Sub_Au AS Sub_Au,	
    Prévoyance.Nbr_JoursSub AS Nbr_JoursSub,	
    Prévoyance.Percu_Du AS Percu_Du,	
    Prévoyance.Percu_Au AS Percu_Au,	
    Prévoyance.Nbr_Alptis AS Nbr_Alptis,	
    Prévoyance.Mt_Percu AS Mt_Percu,	
    Prévoyance.Mois_Paye AS Mois_Paye
    FROM 
    Motif
    RIGHT OUTER JOIN
    (
    Liste_Salariés
    RIGHT OUTER JOIN
    (
    Ijss
    LEFT OUTER JOIN
    Prévoyance
    ON Ijss.IDIjss = Prévoyance.IDPrévoyance
    )
    ON Liste_Salariés.IDListe_Salariés = Ijss.IDListe_Salariés
    )
    ON Motif.IDMotif = Ijss.IDMotif
    ORDER BY 
    Nom ASC,	
    AR_Du ASC

    En lisant rapidement ton code,tu as opté pour l'analyse suivante :
    Nom : screenshot_01-12-2019 21h03_n°01.png
Affichages : 69
Taille : 11,2 Ko
    Il y a peut être plus simple, mais ça tourne

  7. #7
    Nouveau Candidat au Club
    Femme Profil pro
    ide
    Inscrit en
    octobre 2019
    Messages
    123
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : ide
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2019
    Messages : 123
    Points : 0
    Points
    0
    Par défaut
    Bonsoir,

    En faisant un test de ma requête, je me rends compte que les champs Nbr_Carence, Nbr_Jourstotal et suivant me renvoie une valeur NULL.
    Cela aurait-il une influence sur le fait que la valeur que je saisie s'affiche bien et que lorsque je quitte et je reviens sur ma table, la valeur a disparu.

    Sinon, j'ai cherché et pour le moment je n'ai pas encore trouvé de solution. Je continue donc….

    Merci à vous

  8. #8
    Membre éprouvé
    Profil pro
    Inscrit en
    avril 2010
    Messages
    679
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2010
    Messages : 679
    Points : 1 080
    Points
    1 080
    Par défaut
    Citation Envoyé par hilander Voir le message
    Bonsoir,

    En faisant un test de ma requête, je me rends compte que les champs Nbr_Carence, Nbr_Jourstotal et suivant me renvoie une valeur NULL.
    Cela aurait-il une influence sur le fait que la valeur que je saisie s'affiche bien et que lorsque je quitte et je reviens sur ma table, la valeur a disparu.
    Bien vu.

  9. #9
    Membre éprouvé
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    juin 2017
    Messages
    720
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Chef de projet en SSII

    Informations forums :
    Inscription : juin 2017
    Messages : 720
    Points : 1 183
    Points
    1 183
    Par défaut
    Cela ne viendrait-il pas de l'utilisation d'une analyse antérieure et de la non synchronisation de 2 tables ?
    Il y a peut être plus simple, mais ça tourne

  10. #10
    Membre éclairé
    Homme Profil pro
    Inscrit en
    mai 2003
    Messages
    450
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Réunion

    Informations forums :
    Inscription : mai 2003
    Messages : 450
    Points : 795
    Points
    795
    Par défaut
    As-tu exécuté ta requête avec l'option "hModifieFichier" ?
    Philippe,


    N'hésitez à lever le pouce si mon aide vous a été utile.

  11. #11
    Nouveau Candidat au Club
    Femme Profil pro
    ide
    Inscrit en
    octobre 2019
    Messages
    123
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : ide
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2019
    Messages : 123
    Points : 0
    Points
    0
    Par défaut
    Citation Envoyé par philouZ Voir le message
    Oui

    Citation Envoyé par Voroltinquo Voir le message
    Oui c'est bien cela. Je continue à chercher et ce depuis hier. Je me pose une question, comment faire en sorte que la valeur NULL n'apparaisse plus lorsque je teste ma requête.

  12. #12
    Membre éprouvé
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    juin 2017
    Messages
    720
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Chef de projet en SSII

    Informations forums :
    Inscription : juin 2017
    Messages : 720
    Points : 1 183
    Points
    1 183
    Par défaut
    C'est cela pour la requête, l'analyse ou les 2
    Il y a peut être plus simple, mais ça tourne

  13. #13
    Nouveau Candidat au Club
    Femme Profil pro
    ide
    Inscrit en
    octobre 2019
    Messages
    123
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : ide
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2019
    Messages : 123
    Points : 0
    Points
    0
    Par défaut
    Citation Envoyé par Voroltinquo Voir le message
    C'est cela pour la requête, l'analyse ou les 2
    Pour la requête prévoyance, enfin si cela est possible. Peut-être qu'ainsi je pourrais conserver ma saisie. Mais je me trompe peut-être complètement

  14. #14
    Membre éprouvé
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    juin 2017
    Messages
    720
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Chef de projet en SSII

    Informations forums :
    Inscription : juin 2017
    Messages : 720
    Points : 1 183
    Points
    1 183
    Par défaut
    Pour l'analyse tu a donc continuer dans tes errements de tables à synchroniser, uniquement pour conserver les données de test.
    Il est fort possible dans ce cas que tu mettes a jour une valeur dans une table et pas dans l'autre.
    Il y a peut être plus simple, mais ça tourne

  15. #15
    Nouveau Candidat au Club
    Femme Profil pro
    ide
    Inscrit en
    octobre 2019
    Messages
    123
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : ide
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2019
    Messages : 123
    Points : 0
    Points
    0
    Par défaut
    bon j'ai codé toutes mes colonnes pour les calculs et tout fonctionne bien.
    Mais un problème de taille pour moi et pas des moindres, je ne cesse de parcourir et de lire afin de trouver une solution, mais sans succès.

    Comme je vous l'ai déjà souligné, je suis toujours avec mon problème. La saisie des données se fait bien, mais ne reste pas en mémoire car lorsque je quitte ma table et que j'y reviens mes données ne sont plus là.

    Et lorsque je teste ma requête, j'ai toujours la valeur NULL qui s'affiche

    J'ai essayé avec TableAffiche, avec HModifie, Henregistre mais rien n'y fait.

    Ce soir, je fait un break en regardant StarWars et je m'y remettrai demain

    Bonne soirée à tous

  16. #16
    Nouveau Candidat au Club
    Femme Profil pro
    ide
    Inscrit en
    octobre 2019
    Messages
    123
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : ide
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2019
    Messages : 123
    Points : 0
    Points
    0
    Par défaut
    Je n'ai toujours pas trouvé de solution à mon problème

  17. #17
    Membre éprouvé
    Profil pro
    Inscrit en
    avril 2010
    Messages
    679
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2010
    Messages : 679
    Points : 1 080
    Points
    1 080
    Par défaut
    Tu peux nous envoyer ton projet compressé pour voir plus clair.

  18. #18
    Nouveau Candidat au Club
    Femme Profil pro
    ide
    Inscrit en
    octobre 2019
    Messages
    123
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : ide
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2019
    Messages : 123
    Points : 0
    Points
    0
    Par défaut
    Citation Envoyé par Yusep Voir le message
    Tu peux nous envoyer ton projet compressé pour voir plus clair.
    Bonsoir Yusep,

    Je t'envoie mon projet en pièce jointe…

    Pièce jointe 521631

    Merci

  19. #19
    Membre éclairé
    Homme Profil pro
    Inscrit en
    mai 2003
    Messages
    450
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Réunion

    Informations forums :
    Inscription : mai 2003
    Messages : 450
    Points : 795
    Points
    795
    Par défaut
    C'est écrit avec quoi ton projet ? Impossible à ouvrir, ça e fait penser à une version pirate
    Philippe,


    N'hésitez à lever le pouce si mon aide vous a été utile.

  20. #20
    Nouveau Candidat au Club
    Femme Profil pro
    ide
    Inscrit en
    octobre 2019
    Messages
    123
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : ide
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2019
    Messages : 123
    Points : 0
    Points
    0
    Par défaut
    Citation Envoyé par philouZ Voir le message
    C'est écrit avec quoi ton projet ? Impossible à ouvrir, ça e fait penser à une version pirate
    Avec WinDev 20 que j'ai racheté à une personne qui passait à une version supérieure. Moi j'arrive à ouvrir mon fichier Zip

+ Répondre à la discussion
Cette discussion est résolue.
Page 1 sur 3 123 DernièreDernière

Discussions similaires

  1. [WD17] afficher dans une table apartir d'un champ de saisi
    Par didier.dev dans le forum WinDev
    Réponses: 1
    Dernier message: 16/01/2015, 12h45
  2. Réponses: 0
    Dernier message: 24/09/2014, 23h38
  3. Réponses: 1
    Dernier message: 02/05/2013, 18h21
  4. Réponses: 0
    Dernier message: 17/05/2010, 19h14
  5. Réponses: 9
    Dernier message: 26/11/2008, 11h18

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo