Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Architecture Discussion :

OpenVPN en Bridge


Sujet :

Architecture

  1. #1
    Membre à l'essai
    OpenVPN en Bridge
    Bonjour et merci par avance de votre aide...
    je monte un VPN en Bridge sur un DEBIAN 9.9 un petit schéma c 'est mieux que beaucoup de mots...



    Le VPN c 'est OK mon client sous Windows 10 prend bien l' IP que lui donne le serveur VPN dans la plage du VLAN 10.
    La connexion et l' échange de certificat ne posent aucun problème.
    Le but de la manœuvre c 'est que mon client récupère l 'IP public A pour avoir accès depuis l' exterieur à l' application métier qui n' accepte que cette IP en entrée.
    Le client est derrière une box standard.
    Les NATs sur le routeur sont en place sur le protocole UDP et sur le bon port.
    Bien que Mon tunnel VPN marche l' IP public de mon client reste sur B...
    Voici mes fichier de conf
    (pas de groupe pour le moment)

    serveur
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    port 4043
    proto udp
    dev tap0
    
    #dev-node tap-bridge
    
    ca   /etc/openvpn/easy-rsa/keys/ca.crt
    cert /etc/openvpn/easy-rsa/keys/OpenVPN.crt
    key /etc/openvpn/easy-rsa/keys/OpenVPN.key
    dh /etc/openvpn/easy-rsa/keys/dh2048.pem
    
    push "redirect-gateway def1"
    push "route 192.168.0.0 255.255.255.0 192.168.0.254"
    push "route 192.168.1.0 255.255.255.0"
    
    
    ifconfig-pool-persist ipp.txt
    
    server-bridge 192.168.0.7 255.255.255.0 192.168.0.40 192.168.0.50
    
    keepalive 10 120
    comp-lzo
    
    #user nobody
    #group nogroup
    
    persist-key
    persist-tun
    status openvpn-status.log
    verb 1
    CLIENT
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    client
    dev tap0
    proto udp
    remote XXX.XXX.XXX.XXX 4043
    resolv-retry infinite
    nobind
    persist-key
    persist-tun
    ca ca.crt
    cert DM.crt
    key DM.key
    script-security 2
    dhcp-option DNS 192.168.0.1 
    comp-lzo
    verb 1
    
    
    #route-gateway 192.168.0.254
    redirect-gateway def1
    Pas d' erreur sur les logs...

    iptables...
    iptables -A INPUT -i tap0 -j ACCEPT
    iptables -A INPUT -i br0 -j ACCEPT
    iptables -A FORWARD -i br0 -j ACCEPT

    ipforward est bien sur 1

    je ping l 'ensemble de le VLAN 10
    mais pas le VLAN 20 ( et donc le routeur de sortie alors que le routage est en place sur mon INFRA)
    Je pense que le TAG VLAN ne passe pas le tunnel alors j 'ai push les routes mais sans résultat

    ... j' ai vidé mon sac, amen...

  2. #2
    Membre à l'essai
    TUN contre TAP
    Bon pour info j 'ai trouvé le TAP avec les VLANS pose un problème avec une configuration TUN ça marche...

###raw>template_hook.ano_emploi###