IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Symfony PHP Discussion :

Unable to guess the MIME type as no guessers are available


Sujet :

Symfony PHP

  1. #1
    Responsable LaTeX

    Avatar de -Nikopol-
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2013
    Messages
    2 128
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 46
    Localisation : France, Haute Marne (Champagne Ardenne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Enseignement

    Informations forums :
    Inscription : mai 2013
    Messages : 2 128
    Points : 11 189
    Points
    11 189
    Billets dans le blog
    5
    Par défaut Unable to guess the MIME type as no guessers are available
    Bonjour,
    je me bats avec cette erreur depuis un moment déjà
    Unable to guess the MIME type as no guessers are available (did you enable the php_fileinfo extension?)
    obtenue lors de l'upload de fichier.
    J'ai cherché et la solution de décommenter la ligne dans la php.ini ne donne rien. J'ai même été jusqu'à ajouter cette ligne dans les php.ini-development et php.ini-production qui se trouve dans le dossier wamp. et passer par vich_uploader
    Code yaml : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    vich_uploader:
        db_driver: orm
     
        mappings:
            cover_image:
                uri_prefix: /images/cover
                upload_destination: '%kernel.project_dir%/public/images/cover'
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    use Vich\UploaderBundle\Mapping\Annotation as Vich;
     
    /**
     * @ORM\Entity(repositoryClass="App\Repository\ArticleRepository")
     * @ORM\HasLifecycleCallbacks
     * @UniqueEntity(
     *  fields={"title"},
     * message="Un autre article possède déjà le même titre"
     * )
     * @Vich\Uploadable
     */
    class Article
    {
    /**
         * @var string|null
         * @ORM\Column(type="string", length=255,nullable=true)
         */
        private $filename;
        /**
         * @var File|null
         * @Vich\UploadableField(mapping="cover_image", fileNameProperty="filename")
         * @Assert\File(mimeTypes={"application/png" ,"application/jpg","application/jpeg"})
         */
        private $imageFile;
    /**
         * @return string|null
         */
        public function getFilename(): ?string
        {
            return $this->filename;
        }
     
        /**
         * @param string|null $filename
         * @return Article
         */
        public function setFilename(?string $filename): Article
        {
            $this->filename = $filename;
            return $this;
        }
     
        /**
         * @return File|null
         */
        public function getImageFile(): ?File
        {
            return $this->imageFile;
        }
     
        /**
         * @param File|null $imageFile
         * @return Article
         */
        public function setImageFile(?File $imageFile): Article
        {
            $this->imageFile = $imageFile;
            return $this;
        }
    }
    Merci d'avance pour votre aide.

  2. #2
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    8 479
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 8 479
    Points : 13 143
    Points
    13 143
    Par défaut
    quand vous regardez le phpinfo, est ce que vous voyez une section "fileinfo" ?

  3. #3
    Responsable LaTeX

    Avatar de -Nikopol-
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2013
    Messages
    2 128
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 46
    Localisation : France, Haute Marne (Champagne Ardenne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Enseignement

    Informations forums :
    Inscription : mai 2013
    Messages : 2 128
    Points : 11 189
    Points
    11 189
    Billets dans le blog
    5
    Par défaut
    Oui, dans les extensions (sous wamp) j'ai bien fileinfo d'activé.

    même erreur si je fais l'upload "à la main" sans le plugin.

  4. #4
    Membre éprouvé
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2012
    Messages
    617
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2012
    Messages : 617
    Points : 1 110
    Points
    1 110
    Par défaut
    Citation Envoyé par -Nikopol- Voir le message
    Oui, dans les extensions (sous wamp) j'ai bien fileinfo d'activé.
    Il n'est pas impossible que tu tentes de modifier le mauvais fichier de config PHP surtout si ton application se lance avec le serveur de dev de SYMFONY. Ce dernier utilise PHP CLi.
    Si c'est le cas il faut alors vérifier à l'aide de l'invite de commande que fileinfo est activée:

  5. #5
    Responsable LaTeX

    Avatar de -Nikopol-
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2013
    Messages
    2 128
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 46
    Localisation : France, Haute Marne (Champagne Ardenne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Enseignement

    Informations forums :
    Inscription : mai 2013
    Messages : 2 128
    Points : 11 189
    Points
    11 189
    Billets dans le blog
    5
    Par défaut
    php -m ne m'avait rien donné. les options étaient activées mais pas de fichier. J'ai résolu en refaisant une installation complète de php et de wamp. Merci pour votre aide.

Discussions similaires

  1. Réponses: 4
    Dernier message: 22/12/2018, 22h49
  2. Servlet et Mime Type
    Par romano21 dans le forum Servlets/JSP
    Réponses: 2
    Dernier message: 25/10/2005, 17h45
  3. [WebForms][1.1] Unable to make the session state request
    Par the_bmo dans le forum Général Dotnet
    Réponses: 7
    Dernier message: 12/10/2005, 15h27
  4. [Débutant] The authentication type 5, java
    Par agougeon dans le forum PostgreSQL
    Réponses: 1
    Dernier message: 07/05/2005, 15h01
  5. mime type
    Par mitsein dans le forum XML/XSL et SOAP
    Réponses: 2
    Dernier message: 11/07/2004, 14h54

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo