Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Candidat au Club
    Homme Profil pro
    responsable d'ESMS
    Inscrit en
    septembre 2019
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 61
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : responsable d'ESMS
    Secteur : Santé

    Informations forums :
    Inscription : septembre 2019
    Messages : 8
    Points : 4
    Points
    4
    Par défaut ajoutez une valeur une seule fois dans le mois
    Bonjour à tous,
    Je sèche sur une formule:
    =SI(Q5="";P5;P5-S5)+2,5


    ces cellules font références à des chiffres issus de calcul de dates de congés sur une base de 22 jours:
    05/10/2019 ; 23/10/2019 = 16 en P5 .... ce qui me donne un solde de 6 jours
    12/10/2019 ; 15/10/2019 = 3 en S5 ... ce qui me donne un solde de 3 jours
    Cela fonctionne très bien jusque là, les jours fériés et weekends sont bien décomptés etc..

    Maintenant, les 2 ,5 jours à ajouter ne sont acquis qu'une seule fois par mois, en effet, si j'entre plusieurs séquences de congés sur le même mois,, il y aura autant de fois 2,5 jours de plus que de dates posées.


    J'ai fait beaucoup de tentatives qui n'ont pas abouties

    Alors si vous avez une idée....
    Merci à tous

    Jack

  2. #2
    Membre habitué
    Profil pro
    Inscrit en
    mars 2007
    Messages
    138
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2007
    Messages : 138
    Points : 144
    Points
    144
    Par défaut
    Bonsoir

    Je suis parti sur la base que
    05/10/2019 est en N5
    23/10/2019 est en O5
    16 est en P5
    12/10/2019 est en Q5
    15/10/2019 est en R5
    3 est en S5
    que votre formule à améliorer est en T5
    il peut y avoir d'autres dates de Q2 à Q5
    qu'il s'agit de la même année dans la feuille
    qu'il s'agit du même salarié dans la feuille

    La formule que je vous propose en T5 est =SI(Q5="";P5;P5-S5)+SI(NB.SI.ENS($R$1:R5;">="&DATE(ANNEE(R5);MOIS(R5);1);$R$1:R5;"<"&DATE(ANNEE(R5);MOIS(R5)+1;1))=1;2,5;0)Dans la deuxième partie de la formule, je cherche s'il y a déjà une autre date dans la colonne R de la ligne 1 à la ligne en cours. Si c'est la première fois, on rajoute 2,5, sinon on rajoute 0.

    En espérant que cela réponde (un peu tard) à votre besoin.

    Bonne fin de journée

    Pierre Dumas

  3. #3
    Candidat au Club
    Homme Profil pro
    responsable d'ESMS
    Inscrit en
    septembre 2019
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 61
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : responsable d'ESMS
    Secteur : Santé

    Informations forums :
    Inscription : septembre 2019
    Messages : 8
    Points : 4
    Points
    4
    Par défaut
    Bonjour et merci Pierre,
    Et non ce n'est pas trop tard, il faut que je boucle mon dossier et il me manque cet élément.

    Je vais tester votre formule en l'adaptant à mon tableau.

    Je vous dirai ce qu'il en est

    Encore merci

    Jacques

  4. #4
    Candidat au Club
    Homme Profil pro
    responsable d'ESMS
    Inscrit en
    septembre 2019
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 61
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : responsable d'ESMS
    Secteur : Santé

    Informations forums :
    Inscription : septembre 2019
    Messages : 8
    Points : 4
    Points
    4
    Par défaut
    Il me reste encore quelques points à voir mais le code fonctionne bien
    Bonne journée
    A bientôt

Discussions similaires

  1. Afficher un message une seule fois dans une boucle infinie
    Par emulienfou dans le forum Langage
    Réponses: 3
    Dernier message: 24/02/2011, 14h12
  2. DBLink utilisable une seule fois dans une session donnée
    Par thatsallfunk dans le forum Administration
    Réponses: 1
    Dernier message: 22/05/2009, 11h01
  3. Réponses: 4
    Dernier message: 06/06/2008, 10h56
  4. Ma requete s'execute qu'une seule fois dans mon curseur
    Par remyescof dans le forum MS SQL Server
    Réponses: 5
    Dernier message: 21/03/2008, 09h03
  5. Ma requete s'execute qu'une seule fois dans mon curseur
    Par remyescof dans le forum Développement
    Réponses: 5
    Dernier message: 21/03/2008, 09h03

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo