Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Candidat au Club
    ajoutez une valeur une seule fois dans le mois
    Bonjour à tous,
    Je sèche sur une formule:
    =SI(Q5="";P5;P5-S5)+2,5


    ces cellules font références à des chiffres issus de calcul de dates de congés sur une base de 22 jours:
    05/10/2019 ; 23/10/2019 = 16 en P5 .... ce qui me donne un solde de 6 jours
    12/10/2019 ; 15/10/2019 = 3 en S5 ... ce qui me donne un solde de 3 jours
    Cela fonctionne très bien jusque là, les jours fériés et weekends sont bien décomptés etc..

    Maintenant, les 2 ,5 jours à ajouter ne sont acquis qu'une seule fois par mois, en effet, si j'entre plusieurs séquences de congés sur le même mois,, il y aura autant de fois 2,5 jours de plus que de dates posées.


    J'ai fait beaucoup de tentatives qui n'ont pas abouties

    Alors si vous avez une idée....
    Merci à tous

    Jack

  2. #2
    Membre éclairé
    Bonsoir

    Je suis parti sur la base que
    05/10/2019 est en N5
    23/10/2019 est en O5
    16 est en P5
    12/10/2019 est en Q5
    15/10/2019 est en R5
    3 est en S5
    que votre formule à améliorer est en T5
    il peut y avoir d'autres dates de Q2 à Q5
    qu'il s'agit de la même année dans la feuille
    qu'il s'agit du même salarié dans la feuille

    La formule que je vous propose en T5 est =SI(Q5="";P5;P5-S5)+SI(NB.SI.ENS($R$1:R5;">="&DATE(ANNEE(R5);MOIS(R5);1);$R$1:R5;"<"&DATE(ANNEE(R5);MOIS(R5)+1;1))=1;2,5;0)

    Dans la deuxième partie de la formule, je cherche s'il y a déjà une autre date dans la colonne R de la ligne 1 à la ligne en cours. Si c'est la première fois, on rajoute 2,5, sinon on rajoute 0.

    En espérant que cela réponde (un peu tard) à votre besoin.

    Bonne fin de journée

    Pierre Dumas
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  3. #3
    Candidat au Club
    Bonjour et merci Pierre,
    Et non ce n'est pas trop tard, il faut que je boucle mon dossier et il me manque cet élément.

    Je vais tester votre formule en l'adaptant à mon tableau.

    Je vous dirai ce qu'il en est

    Encore merci

    Jacques

  4. #4
    Candidat au Club
    Il me reste encore quelques points à voir mais le code fonctionne bien
    Bonne journée
    A bientôt

###raw>template_hook.ano_emploi###