Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Access Discussion :

Table liée avec bibliothèque AS400


Sujet :

Access

  1. #1
    Membre à l'essai
    Profil pro
    Inscrit en
    mai 2009
    Messages
    21
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2009
    Messages : 21
    Points : 12
    Points
    12
    Par défaut Table liée avec bibliothèque AS400
    Bonjour,

    Je cherche à lier une bibliothèque AS400 avec Access via ODBC

    Pour certaines bibliothèques, tout est ok mais sur la principale je rencontre le message suivant :

    Définition de champ "S2FON1" non valide dans la définition de l'index ou de la relation.
    Le champ "S2FON1" n'existe pas dans cette bibliothèque, seul le champ S2FONC existe.

    Lorsque je fais le lien dans excel, cela fonctionne bien.

    Une idée ?

  2. #2
    Expert éminent
    Avatar de tee_grandbois
    Homme Profil pro
    retraité mais encore activé
    Inscrit en
    novembre 2004
    Messages
    4 838
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 62
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : retraité mais encore activé

    Informations forums :
    Inscription : novembre 2004
    Messages : 4 838
    Points : 8 227
    Points
    8 227
    Par défaut
    bonsoir,
    difficile de répondre sans avoir au minimum sous les yeux la définition de la table externe: nom et type des champs, index et type des champs des index...
    Comme le message d'erreur l'indique, ce n'est pas un problème de champ mais d'index ou de relation.
    Donc vérifier du côté des index ...
    Quand on est derrière l'écran on n'a aucun clavier sous les mains ...

  3. #3
    Membre à l'essai
    Profil pro
    Inscrit en
    mai 2009
    Messages
    21
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2009
    Messages : 21
    Points : 12
    Points
    12
    Par défaut
    Bonjour,

    J'ai fouillé un peu et le champ en question apparaît dans un fichier logique (mais pas dans le physique) :
    Images attachées Images attachées   

  4. #4
    Expert éminent
    Avatar de tee_grandbois
    Homme Profil pro
    retraité mais encore activé
    Inscrit en
    novembre 2004
    Messages
    4 838
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 62
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : retraité mais encore activé

    Informations forums :
    Inscription : novembre 2004
    Messages : 4 838
    Points : 8 227
    Points
    8 227
    Par défaut
    bonjour,
    ne peux-tu pas essayer de faire l'attache avec une copie du fichier physique (donc sans fichier logique associé) pour voir si ce n'est pas cela qui coince ?
    Quand on est derrière l'écran on n'a aucun clavier sous les mains ...

Discussions similaires

  1. Réponses: 7
    Dernier message: 23/08/2006, 15h59
  2. Réponses: 2
    Dernier message: 02/08/2006, 10h25
  3. Table liée avec elle même
    Par jozzz dans le forum Access
    Réponses: 1
    Dernier message: 12/06/2006, 11h53
  4. [VB]Utiliser plusieurs table liées avec un contrôle Data
    Par yangoal25 dans le forum VB 6 et antérieur
    Réponses: 25
    Dernier message: 21/02/2006, 15h36
  5. requete sur 2 tables liées avec même nom de champs
    Par Australia dans le forum Access
    Réponses: 5
    Dernier message: 02/02/2006, 11h38

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo